バージョン選択

フォーラム

メニュー

オンライン状況

59 人のユーザが現在オンラインです。 (27 人のユーザが フォーラム を参照しています。)
登録ユーザ: 2
ゲスト: 57
AndER kuroaa もっと...

サイト内検索

バグ報告 > フロント機能 > IDを使った、注文番号のフォーマット(eccube_order_no_format )が動作しない

フロント機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
nonoichi
投稿日時: 2020/4/29 12:16
対応状況: −−−
新米
登録日: 2020/4/24
居住地:
投稿: 3
IDを使った、注文番号のフォーマット(eccube_order_no_format )が動作しない
[EC-CUBE] EC-CUBE4.0.3
[レンタルサーバ] Docker
[OS] macOS10.15.3
[PHP] php7.3
[データベース] MySQL5.6
[WEBサーバ] Apache
[ブラウザ] GoogleChrome81
[導入プラグインの有無] 無
[カスタマイズの有無] 無
[現象]
app/config/eccube/packages/eccube.yaml で以下の指定をしても、
IDが正しくセットされない。

eccube_order_no_format: {id,1}


$Order->getId() が「0」がセットされて処理が通ってしまう。


[改修案]

60行目に、以下の記載を追加し、
IDが「0」の場合は処理しないようにすれば、
$Order->getId()が正しく取得できたときに処理が通るようになり、
事象が解消できました。

if (!$Order->getId()) {
return;
}


app配下で処理をproxyする処理が大変なので、
コアに適用していただけますと助かります。
よろしくお願いいたします。
nyorai
投稿日時: 2020/5/11 10:03
対応状況: −−−
長老
登録日: 2015/8/21
居住地:
投稿: 294
Re: IDを使った、注文番号のフォーマット(eccube_order_no_format )が動作しない
こちらでしょうかね。
https://github.com/EC-CUBE/ec-cube/pull/4159

4.0.4で反映されるかと思います。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は63,571名です
総投稿数は96,798件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
468
2438
4
nanasess
2077
5
yuh
1612
6
umebius
1588
7
red
1406
8
h_tanaka
1022
9
fukap
907
10
tsuji
863
11
shutta
835
12
tao_s
792
13 ramrun 789
14 karin 657
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.