バージョン選択

フォーラム

メニュー

オンライン状況

72 人のユーザが現在オンラインです。 (53 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 72
もっと...

サイト内検索

質問 > フロント機能 > カレンダーブロックが表示されない

フロント機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
poporin
投稿日時: 2013/1/24 12:43
対応状況: −−−
常連
登録日: 2012/6/6
居住地:
投稿: 68
カレンダーブロックが表示されない
ECCUBE2.12.2を新規でインストールしサイト作成を
行っております。
なぜかカレンダーブロックだけが表示されません。

DEBUG_MODEをtrueにすると管理画面とカレンダーブロックが
表示されるはずの場所に下記のエラーがでます。

カレンダーブロックが表示されるはずの場所のエラー

Warning: Wrong parameter count for debug_backtrace() in /home/*****/public_html/data/class/util/GC_Utils.php on line 78

Warning: array_reverse() [function.array-reverse]: The argument should be an array in /home/*****/public_html/data/class/util/GC_Utils.php on line 81

Warning: Invalid argument supplied for foreach() in /home/*****/public_html/data/class/util/GC_Utils.php on line 81


管理画面上部でのエラー

Warning: Wrong parameter count for debug_backtrace() in /home/*****/public_html/data/class/util/GC_Utils.php on line 78

Warning: array_reverse() [function.array-reverse]: The argument should be an array in /home/*****/public_html/data/class/util/GC_Utils.php on line 81

Warning: Invalid argument supplied for foreach() in /home/*****/public_html/data/class/util/GC_Utils.php on line 81

Warning: Wrong parameter count for debug_backtrace() in /home/*****/public_html/data/class/util/GC_Utils.php on line 78

Warning: array_reverse() [function.array-reverse]: The argument should be an array in /home/*****/public_html/data/class/util/GC_Utils.php on line 81

Warning: Invalid argument supplied for foreach() in /home/*****/public_html/data/class/util/GC_Utils.php on line 81

Warning: Wrong parameter count for debug_backtrace() in /home/*****/public_html/data/class/util/GC_Utils.php on line 78

Warning: array_reverse() [function.array-reverse]: The argument should be an array in /home/*****/public_html/data/class/util/GC_Utils.php on line 81

Warning: Invalid argument supplied for foreach() in /home/*****/public_html/data/class/util/GC_Utils.php on line 81


過去ログを調べましたら、管理画面上のエラーは実害がなければfalseにしておけば良いとありましたが
カレンダーブロックは無いと困りますので、正常に表示されるにはどのように調べていくと良いでしょうか?

パーミッションの設定は、wadaxサーバーの指定通りで、フォルダが707 画像やcss、.tplなどは606なので、606で指定しています。

また、プラグインは今のところ1つもいれておりません。

気になる点としてdata/Smarty/templates/default/_packages というフォルダがありますが本件と関係がありますでしょうか?

どうかご教授お願い致します。



追記/data/logs/error.logに下記のような表示がありました。

2013/01/24 15:21:14 [/test/index.php] Warning(E_USER_WARNING): Smarty error: unable to read resource: "/home/*****/public_html/test/../data/Smarty/templates/default/frontparts/bloc/‘calendartpl’" on [/home/*****/public_html/data/module/Smarty/libs/Smarty.class.php(1093)] from **********
customer_id =

何かわかりますでしょうか?


ECCUBE 2.12.2

DB postgres 8.1.23

PHP 5.1.6

サーバー wadax 共用サーバー
fukap
投稿日時: 2013/1/24 14:24
対応状況: −−−
仙人
登録日: 2009/7/7
居住地: 滋賀県
投稿: 907
Re: カレンダーブロックが表示されない
data/class/util/GC_Utils.php の debug_backtrace() あたりでうまくいっていないようですね。

data/class/util/GC_Utils.php の 78行目で、
$arrBacktrace = debug_backtrace();
とするとどうなりますか?
poporin
投稿日時: 2013/1/24 17:23
対応状況: 確認中
常連
登録日: 2012/6/6
居住地:
投稿: 68
Re: カレンダーブロックが表示されない
お返事ありがとうございます。

ご指摘のところ78行目ですが、実際には82行目にありました。

$arrBacktrace = debug_backtrace(false); 変更前

$arrBacktrace = debug_backtrace();   変更後

debug_modeはtrueにしたままで記述をしました。

エラーの文面自体は消えましたがカレンダーブロックも消えてしまい
表示されていない状態です。

試しにカレンダーブロックの内容をコピーし、新規ブロックカレンダー2として作成し、配置しましたら、見出しの「カレンダー」の画像と「※赤字は休業日です」の文字だけ表示されました。

中身を引っ張ってこれていないような状態です。

何かわかりますでしょうか?

どうぞよろしくお願い致します。


fukap
投稿日時: 2013/1/24 17:48
対応状況: −−−
仙人
登録日: 2009/7/7
居住地: 滋賀県
投稿: 907
Re: カレンダーブロックが表示されない
カレンダーブロックが表示されない件に関しては、以下の点はどうでしょうか?

・html/frontparts/bloc/calendar.php のファイルが存在しているか。
・data/class_extends/page_extends/frontparts/bloc/LC_Page_FrontParts_Bloc_Calendar_Ex.php のファイルが存在しているか。
・data/class/pages/frontparts/bloc/LC_Page_FrontParts_Bloc_Calendar.php のファイルが存在しているか。
・data/Smarty/templates/default/frontparts/bloc/calendar/tpl のファイルは存在しているか。
・管理画面>デザイン管理>(端末名)>レイアウト設定 で、トップページ等でカレンダーブロックが未使用ブロックになっていないか。

多少、問題の切り分けになるかもしれません。
poporin
投稿日時: 2013/1/24 18:23
対応状況: −−−
常連
登録日: 2012/6/6
居住地:
投稿: 68
Re: カレンダーブロックが表示されない
どうもありがとうございます。

ご指摘頂いたファイルは全て存在しておりました。

管理画面を見ても、カレンダーブロックは未使用ブロックの枠には
無く、TOPページの部分に入っていました。

切り分けがなかなか難しい状態ですね・・・・。

本件と関係あるかはわかりませんが、気になる点が1つあります。

ファイルはFFFTPソフトを使ってアップロードしています。
例えば、calendar.tplの「所有権」を使用者(自分)にしてパーミッションを606に変更しました。そうこうしている内にいつのまにか所有権がマスター側(サーバー会社)になってしまいます。

こうなってしまうとパーミッションの変更が自分ではできなくなります。
昨日それに気づき、サーバー側で所有権を変更してもらいましたが
いつのまにかまた、サーバー側を示す数値に変わっています。

サーバー会社に修正してもらってからも、表示はされなかったので
関係はないかも知れませんが・・・。

何とか原因がつかめると良いのですが。

どうぞよろしくお願い致します。

fukap
投稿日時: 2013/1/24 19:22
対応状況: −−−
仙人
登録日: 2009/7/7
居住地: 滋賀県
投稿: 907
Re: カレンダーブロックが表示されない
パーミッションは、サーバー会社の仕様に合わせれば問題ないと思います。

あとは、data/module/Calendar/ 以下のディレクトリやファイルはアップロードできていますか?
poporin
投稿日時: 2013/1/24 19:43
対応状況: −−−
常連
登録日: 2012/6/6
居住地:
投稿: 68
Re: カレンダーブロックが表示されない
何度も申し訳ありません。

念のためファイルを今一度アップロード致しました。

結果としては変わらず、デフォルトのカレンダーブロックだと
何も表示されず、コピーしたカレンダー2ブロックだと見出し画像と
文字だけで、日付の部分は表示されない状態となっています。

お手上げ状態になってしまいました・・・。
poporin
投稿日時: 2013/1/24 22:58
対応状況: 解決済
常連
登録日: 2012/6/6
居住地:
投稿: 68
Re: カレンダーブロックが表示されない
fukap様

幾度もお付き合いくださいましてありがとうございました。

ファイルを再インストールすることで解決できましたので御報告
致します。

どうもありがとうございました。

今後ともどうぞよろしくお願いいたします。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は56,690名です
総投稿数は94,613件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
2024
4
468
1951
5
yuh
1611
6
umebius
1490
7
red
1379
8
h_tanaka
943
9
fukap
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
783
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.