バージョン選択

フォーラム

メニュー

オンライン状況

25 人のユーザが現在オンラインです。 (16 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 25
もっと...

PR

デザインテンプレート EC-CUBE3.0版が登場!
広告掲載について

サイト内検索

質問 > その他 > さくらVPSでEC-CUBE 3.0.13インストールできない

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
imbo
投稿日時: 2017/2/22 22:16
対応状況: −−−
新米
登録日: 2017/2/22
居住地:
投稿: 3
さくらVPSでEC-CUBE 3.0.13インストールできない
▼テンプレート
[EC-CUBE] EC-CUBE3.0.13、新規インストール
[レンタルサーバ] さくらVPS
[OS] CentOS 7.3.1611
[PHP] 7.0.16
[データベース] MySQL 5.7.17
[WEBサーバ] Apache 2.4.6
[ブラウザ] firefox 51.0.1
[導入プラグインの有無] 無
[カスタマイズの有無] 無
[現象] http://xxx.xxx.xxx.xxx/eccube/html/install.php にアクセスすると、下記のエラー表記が出ます。

Warning: require(/var/www/html/eccube/vendor/composer/../silex/silex/src/Silex/ControllerProviderInterface.php): failed to open stream: No such file or directory in /var/www/html/eccube/vendor/symfony/class-loader/ApcClassLoader.php on line 110

Fatal error: require(): Failed opening required '/var/www/html/eccube/vendor/composer/../silex/silex/src/Silex/ControllerProviderInterface.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/eccube/vendor/symfony/class-loader/ApcClassLoader.php on line 110



まったく初心者ですので、どこが問題なのか、教えて頂けますでしょうか。
よろしくお願いします。
aoki.u
投稿日時: 2017/2/22 22:41
対応状況: −−−
常連
登録日: 2017/2/19
居住地:
投稿: 44
Re: さくらVPSでEC-CUBE 3.0.13インストールできない
FTPなりSCPなりで全ファイル正しく転送されていないということはないでしょうか?

あるいは、ライブラリをcomposer installでインストールされたならそれが正しくインストールされていないということはないでしょうか。


----------------
エンジニアです!
ECCUBEのカスタマイズやプラグイン開発に専念しています。ご相談ください。

imbo
投稿日時: 2017/2/24 12:03
対応状況: −−−
新米
登録日: 2017/2/22
居住地:
投稿: 3
Re: さくらVPSでEC-CUBE 3.0.13インストールできない
ご回答いただきありがとうございます。

昨日VPS環境を確認したら、composerがインストールされていなかったです。急いでインストールしましたが、エラーが変わっていないです。
システム要件に記載されているライブラリは、全部composer installでもう一回インストールする必要でしょうか?

ご教授お願いします。
aoki.u
投稿日時: 2017/2/24 12:32
対応状況: −−−
常連
登録日: 2017/2/19
居住地:
投稿: 44
Re: さくらVPSでEC-CUBE 3.0.13インストールできない

EC-CUBEを配置したディレクトリに移動してcomposer installいうコマンドを叩けば必要なライブラリは全てインストールされると思います。


----------------
エンジニアです!
ECCUBEのカスタマイズやプラグイン開発に専念しています。ご相談ください。

aoki.u
投稿日時: 2017/2/24 12:34
対応状況: −−−
常連
登録日: 2017/2/19
居住地:
投稿: 44
Re: さくらVPSでEC-CUBE 3.0.13インストールできない
といいますか、最初にcomposerでインストールしたわけではないなら、方法はなんでも大丈夫ですよ。/vendor以下のファイル等、全ておう1度転送しなおしてみてはいかがでしょうか。
imbo
投稿日時: 2017/2/24 19:03
対応状況: −−−
新米
登録日: 2017/2/22
居住地:
投稿: 3
Re: さくらVPSでEC-CUBE 3.0.13インストールできない
ご教授頂きありがとうございます。

EC-CUBEを配置したディレクトリで、composer installを実行してみて、エラー表示が減りました。

今度、下記のエラー表示だけが残っています。
Fatal error: Interface 'Silex\ControllerProviderInterface' not found in /var/www/html/eccube/src/Eccube/ControllerProvider/InstallControllerProvider.php on line 30

468
投稿日時: 2017/3/2 9:29
対応状況: −−−
仙人
登録日: 2008/10/26
居住地:
投稿: 402
Re: さくらVPSでEC-CUBE 3.0.13インストールできない
無理にcomposerを利用する必要は無いと思いますので、
配布されているインストールパッケージの中身をもう一度配置し直してみては如何でしょうか?
さくらVPSを利用していますが、ECCUBE3は特に問題無く動作しています。


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
■360°画像ビューワーimg360
■ECCUBE技術資料blog

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ

 

ログイン


EC-CUBEペイメント

統計情報

総メンバー数は19,116名です
総投稿数は79,891件です

投稿数ランキング

1
seasoft
7331
2
AMUAMU
2712
3
nanasess
1618
4
yuh
1313
5
red
1027
6
fukap
907
7
shutta
827
8 ramrun 789
9
tsuji
778
10
tao_s
646


ネットショップの壺

EC-CUBEガイドブック
Copyright© LOCKON CO.,LTD. All Rights Reserved.