バージョン選択

フォーラム

メニュー

オンライン状況

40 人のユーザが現在オンラインです。 (29 人のユーザが フォーラム を参照しています。)
登録ユーザ: 3
ゲスト: 37
red umebius 468 もっと...

サイト内検索

質問 > その他 > 【v4.x】API使用について

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
yamada1221
投稿日時: 2019/1/9 12:03
対応状況: −−−
新米
登録日: 2019/1/9
居住地:
投稿: 2
【v4.x】API使用について
EC-CUBE4.xでAPIは使用可能でしょうか。


EC-CUBE4.0特設サイトを見る限りは「拡張API」とあるので使用可能なのかなともいましたが、、
https://www.ec-cube.net/product/4.0/

「EC-CUBE API β版プラグイン」を見る限りは3.x系の対応のみなのかなと思いました。
https://www.ec-cube.net/products/detail.php?product_id=1116

また、β版の場合はいつ頃に製品版となる予定でしょうか。
開発方針(http://doc.ec-cube.net/api_policy)には記載が見当たりませんでした。

ご回答いただけると幸いです。
nanasess
投稿日時: 2019/1/10 11:15
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1878
Re: 【v4.x】API使用について
おそらく、 Web 経由でアクセス可能な RESTful API のことを想定されていると思いますが、こちらは 4.x にはまだ実装されていません。

引用:

EC-CUBE4.0特設サイトを見る限りは「拡張API」とあるので使用可能なのかなともいましたが、、


この拡張APIは、内部で利用しているAPI(WebAPIではない)を拡張するための仕組みを差しています。


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
有限会社 Loop AZ

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

yamada1221
投稿日時: 2019/1/10 14:37
対応状況: 解決済
新米
登録日: 2019/1/9
居住地:
投稿: 2
Re: 【v4.x】API使用について
わかりにくい表現でお手を煩わせてしまい申し訳ございません。
ご回答ありがとうございます。
承知しました。

では当面はRESTful APIを使いたい場合は3.xを使うしかないですね。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

統計情報

総メンバー数は40,621名です
総投稿数は90,023件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1878
4
468
1569
5
yuh
1568
6
red
1212
7
umebius
1083
8
fukap
907
9
tsuji
837
10
shutta
827
11 ramrun 789
12
tao_s
691
13 karin 656
14
h_tanaka
651
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© LOCKON CO.,LTD. All Rights Reserved.