バージョン選択

フォーラム

メニュー

オンライン状況

44 人のユーザが現在オンラインです。 (31 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 44
もっと...

サイト内検索

質問 > その他 > EC-CUBE4.0.1で、インストールに辿り着けません。

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
YKazu0405
投稿日時: 2019/1/9 14:57
対応状況: −−−
新米
登録日: 2018/11/12
居住地:
投稿: 7
EC-CUBE4.0.1で、インストールに辿り着けません。
▼テンプレート
[EC-CUBE] EC-CUBE4.1、新規インストール
[レンタルサーバ]GMOクラウド
[OS]CentOS Linux release 7.6.1810 (Core)
[PHP]PHP 7.3.0
[データベース]MariaDB-compat-10.3.11-1.el7.centos.x86_64
[WEBサーバ]Apache/2.4.6 (CentOS)
[現象]
学習用にと、クラウドのサーバーを一つレンタルしました。試用期間終了後、一度つぶすつもりなので、IPのまま設定してあります。

http://153.122.20.247/test.php

ではPHPが正常動作していますし、

http://153.122.20.247/wordpress/
とWordPressをインストールした限りでは正常に動作しています。このため、データベースの稼働などには問題がないと思います。

しかし、eccube-4.0.1.zip をunzipした

http://153.122.20.247/eccube

をブラウザからリクエストすると、エラーになってしまいます。
こちらでエラーメッセージのいくつかを検索しましたが、このエラーはすぐに発生するので、検索結果の状況と合致せず、理由がわからないでおります。

ECCUBEをインストールする環境として、サーバーにApacheとPHP、mysql系のデータベースの他、何か必要なものがありますでしょうか?

なにかヒントになるような事がありましたら、ご教示いただけると助かります。

よろしくお願いいたします。
468
投稿日時: 2019/1/9 19:40
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1391
Re: EC-CUBE4.0.1で、インストールに辿り着けません。
具体的にどのようなエラーが発生しているのでしょうか?
私はphp7.3の環境でeccube4を動作させた事がないのですが、正常に動くのでしょうか?


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

YKazu0405
投稿日時: 2019/1/9 19:45
対応状況: −−−
新米
登録日: 2018/11/12
居住地:
投稿: 7
Re: EC-CUBE4.0.1で、インストールに辿り着けません。
失礼しました。

http://153.122.20.247/eccube/

でそのまま表示されますが、テキストをコピーすると下記のようになります。

Whoops, looks like something went wrong.
(2/2) FileLoaderLoadException
Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /var/www/html/eccube/app/config/eccube/services.yaml (which is loaded in resource "/var/www/html/eccube/app/config/eccube/services.yaml").

in FileLoader.php line 168
at FileLoader->doImport('/var/www/html/eccube/app/config/eccube/services.yaml', null, false, null)
in FileLoader.php line 90
at FileLoader->import('/var/www/html/eccube/app/config/eccube/services.yaml')
in GlobFileLoader.php line 27
at GlobFileLoader->load('/var/www/html/eccube/app/config/eccube/services.{php,xml,yaml,yml}', 'glob')
in DelegatingLoader.php line 40
at DelegatingLoader->load('/var/www/html/eccube/app/config/eccube/services.{php,xml,yaml,yml}', 'glob')
in Kernel.php line 119
at Kernel->configureContainer(object(ContainerBuilder), object(DelegatingLoader))
in MicroKernelTrait.php line 80
at Kernel->Symfony\Bundle\FrameworkBundle\Kernel\{closure}(object(ContainerBuilder))
in ClosureLoader.php line 38
at ClosureLoader->load(object(Closure), null)
in DelegatingLoader.php line 40
at DelegatingLoader->load(object(Closure))
in MicroKernelTrait.php line 83
at Kernel->registerContainerConfiguration(object(DelegatingLoader))
in Kernel.php line 774
at Kernel->buildContainer()
in Kernel.php line 640
at Kernel->initializeContainer()
in Kernel.php line 135
at Kernel->boot()
in Kernel.php line 89
at Kernel->boot()
in Kernel.php line 195
at Kernel->handle(object(Request))
in index.php line 74
(1/2) ContextErrorException
Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

in tcpdf.php line 17786
at ErrorHandler->handleError(2, '"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?', '/var/www/html/eccube/vendor/tecnickcom/tcpdf/tcpdf.php', 17786)
in Kernel.php line 609
at Kernel->Symfony\Component\HttpKernel\{closure}(2, '"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?', '/var/www/html/eccube/vendor/tecnickcom/tcpdf/tcpdf.php', 17786, array('class' => 'TCPDF', 'e' => 32767, 'file' => '/var/www/html/eccube/vendor/composer/../tecnickcom/tcpdf/tcpdf.php', 'wasCached' => false))
in DebugClassLoader.php line 146
at require()
in DebugClassLoader.php line 146
at DebugClassLoader->loadClass('TCPDF')
at spl_autoload_call('TCPDF')
in TcpdfFpdi.php line 30
at require('/var/www/html/eccube/vendor/setasign/fpdi/src/TcpdfFpdi.php')
in DebugClassLoader.php line 146
at DebugClassLoader->loadClass('setasign\\Fpdi\\TcpdfFpdi')
at spl_autoload_call('setasign\\Fpdi\\TcpdfFpdi')
in OrderPdfService.php line 31
at require('/var/www/html/eccube/src/Eccube/Service/OrderPdfService.php')
in DebugClassLoader.php line 146
at DebugClassLoader->loadClass('Eccube\\Service\\OrderPdfService')
at spl_autoload_call('Eccube\\Service\\OrderPdfService')
at class_exists('Eccube\\Service\\OrderPdfService')
in ClassExistenceResource.php line 78
at ClassExistenceResource->isFresh(0)
in ContainerBuilder.php line 369
at ContainerBuilder->getReflectionClass('Eccube\\Service\\OrderPdfService')
in FileLoader.php line 149
at FileLoader->findClasses('Eccube\\', '../../../src/Eccube/*', '../../../src/Eccube/{Annotation,Common,Entity,Exception,Log,Plugin,ServiceProvider,Resource,Doctrine/ORM/tools/}')
in FileLoader.php line 57
at FileLoader->registerClasses(object(Definition), 'Eccube\\', '../../../src/Eccube/*', '../../../src/Eccube/{Annotation,Common,Entity,Exception,Log,Plugin,ServiceProvider,Resource,Doctrine/ORM/tools/}')
in YamlFileLoader.php line 584
at YamlFileLoader->parseDefinition('Eccube\\', array('resource' => '../../../src/Eccube/*', 'exclude' => '../../../src/Eccube/{Annotation,Common,Entity,Exception,Log,Plugin,ServiceProvider,Resource,Doctrine/ORM/tools/}'), '/var/www/html/eccube/app/config/eccube/services.yaml', array('autowire' => true, 'autoconfigure' => true, 'public' => false, 'bind' => array('$cartPurchaseFlow' => object(BoundArgument), '$shoppingPurchaseFlow' => object(BoundArgument), '$orderPurchaseFlow' => object(BoundArgument), '$_orderStateMachine' => object(BoundArgument))))
in YamlFileLoader.php line 239
at YamlFileLoader->parseDefinitions(array('parameters' => array('container.dumper.inline_class_loader' => true, 'env(ECCUBE_LOCALE)' => 'ja', 'env(ECCUBE_TIMEZONE)' => 'Asia/Tokyo', 'env(ECCUBE_CURRENCY)' => 'JPY', 'locale' => '%env(ECCUBE_LOCALE)%', 'timezone' => '%env(ECCUBE_TIMEZONE)%', 'currency' => '%env(ECCUBE_CURRENCY)%'), 'services' => array('Eccube\' => array('resource' => '../../../src/Eccube/*', 'exclude' => '../../../src/Eccube/{Annotation,Common,Entity,Exception,Log,Plugin,ServiceProvider,Resource,Doctrine/ORM/tools/}'), 'Eccube\Common\EccubeConfig' => array('public' => true), 'Eccube\Service\TaxRuleService' => array('lazy' => true, 'public' => true), 'Eccube\Service\CartService' => array('lazy' => true), 'Eccube\Service\SystemService' => array('lazy' => true, 'public' => true), 'Eccube\Service\Composer\ComposerProcessService' => array('lazy' => true), 'Eccube\Service\Composer\ComposerServiceInterface' => array('factory' => array('Eccube\\Service\\Composer\\ComposerServiceFactory', 'createService')), 'Eccube\Controller\' => array('resource' => '../../../src/Eccube/Controller', 'tags' => array('controller.service_arguments')), 'Eccube\Twig\Extension\EccubeBlockExtension' => array('tags' => array('twig.extension'), 'bind' => array('$blockTemplates' => '%eccube_twig_block_templates%')), 'Plugin\' => array('resource' => '../../../app/Plugin/*', 'exclude' => '../../../app/Plugin/*/{Entity,Resource,ServiceProvider,Tests,DoctrineMigrations}'), 'Customize\' => array('resource' => '../../../app/Customize/*', 'exclude' => '../../../app/Customize/{Entity,Resource,Tests}'), 'Customize\Controller\' => array('resource' => '../../../app/Customize/Controller', 'tags' => array('controller.service_arguments')), 'twig.extension.stringloader' => array('class' => 'Twig_Extension_StringLoader', 'tags' => array('twig.extension')), 'eccube.collector.core' => array('class' => 'Eccube\\DataCollector\\EccubeDataCollector', 'tags' => array(array('name' => 'data_collector', 'template' => '@toolbar/eccube.html.twig', 'id' => 'eccube_core', 'priority' => -512))), 'eccube.security.success_handler' => array('class' => 'Eccube\\Security\\Http\\Authentication\\EccubeAuthenticationSuccessHandler'), 'eccube.security.failure_handler' => array('class' => 'Eccube\\Security\\Http\\Authentication\\EccubeAuthenticationFailureHandler'), 'eccube.logger' => array('class' => 'Eccube\\Log\\Logger', 'arguments' => array('@Eccube\\Request\\Context', '@monolog.logger', '@monolog.logger.front', '@monolog.logger.admin'), 'lazy' => true, 'public' => true), 'eccube.log.formatter.line' => array('class' => 'Monolog\\Formatter\\LineFormatter', 'arguments' => array('[%%datetime%%] %%channel%%.%%level_name%% [%%extra.session_id%%] [%%extra.uid%%] [%%extra.user_id%%] [%%extra.class%%:%%extra.function%%:%%extra.line%%] - %%message%% %%context%% [%%extra.http_method%%, %%extra.url%%, %%extra.ip%%, %%extra.referrer%%, %%extra.user_agent%%]')), 'Eccube\Log\Processor\SessionProcessor' => array('tags' => array(array('name' => 'monolog.processor'))), 'Eccube\Log\Processor\TokenProcessor' => array('tags' => array(array('name' => 'monolog.processor'))), 'Monolog\Processor\UidProcessor' => array('tags' => array(array('name' => 'monolog.processor'))), 'Monolog\Processor\IntrospectionProcessor' => array('arguments' => array('!php/const:Monolog\\Logger::DEBUG', array('Eccube\\\\Log', 'Psr\\\\Log')), 'tags' => array(array('name' => 'monolog.processor'))), 'Symfony\Bridge\Monolog\Processor\WebProcessor' => array('arguments' => array(array('url' => 'REQUEST_URI', 'ip' => 'REMOTE_ADDR', 'http_method' => 'REQUEST_METHOD', 'server' => 'SERVER_NAME', 'referrer' => 'HTTP_REFERER', 'user_agent' => 'HTTP_USER_AGENT')), 'tags' => array(array('name' => 'monolog.processor'), array('name' => 'kernel.event_listener', 'event' => 'kernel.request', 'priority' => 1024))), 'Symfony\Component\HttpFoundation\ParameterBag' => null, 'Eccube\Twig\Extension\IgnoreRoutingNotFoundExtension' => array('autoconfigure' => false))), '/var/www/html/eccube/app/config/eccube/services.yaml')
in YamlFileLoader.php line 148
at YamlFileLoader->load('/var/www/html/eccube/app/config/eccube/services.yaml', null)
in FileLoader.php line 153
at FileLoader->doImport('/var/www/html/eccube/app/config/eccube/services.yaml', null, false, null)
in FileLoader.php line 90
at FileLoader->import('/var/www/html/eccube/app/config/eccube/services.yaml')
in GlobFileLoader.php line 27
at GlobFileLoader->load('/var/www/html/eccube/app/config/eccube/services.{php,xml,yaml,yml}', 'glob')
in DelegatingLoader.php line 40
at DelegatingLoader->load('/var/www/html/eccube/app/config/eccube/services.{php,xml,yaml,yml}', 'glob')
in Kernel.php line 119
at Kernel->configureContainer(object(ContainerBuilder), object(DelegatingLoader))
in MicroKernelTrait.php line 80
at Kernel->Symfony\Bundle\FrameworkBundle\Kernel\{closure}(object(ContainerBuilder))
in ClosureLoader.php line 38
at ClosureLoader->load(object(Closure), null)
in DelegatingLoader.php line 40
at DelegatingLoader->load(object(Closure))
in MicroKernelTrait.php line 83
at Kernel->registerContainerConfiguration(object(DelegatingLoader))
in Kernel.php line 774
at Kernel->buildContainer()
in Kernel.php line 640
at Kernel->initializeContainer()
in Kernel.php line 135
at Kernel->boot()
in Kernel.php line 89
at Kernel->boot()
in Kernel.php line 195
at Kernel->handle(object(Request))
in index.php line 74
468
投稿日時: 2019/1/9 20:16
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1391
Re: EC-CUBE4.0.1で、インストールに辿り着けません。
PHP7.3では、switch構文内でcontinueを利用するとWarningが発生するようになったようですので、
その変更に引っかかっているのではないでしょうか?
(7.3未満は、switch構文内でcontinueはbreakと同等に扱われているようです)

ログを見る限りでは、
/var/www/html/eccube/vendor/tecnickcom/tcpdf/tcpdf.php
のファイルが怪しいようです。
ECCUBE4が利用しているライブラリ自体がPHP7.3に対応できていないと思われます。


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

YKazu0405
投稿日時: 2019/1/10 9:02
対応状況: −−−
新米
登録日: 2018/11/12
居住地:
投稿: 7
Re: EC-CUBE4.0.1で、インストールに辿り着けません。
ありがとうございます。
「新しいPHPでは動かない」というのは少々衝撃でしたが、解決のヒントになりました。

yum remove php php-*
で今のPHPを全削除し、

yum -y install --enablerepo=remi,remi-php72 php php-mbstring php-xml php-xmlrpc php-gd php-pdo php-pecl-mcrypt php-mysqlnd php-pecl-mysql

にて、PHPを7.2にバージョンダウンしました。

PHP 7.2.14 (cli)

にしたところ、
http://153.122.20.247/test.php

で無事にPHPの動作が確認できたため、

http://153.122.20.247/eccube/

を起動したところ、インストーラーが起動しました。

zipとintlが不足しているというエラーは出ましたが

yum -y install --enablerepo=remi,remi-php72 php-pecl-zip php-intl

にてインストール後、Apacheを再起動したところ、エラーも消えました。

ありがとうございました。
yukim
投稿日時: 2019/1/10 13:31
対応状況: 解決済
新米
登録日: 2019/1/8
居住地:
投稿: 6
Re: EC-CUBE4.0.1で、インストールに辿り着けません。
EC CUBE自体のバージョンが最新のPHPに対応していないのではなく、依存ライブラリーが対応していないという状況ですので、これは外部ライブラリーを使う以上はしょうがない問題だと思われます。
YKazu0405
投稿日時: 2019/1/10 18:41
対応状況: 解決済
新米
登録日: 2018/11/12
居住地:
投稿: 7
Re: EC-CUBE4.0.1で、インストールに辿り着けません。
ありがとうございました。

了解です。今後は稼働バージョンをよく確認してインストールしたいと思います。

現在はバージョンダウンした7.2で正常動作しています。

設定は少々手間ではありますが、VPSですので、バージョンなどは自由に選べるのが今回功を奏しました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

統計情報

総メンバー数は37,862名です
総投稿数は88,921件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1865
4
yuh
1545
5
468
1391
6
red
1205
7
umebius
1007
8
fukap
907
9
shutta
827
10
tsuji
815
11 ramrun 789
12
tao_s
667
13 karin 656
14 sumida 641
15
h_tanaka
634
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© LOCKON CO.,LTD. All Rights Reserved.