バージョン選択

フォーラム

メニュー

オンライン状況

62 人のユーザが現在オンラインです。 (43 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 62
もっと...

サイト内検索

プラグイン > その他 > ソニーペイメントサービス。決済時にシステムエラー

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
adafsa
投稿日時: 2019/2/25 11:32
対応状況: 解決済
半人前
登録日: 2019/2/6
居住地:
投稿: 16
ソニーペイメントサービス。決済時にシステムエラー
▼テンプレート
[EC-CUBE] EC-CUBE3.016、新規インストール
[レンタルサーバ]NTTコミュニケーションズMAIL&WEB BUSINESS LITE
[OS] Linux 3.10.0-693.17.1.el7.x86_64
[PHP] 5.6.32
[データベース] MySQL 5.1.73
[WEBサーバ] Apache
[ブラウザ] chrome
[導入プラグインの有無] ソニーペイメントサービス
[カスタマイズの有無] 無し
[cURL] 7.19.7
[現象]

ソニーペイメントサービスの決済を行うと、
「決済モジュールの通信エラーが発生しました。詳しくは管理者にご連絡してください。」
表示される。

ソースを追うと、
Guzzle\Http\Clientのsend()コマンドにて、
PHP cHTML(35) SSL connect error
が発生してしまいます。

恐らくは、サーバ側の問題だと思いますが、何かアドバイスいただけませんでしょうか?

・試した事

$curlOptionsのCURLOPT_SSLVERSION に0から6まで試行するが変わらず。

サーバを変え、cURLバージョンが7.41.0のサーバだと問題なく動作します。
468
投稿日時: 2019/2/25 12:46
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1818
Re: ソニーペイメントサービス。決済時にシステムエラー
cURLが利用するSSL Versionはどのようになっているのでしょうか?


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

adafsa
投稿日時: 2019/2/25 17:07
対応状況: −−−
半人前
登録日: 2019/2/6
居住地:
投稿: 16
Re: ソニーペイメントサービス。決済時にシステムエラー
ご回答ありがとうございます。

SSL VersionはTLS1.2です。

該当サーバでは有効性を確認しております。
宜しくお願い致します。
yukim
投稿日時: 2019/2/25 20:22
対応状況: −−−
半人前
登録日: 2019/1/8
居住地:
投稿: 11
Re: ソニーペイメントサービス。決済時にシステムエラー
「決済モジュールの通信エラーが発生しました。詳しくは管理者にご連絡してください。」という内容のエラーですが、IPアドレスの登録などソニーペイメント側の設定画面で入力が必要な項目は全て入力済みでしょうか?
特にグローバルIPを入力漏れされる方が多いため、そちらを一旦ご確認頂けましたら幸いです。
adafsa
投稿日時: 2019/2/25 23:27
対応状況: −−−
半人前
登録日: 2019/2/6
居住地:
投稿: 16
Re: ソニーペイメントサービス。決済時にシステムエラー
アドバイスありがとうございます。

設定項目自体はソニーペイメントにも確認して頂いており、問題ないと考えております。

よろしくお願いいたします。
468
投稿日時: 2019/2/26 8:47
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1818
Re: ソニーペイメントサービス。決済時にシステムエラー
cURLコマンドのオプションにある--tlsv1.2がcURL7.34.0以降で追加された機能のようですが、その辺りが関係あるのでしょうか?

もしくはcURLが利用するSSLがNSSになっていて、そのNSSがTLS1.2に対応していないという可能性はありませんか?
(NSSは3.19.1-6以降にTLS1.2に対応)


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

adafsa
投稿日時: 2019/2/26 9:36
対応状況: −−−
半人前
登録日: 2019/2/6
居住地:
投稿: 16
Re: ソニーペイメントサービス。決済時にシステムエラー
ありがとうございます。

cURLのバージョンは7.19.7になっています。
オプションでTLS1.2を指定していますが、
これが無効になっているという事になりますでしょうか?

併せて、SSLはNSS 3.16になっていました。
これが問題でしょうか。

"version_number" => 463623
"age" => 3
"features" => 1597
"ssl_version_number" => 0
"version" => "7.19.7"
"host" => "x86_64-redhat-linux-gnu"
"ssl_version" => "NSS/3.16.2.3 Basic ECC"
"libz_version" => "1.2.3"

であれば、サーバ側でバージョンアップができないと利用は無理と言う事になりますかね・・・。
468
投稿日時: 2019/2/26 9:51
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1818
Re: ソニーペイメントサービス。決済時にシステムエラー
NSS/3.16.2.3 Basic ECC

ここが3.19.1-6以降でないとtls1.2で通信できないようです。
yumコマンドが利用できるサーバであれば、updateすれば問題が解決するそうですが、
そういった権限のないサーバでは利用は難しそうですね。


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

adafsa
投稿日時: 2019/2/26 10:06
対応状況: 解決済
半人前
登録日: 2019/2/6
居住地:
投稿: 16
Re: ソニーペイメントサービス。決済時にシステムエラー
ありがとうございます。
何が原因かわからず困り果てていました。

原因がつかめたので次の対策に移る事ができました。
大変助かりました。
ありがとうございました!
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

ec-cube.co

統計情報

総メンバー数は49,270名です
総投稿数は93,147件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1964
4
468
1818
5
yuh
1601
6
red
1342
7
umebius
1296
8
fukap
907
9
h_tanaka
905
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
758
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.