バージョン選択

フォーラム

メニュー

オンライン状況

44 人のユーザが現在オンラインです。 (30 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 44
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > EC-CUBE4 プラグインの有効化・インストールができません。

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 古いものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
minny
投稿日時: 2019/3/14 17:10
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 44
Re: EC-CUBE4 プラグインの有効化・インストールができません。
Rights様

ご報告ありがとうございます。

>memory_limit = 512M
>max_execution_time = 180
>xdebugが有効になっている -> xdebugを無効にして解消

こちらについて、php.iniの変更ができないようでしたので、
htaccessで変更しました。

phpinfo();で確認したところ変更されていましたが、やはりインストール途中(半分くらい)でエラーになってしまいます。

>php(Ver7)を、デフォルトのモジュール版からcgi版に変更した事。
こちらにしましては、先ほど変更したところ
プラグイン詳細画面まで進めない状況から、インストールボタンが押せる状況まで進みました。

ヘテムルで設定可能な memory_limit について、
上限は「128MB」で、この値を超過して動作することができないようです。

phpinfoでmemory_limit = 512Mとなっていても実際には128MBでうごいているということになるのでしょうか。

プラグインインストール時のログは以下の内容でした。
この状態で有効化できない状態です。

--

<warning>Deprecation warning: require.ec-cube/Maker4 is invalid, it should not contain uppercase characters. Please use ec-cube/maker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>
[156.3MiB/1.58s] Using version ^4.0 for ec-cube/Maker4
[156.3MiB/1.58s] ./composer.json has been updated
[156.7MiB/1.66s] <warning>Deprecation warning: require.ec-cube/Maker4 is invalid, it should not contain uppercase characters. Please use ec-cube/maker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[156.7MiB/1.66s] <warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[156.7MiB/1.66s] <warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>
[160.6MiB/1.86s] <warning>Dependency "ec-cube/plugin-installer" is also a root requirement, but is not explicitly whitelisted. Ignoring.</warning>
[160.4MiB/1.86s] Loading composer repositories with package information
[161.0MiB/2.65s] Updating dependencies (including require-dev)
[512.5MiB/9.64s] Nothing to install or update
[482.9MiB/9.68s] <warning>Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.</warning>
[482.9MiB/9.68s] <warning>Package symfony/lts is abandoned, you should avoid using it. Use symfony/flex instead.</warning>
[483.6MiB/9.69s] Generating optimized autoload files
[485.5MiB/11.06s] Memory usage: 485.52MiB (peak: 544.59MiB), time: 11.06s
完了

--

サーバーを変えるご提案について、IDCF Cloudでしたら可能のようですが、こちらのサーバーはどうなのかお分かりになる方いらっしゃいますでしょうか・・?
Rights
投稿日時: 2019/3/14 16:45
対応状況: −−−
一人前
登録日: 2019/3/12
居住地:
投稿: 98
Re: EC-CUBE4 プラグインの有効化・インストールができません。
有料プラグインインストールの件、解決しましたのでご報告を、

再度、オーナーズストアから新規追加を行い、導入しようとしたプラグインを検索して表示したところ、インストールが選択でき、インストール>有効化ができました。

ただ、この手順を確認する前に、サーバー側の php.ini の
memory_limit = 512M
max_execution_time = 180
に変更(元々はサーバーのデフォルト設定で利用)した事。

php(Ver7)を、デフォルトのモジュール版からcgi版に変更した事。
(最終的に、元のモジュール版に戻しました)

php.ini の設定を変えたことで解決したのか、順を追って確認しなかったため、切り分けができませんでした。

申し訳ありません。

※一部の導入済みプラグインのサムネイル画像が No Image になった状態は、変わりありません。
minny
投稿日時: 2019/3/14 16:37
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 44
Re: EC-CUBE4 プラグインの有効化・インストールができません。
Ringo様

sshで接続し、unzipできました。
ですが、プラグインをインストールできないのは解決できておりません。

phpを7.1(モジュール版)から7.1(CGI版)に変更したところ、
管理画面からプラグイン詳細まで進めるようになり、インストールの途中でエラーになるようになりました。
minny
投稿日時: 2019/3/14 15:59
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 44
Re: EC-CUBE4 プラグインの有効化・インストールができません。
phpを7.1(モジュール版)から7.1(CGI版)に変更してみたところ、
管理画面 プラグイン プラグインを探すから【入手する】ボタンが押せるようになり、詳細画面からインストールボタンも押せるようになした。
ですが、その後インストールが途中で止まってしまい、システムエラーとなります。
何度試しても同じ動きになります。

エラーログは以下です。

[2019-03-14 15:48:53] app.INFO [N/A] [4192e51] [1] [Eccube\Log\Logger:log:68] - PROCESS END ["admin_store_plugin"] [GET, /●●/●●/store/plugin, 126.243.68.194, http://●●.jp/●●/●●/store/plugin/api/install/1758/confirm, Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36]
minny
投稿日時: 2019/3/14 15:38
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 44
Re: EC-CUBE4 プラグインの有効化・インストールができません。
Rights様

コメントありがとうございます。
微妙に現象がちがうのですね。

試しにGitHubからDLしたデータを独自プラグインのアップロードからアップしてみたところ以下のエラーが出ました。

/var/cache/prod/Plugin/d9f60cd98a678425d8f7a1c086f038070001b377/composer.json not found.
Rights
投稿日時: 2019/3/14 15:26
対応状況: −−−
一人前
登録日: 2019/3/12
居住地:
投稿: 98
Re: EC-CUBE4 プラグインの有効化・インストールができません。
こちらでは、一覧にプラグインの表示は出ますが、操作するためのボタンが表示されないため、インストールするされない(できない)状態です。
minny
投稿日時: 2019/3/14 15:17
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 44
Re: EC-CUBE4 プラグインの有効化・インストールができません。
nyorai様

コメントありがとうございます。

memory_limitが128M -> memory_limitを512M
こちらは只今確認中です。

xdebugは、色々検索してみたのですがわかりませんでした。

その他はクリアしていました。
minny
投稿日時: 2019/3/14 15:12
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 44
Re: EC-CUBE4 プラグインの有効化・インストールができません。
468様

ご助言ありがとうございます。
EC-CUBE3では、x-serverやロリポップなどでもこのようなエラーはなかったので、疑問に思っています。

商品を削除できない現象については、WAFをOFFにすることで解決できました。

1点memory_limitが128Mだったのでこちらは、変更できないかどうか確認しております。
468
投稿日時: 2019/3/14 14:56
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 3217
Re: EC-CUBE4 プラグインの有効化・インストールができません。
VPSやAWSのようなroot権限有りのサービスは自由度が高い代わりに
ミドルウェアのインストールや設定を自分達で行う必要があり、それはそれで中々ハードルが高いのではないでしょうか?

eccubeを手軽に利用できるようにするには、この問題は原因をしっかりと調べて対処した方がよいかと思います。
とは言え、私も現象の再現する環境が用意出来ておらず、
調査は出来ていないのですが…


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

nyorai
投稿日時: 2019/3/14 14:01
対応状況: −−−
仙人
登録日: 2015/8/21
居住地:
投稿: 302
Re: EC-CUBE4 プラグインの有効化・インストールができません。
以前PHPの設定が原因でプラグインがインストールできない事象がありました。
以下の内容は参考になりますでしょうか?

https://github.com/EC-CUBE/ec-cube/issues/3990
« 1 (2) 3 4 »
スレッド表示 | 古いものから 前のトピック | 次のトピック | トップ


 



ログイン



統計情報

総メンバー数は76,865名です
総投稿数は105,255件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2275
5
umebius
2085
6
yuh
1669
7
red
1556
8
h_tanaka
1195
9
tsuji
944
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.