バージョン選択

フォーラム

メニュー

オンライン状況

94 人のユーザが現在オンラインです。 (64 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 93
kokokoon もっと...

サイト内検索

プラグイン > その他 > プラグインのインストールが出来ません。

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
mav1224
投稿日時: 2019/7/3 15:40
対応状況: −−−
新米
登録日: 2019/6/20
居住地:
投稿: 7
プラグインのインストールが出来ません。

[EC-CUBE] 4.0
[レンタルサーバ] 使えるねっと
[PHP] 7.3.6
[現象]
公式サイトのストアより購入済み。
サイト登録も済ませ、EC-CUBEに認証キーも入力済みです。

プラグインをインストールしようとしていますが、[オーナーズストア]→[プラグイン]→[プラグイン一覧]にインストールボタン(?)らしきものが見当たりません。

こちらのサイトのように、[有効化]というようなものが出るのでしょうか?それが見当たりません。
https://www.shiro8.net/manual4/v40x/store/plugin.html
(そもそも管理画面のデザインが少し違うのですが…)

ステータス・アップデートの部分は空白です。
検索してこちらを見つけたのですが、インストールボタン的なものが無いのでどこからインストールをしたらいいのかが全く分からず…
https://www.ec-cube.net/product/faq.php#question49

プラグインはどこからインストールをしたらいいのでしょうか?
3tiles
投稿日時: 2019/7/3 16:31
対応状況: −−−
一人前
登録日: 2019/6/19
居住地:
投稿: 79
Re: プラグインのインストールが出来ません。
ケースが違うかもしれませんが、下記ののスレッドとか参考になりませんでしょうか?

EC-CUBE4 プラグインの有効化・インストールができません。
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=21727&forum=16


----------------
スリータイルズ
WEBメディア「WEBshiru(ウェブシル)」

mav1224
投稿日時: 2019/7/3 17:45
対応状況: −−−
新米
登録日: 2019/6/20
居住地:
投稿: 7
Re: プラグインのインストールが出来ません。
返答ありがとうございます。

こちらの方もまだ解決済みとはなっていないようですが…
とりあえずキャッシュの削除をしてみましたが変化はありませんでした。
dtb_pluginは「返り値が空でした (行数 0)。 (Query took 0.0008 seconds.)」と出てます。

「商品登録はできるのに削除ができませんでした。」という事例になっていますが、私の方は試してみたところ登録・削除共に問題なしでした。
「試しに管理画面から『オーナーズストアから新規追加』ボタンを押すと500エラーとなります。」
こちらは私もエラー画面になりました。
.htaccessに「<Limit PUT DELETE>~」を追加してみましたが、こちらも変化はありませんでした。
3tiles
投稿日時: 2019/7/4 0:37
対応状況: −−−
一人前
登録日: 2019/6/19
居住地:
投稿: 79
Re: プラグインのインストールが出来ません。
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=21727&forum=16&post_id=91082

によれば、

引用:

故、『オーナーズストアから新規追加』の「500エラー」を何とか修正しないと、上記の「3.」の段階になれない。


とのことなので、なんとかエラーを解消しないと先へ進めないのではないでしょうか?

エラーの内容とかはどんな感じでしょうか?

また、
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=21727&forum=16&post_id=91094

引用:

有効化やインストールの PHP プロセスが高負荷だと判断され、強制終了してしまう場合があります。(OOM KIller など)


https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=21727&forum=16&post_id=91118

引用:

わかっていることは、共有サーバーでは、インストールや有効化の PHP プロセスが高負荷と判断され、強制終了してしまうことです。

Symfony DI のキャッシュ生成処理や、 Composer API をコールする処理が該当します。


とのことなので、ご利用のサーバー環境でも強制終了してしまっている恐れもあるかもしれません。


----------------
スリータイルズ
WEBメディア「WEBshiru(ウェブシル)」

mav1224
投稿日時: 2019/7/4 16:06
対応状況: −−−
新米
登録日: 2019/6/20
居住地:
投稿: 7
Re: プラグインのインストールが出来ません。
返答ありがとうございます。

500エラーについてですが、[オーナーズストア]→[プラグイン]→[プラグインを探す]→適当なものを選択して[入手する]をクリックすると、「システムエラーが発生しました。大変お手数ですが、サイト管理者までご連絡ください。」のエラーメッセージが出ます。

>PHP プロセスが高負荷と判断され、強制終了してしまうことです。
これはどこで確認したらよいでしょうか?
レンタルサーバを管理している会社に尋ねた方が早いでしょうか?
3tiles
投稿日時: 2019/7/4 21:44
対応状況: −−−
一人前
登録日: 2019/6/19
居住地:
投稿: 79
Re: プラグインのインストールが出来ません。
引用:

500エラーについてですが、[オーナーズストア]→[プラグイン]→[プラグインを探す]→適当なものを選択して[入手する]をクリックすると、「システムエラーが発生しました。大変お手数ですが、サイト管理者までご連絡ください。」のエラーメッセージが出ます。


EC-CUBE側のログに詳細なエラー情報が記録されているかもしれないので確認してみてはどうでしょうか?

ただ、

プラグインインストール時のエラーが表示されない場合があるのを修正
https://github.com/EC-CUBE/ec-cube/pull/4093

上記Issueによれば、ログが残らない場合もあるそうなので、その場合は上記の修正を適用してみては如何でしょうか?

また、前述のスレッドでは、
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=21727&forum=16&post_id=91116
のように、memory_limitとmax_execution_timeの設定を増やすことで解消された方もいらっしゃるようなのですが、そちらは試されてますでしょうか?

まだであれば、
https://github.com/EC-CUBE/ec-cube/issues/3990
によると、
引用:

xdebugが有効になっている -> xdebugを無効にして解消
memory_limitが128M -> memory_limitを512Mにして解消
max_execution_timeが30 -> max_execution_timeを180にして解消
composer.json/composer.lockに書き込み権限がない -> 書き込み権限を与える

とかも有効だったようです。

引用:

>PHP プロセスが高負荷と判断され、強制終了してしまうことです。
これはどこで確認したらよいでしょうか?
レンタルサーバを管理している会社に尋ねた方が早いでしょうか?


ログから確認できれば良いのですが、実際それで判別できるかどうかは何とも言えないです。
(OOM KillerとかであればOS(kernel)レベルでのログの確認とかが必要な場合があります。)
そういったサポートがあるのであれば、尋ねてみた方が早いかもしれません。


----------------
スリータイルズ
WEBメディア「WEBshiru(ウェブシル)」

mav1224
投稿日時: 2019/7/5 9:40
対応状況: −−−
新米
登録日: 2019/6/20
居住地:
投稿: 7
Re: プラグインのインストールが出来ません。
返答ありがとうございます。

引用:
EC-CUBE側のログに詳細なエラー情報が記録されているかもしれないので確認してみてはどうでしょうか?

多分これだと思うのですが…
確認する場所は[設定][システム設定][ログ表示][admin-"日付".log]で良かったでしょうか?
あと、1行がとても長いのですがどこまで掲載したらいいでしょうか…

システムエラーが発生しました。 ["<warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>\n\nIn JsonFile.php line 299:\n

<warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning> In JsonFile.php line 299:

多分この2行だと思いますが合ってますでしょうか?


引用:
memory_limitとmax_execution_timeの設定を増やすことで解消された方もいらっしゃるようなのですが、


memory_limitが128M -> memory_limitを512M
max_execution_timeが30 -> max_execution_timeを180
この2つは設定しました。

xdebugが有効になっている
これがどこで確認したらいいのかが分かりませんでした。
(有効にする方法は見つけたのですが、無効にする方法が確認できず…)
EC-CUBE内のPHP情報には「Configure Command」の中に「/opt/plesk/php/7.3/etc/php.d/50-xdebug.ini, 」の記述はありましたが、それ以下に「xdebug」は出てきていません。

composer.json/composer.lockに書き込み権限がない
/vendor/egulias/email-validator/
/vendor/jdorn/sql-formatter/
の中にcomposer.lockがあったので、644→666に変更。
同じ場所にあったcomposer.jsonも644→666に変更してみました。
こちらは設定後も変化はありませんでした。


エラーログから何か改善方法は判別できるでしょうか…
chankotaro
投稿日時: 2019/7/6 15:09
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
Re: プラグインのインストールが出来ません。
横から失礼いたします。

私も同じ問題で困っているので、こちら参考にさせていただきたいです。

私もxdebugを無効にする方法がよくわからいのですが、教えていただけますでしょうか?

memory_limitが128M -> memory_limitを512M
max_execution_timeが30 -> max_execution_timeを180
composer.lock →666
composer.json →666
はいずれも対応済みです。

それ以外ではこんなエラーが出ています。

Deprecation warning: require.ec-cube/CartClearV4 is invalid, it should not contain uppercase characters. Please use ec-cube/cartclearv4 instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/ECCUBE4LineLoginIntegration is invalid, it should not contain uppercase characters. Please use ec-cube/eccube4lineloginintegration instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/MailMagazine4 is invalid, it should not contain uppercase characters. Please use ec-cube/mailmagazine4 instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/Maker4 is invalid, it should not contain uppercase characters. Please use ec-cube/maker4 instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/RecommendedProducts4 is invalid, it should not contain uppercase characters. Please use ec-cube/recommendedproducts4 instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require.ec-cube/SprocketTag is invalid, it should not contain uppercase characters. Please use ec-cube/sprockettag instead. Make sure you fix this as Composer 2.0 will error.
Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.
PHP Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /home/drugpure/drugpure.jp/public_html/vendor/ec-cube/plugin-installer/src/Eccube/Composer/PluginInstaller.php on line 72

Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /home/drugpure/drugpure.jp/public_html/vendor/ec-cube/plugin-installer/src/Eccube/Composer/PluginInstaller.php on line 72

宜しくお願い致します。
red
投稿日時: 2019/7/6 17:10
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1350
Re: プラグインのインストールが出来ません。
この件は多分これで解決します
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=22109&forum=16&post_id=92744#forumpost92744


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

red
投稿日時: 2019/7/6 17:11
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1350
Re: プラグインのインストールが出来ません。
こちらは、PHPのバージョンなど怪しいような?


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

(1) 2 3 »
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

ec-cube.co

統計情報

総メンバー数は50,762名です
総投稿数は93,483件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1984
4
468
1848
5
yuh
1602
6
red
1350
7
umebius
1296
8
h_tanaka
924
9
fukap
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
774
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.