バージョン選択

フォーラム

メニュー

オンライン状況

84 人のユーザが現在オンラインです。 (59 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 83
facepoker もっと...

サイト内検索

プラグイン > その他 > プラグインのインストールが出来ません。

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
chankotaro
投稿日時: 2019/7/6 21:38
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
Re: プラグインのインストールが出来ません。
ありがとうございます。

こちらのリンクを試したところ、こんな風にでました。

composer update symfony/flex --no-plugins --no-scripts
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 9 installs, 1 update, 0 removals
- Updating symfony/flex (v1.1.8 => v1.4.1): Downloading (100%)
- Installing ec-cube/eccube4lineloginintegration (1.1.0): Downloading (100%)
- Installing ec-cube/sprockettag (1.0.0): Downloading (100%)
- Installing ec-cube/cartclearv4 (1.0.1): Downloading (100%)
- Installing ec-cube/mgsocialbutton (1.0.1): Downloading (100%)
- Installing ec-cube/mailmagazine4 (4.0.1): Downloading (100%)
- Installing ec-cube/maker4 (4.0.1): Downloading (100%)
- Installing ec-cube/productreview4 (4.0.1): Downloading (100%)
- Installing ec-cube/recommendedproducts4 (1.0.3): Downloading (100%)
- Installing ec-cube/relatedproduct4 (4.0.1): Downloading (100%)
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Package symfony/lts is abandoned, you should avoid using it. Use symfony/flex instead.
Writing lock file
Generating optimized autoload files
Warning: Ambiguous class resolution, "Eccube\Entity\Product" was found in both "$baseDir . '/app/proxy/entity/Product.php" and "/home/drugpure/drugpure.jp/public_html/src/Eccube/Entity/Product.php", the first will be used.


ちなみに、
サーバー:Xserver
ec-cube 4.0.2
PHP: 7.2.17
MySQL:5.7
が現在の環境です。

次に何をしたら良いでしょうか。よろしくお願いいたします。
red
投稿日時: 2019/7/7 19:26
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインのインストールが出来ません。
それぞれの人が事象が違うので、
やった結果、どの画面でどうなってるかを詳しく教えてください


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

mav1224
投稿日時: 2019/7/8 10:53
対応状況: −−−
新米
登録日: 2019/6/20
居住地:
投稿: 7
Re: プラグインのインストールが出来ません。
返答ありがとうございます。

composer update symfony/flex --no-plugins --no-scripts
をTerminalから実行してみたところ以下のメッセージが出ました。

Composer could not find a composer.json file in /root
To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ "Getting Started" section

これは、composer.json が /rootにないという意味でしょうか?
この場合、
/vendor/egulias/email-validator/
/vendor/jdorn/sql-formatter/
の2か所に移動して、「composer update symfony/flex --no-plugins --no-scripts」を実行したら良いという事で間違いないでしょうか?

red
投稿日時: 2019/7/8 11:33
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインのインストールが出来ません。
違います。
composer update symfony/flex --no-plugins --no-scripts



php composer.phar update symfony/flex --no-plugins --no-scripts

です。

composer.phar が多分ないと思うので

curl -sS https://getcomposer.org/installer | php

として取得してください


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

mav1224
投稿日時: 2019/7/8 14:52
対応状況: −−−
新米
登録日: 2019/6/20
居住地:
投稿: 7
Re: プラグインのインストールが出来ません。
ありがとうございます。

もしかしたらこれが原因なのかも…

まずは、
引用:
composer.phar が多分ないと思うので curl -sS https://getcomposer.org/installer | php

こちらを実行しました。

すると、以下のメッセージが出ました。

Downloading...

Composer (version 1.8.6) successfully installed to: /root/composer.phar
Use it: php composer.phar

Some settings on your machine may cause stability issues with Composer.
If you encounter issues, try to change the following:

Your PHP (5.3.3) is quite old, upgrading to PHP 5.3.4 or higher is recommended.
Composer works with 5.3.2+ for most people, but there might be edge case issues.

インストールは出来ているけど、php5.3.3は古いから5.3.4以上にしなさいという事ですよね?

ちなみにこのまま
php composer.phar update symfony/flex --no-plugins --no-scripts
を実行すると、
Composer could not find a composer.json file in /root
のメッセージが出ます。



私のサーバにはpleskがインストールされているのですけど、インストールをしようとしているサブドメイン(元のドメインの方も)の設定では7.3.6を使用するという事になっています。

しかし、サーバーにインストールされているphpのバージョンを見ると、その中に「PHP 5 from OS vendor」というものがあり、これが、5.3.3のようです。
pleskの[サーバ管理][ツールと設定][php設定]の中に、「使用可能にする PHP ハンドラを選択してください。」というものがあったので、「5.3.3 by OS vendor CGI アプリケーション(その他php5系全て)」のチェックを外して利用しないようにしていますが、効果が無い様子です。


「PHP 5 from OS vendor」を削除しようとしてみると、以下のようなメッセージが出ました。

------
以下のコンポーネントは、削除しようとしているコンポーネントに依存しているか、インストールしようとしているコンポーネントと競合しています。

All language localization for Plesk, Let's Encrypt, Ruby support, Phusion Passenger server, SEO Toolkit, WordPress Toolkit, Advisor, Webalizer, AWStats, Watchdog system monitoring, Plesk Firewall, Plesk VPN, Plesk file server

これらのコンポーネントは、以下で削除用に選択されています。すべての追加コンポーネントの削除を確定するには、[続行する]をクリックします。特定のコンポーネントの削除またはインストールをキャンセルするには、アクションリストから該当オプションを選択します。

以下のコンポーネントは、削除しようとしているコンポーネントに依存しているか、インストールしようとしているコンポーネントと競合していますが、明示的に削除することはできません。

Plesk

アクションリストから該当するオプションを選択することによってこれらのコンポーネントの削除を許可するか、あるいは、これらのコンポーネントが依存する他のコンポーネントが削除されていないか、または競合するコンポーネントがインストールされていないかを確認してから[続行する]をクリックします。コンポーネント削除を中止するには、[変更をキャンセル]をクリックします。
------

このメッセージと共に、上のリストにあるコンポーネントを同時に削除しようとしているのですが、さすがにこれはまずいですよね…

これは、サーバを変えないと動かないという事でしょうか…

red
投稿日時: 2019/7/8 16:16
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインのインストールが出来ません。
successfully installed to: /root/composer.phar

と出ている時点でおかしいですね。
ec-cubeのcomposer.jsonがある場所と同じ場所で実行してください

また
PHP (5.3.3) is quite old とでるのはおそらく、sshで php と実行するとPHP5.3になるようになっているのではないでしょうか?
php73とか、たぶんそのバージョンのPHPを実行するコマンドがあると思います

サーバー会社に問い合わせるか、調べるかしてください


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

mav1224
投稿日時: 2019/7/8 17:05
対応状況: −−−
新米
登録日: 2019/6/20
居住地:
投稿: 7
Re: プラグインのインストールが出来ません。
ありがとうございます。

vendor/jdorn/sql-formatter/に移動して、2つを実行しました。

curl~の方は全く同じメッセージが出ました。
(phpのバージョンについては少し調べてみました。なんとかなりそうなのですが、phpの場所がよく解らないので調べてみます。)

php composer.phar update~の方を実行すると、いくつかのファイルで背景が黄色の以下のメッセージが出ます。

Failed to download symfony/yaml from source: Failed to clone https://github.com/symfony/yaml.git, git was not found, check that it is installed and in your PATH env.

sh: git: command not found

Now trying to download from dist
(ファイル名とURL部分はそれぞれ違います。)

最終的には

phpunit/phpunit-mock-objects suggests installing ext-soap (*)
phpunit/php-code-coverage suggests installing ext-xdebug (>=2.0.5)
phpunit/phpunit suggests installing phpunit/php-invoker (>=1.1.0,<1.2.0)
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Writing lock file
Generating autoload files

のメッセージが出て終わりました。

とりあえずこの状態で、ec-cubeの管理画面に入ってみましたが、変化はなく、インストール等のボタンは出ませんでした。
(apacheの再起動などが必要だったでしょうか?)


vendor/egulias/email-validator/に移動して、2つを実行しました。

curl~の方は全く同じメッセージが出ました。


php composer.phar update~の方を実行すると、一部背景が赤色の以下のメッセージが出ます。

Package "symfony/flex" listed for update is not installed. Ignoring.
Loading composer repositories with package information


[RuntimeException]
Failed to clone https://github.com/dominicsayers/isemail, git was not found, check that it is installed and in your PATH env.

sh: git: command not found



これは正常にインストールされていない感じがしますが…どうしたら良いでしょうか?
red
投稿日時: 2019/7/8 17:08
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインのインストールが出来ません。
実行してるパスが違います。


vendor
composer.json
composer.lock
html
index.php

などがある場所で実行です。


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

chankotaro
投稿日時: 2019/7/9 9:16
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
Re: プラグインのインストールが出来ません。
説明がわかりにくくて申し訳ありません。

ec-cubeのcomposer.jsonなどがあるディレクトリで
composer update symfony/flex --no-plugins --no-scripts
を行ったら、以下の文言がでてきて、相変わらず、プラグインの有効ボタンなどが表示されない状態です。次にどんなことをすればよいかご教示いただけますでしょうか。

Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 9 installs, 1 update, 0 removals
- Updating symfony/flex (v1.1.8 => v1.4.1): Downloading (100%)
- Installing ec-cube/eccube4lineloginintegration (1.1.0): Downloading (100%)
- Installing ec-cube/sprockettag (1.0.0): Downloading (100%)
- Installing ec-cube/cartclearv4 (1.0.1): Downloading (100%)
- Installing ec-cube/mgsocialbutton (1.0.1): Downloading (100%)
- Installing ec-cube/mailmagazine4 (4.0.1): Downloading (100%)
- Installing ec-cube/maker4 (4.0.1): Downloading (100%)
- Installing ec-cube/productreview4 (4.0.1): Downloading (100%)
- Installing ec-cube/recommendedproducts4 (1.0.3): Downloading (100%)
- Installing ec-cube/relatedproduct4 (4.0.1): Downloading (100%)
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Package symfony/lts is abandoned, you should avoid using it. Use symfony/flex instead.
Writing lock file
Generating optimized autoload files
Warning: Ambiguous class resolution, "Eccube\Entity\Product" was found in both "$baseDir . '/app/proxy/entity/Product.php" and "/home/drugpure/drugpure.jp/public_html/src/Eccube/Entity/Product.php", the first will be used.
red
投稿日時: 2019/7/9 10:47
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインのインストールが出来ません。
キャッシュクリアしてみても状況はかわりませんか?

2人が入り混じっているので、なにが何やらな感じです。


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

« 1 (2) 3 »
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

ec-cube.co

統計情報

総メンバー数は50,992名です
総投稿数は93,510件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1984
4
468
1858
5
yuh
1604
6
red
1353
7
umebius
1296
8
h_tanaka
924
9
fukap
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
774
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.