バージョン選択

フォーラム

メニュー

オンライン状況

74 人のユーザが現在オンラインです。 (58 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 73
misako もっと...

サイト内検索

プラグイン > その他 > プラグインをインストールできません。

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
chankotaro
投稿日時: 2019/7/9 11:32
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
プラグインをインストールできません。
他のスレッドに書き込んでややこしくなったので、新規に立てます。

[EC-CUBE] 4.0.2
[レンタルサーバ] Xserver
[PHP] PHP 7.2.17
[データベース] MySQL 5.7

[現象] composer update symfony/flex --no-plugins --no-scripts
をしてキャッシュクリアもしましたが、まだステータスに何も見えません。

memory_limitが128M -> memory_limitを512M
max_execution_timeが30 -> max_execution_timeを180
composer.lock →666
composer.json →666
はいずれも対応済みです。

composer update symfony/flex --no-plugins --no-scripts
をcomposer.jsonがあるディレクトリで行ったら以下のめっせーじがでました。
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 9 installs, 1 update, 0 removals
- Updating symfony/flex (v1.1.8 => v1.4.1): Downloading (100%)
- Installing ec-cube/eccube4lineloginintegration (1.1.0): Downloading (100%)
- Installing ec-cube/sprockettag (1.0.0): Downloading (100%)
- Installing ec-cube/cartclearv4 (1.0.1): Downloading (100%)
- Installing ec-cube/mgsocialbutton (1.0.1): Downloading (100%)
- Installing ec-cube/mailmagazine4 (4.0.1): Downloading (100%)
- Installing ec-cube/maker4 (4.0.1): Downloading (100%)
- Installing ec-cube/productreview4 (4.0.1): Downloading (100%)
- Installing ec-cube/recommendedproducts4 (1.0.3): Downloading (100%)
- Installing ec-cube/relatedproduct4 (4.0.1): Downloading (100%)
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Package symfony/lts is abandoned, you should avoid using it. Use symfony/flex instead.
Writing lock file
Generating optimized autoload files
Warning: Ambiguous class resolution, "Eccube\Entity\Product" was found in both "$baseDir . '/app/proxy/entity/Product.php" and "/src/Eccube/Entity/Product.php", the first will be used.
red
投稿日時: 2019/7/9 13:20
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインをインストールできません。
プラグインがたくさんインストールされていそうですが、1つも有効化出来ない状態でしょうか?


例えば、
bin/console eccube:plugin:install --code= ProductReview4
とコマンド実行するとインストールはされるのでしょうか?


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

cyb2019
投稿日時: 2019/7/9 19:59
対応状況: −−−
新米
登録日: 2019/7/9
居住地:
投稿: 10
Re: プラグインをインストールできません。
本日同じ現象で悩んでおりました。
PHP 7.3.7
の環境で
composer update symfony/flex --no-plugins --no-scripts
を実行しても解決しませんでしたが、
PHP 7.2.20
にダウングレードした後に
composer update symfony/flex --no-plugins --no-scripts
を実行したら無事プラグインのインストールを行うことができました。
chankotaro
投稿日時: 2019/7/9 20:39
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
Re: プラグインをインストールできません。
ありがとうございます。

bin/console eccube:plugin:install --code= RecommendedProduct4
を行ったら、以下のエラーが返ってきました。

PHP Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /home/drugpure/drugpure.jp/public_html/bin/console on line 15

ちなみに、プラグイン21個中5個はインストール有効となっていて、それ以外の16個が何もステータスが出ない状態です。

bin/consoleの中身は以下の通りです。
#!/usr/bin/env php
<?php

use Eccube\Kernel;
use Symfony\Bundle\FrameworkBundle\Console\Application;
use Symfony\Component\Dotenv\Dotenv;
use Symfony\Component\Console\Input\ArgvInput;
use Symfony\Component\Debug\Debug;

umask(0000);
set_time_limit(0);

require __DIR__.'/../vendor/autoload.php';

if (!class_exists(Application::class)) {
throw new \RuntimeException('You need to add "symfony/framework-bundle" as a Composer dependency.');
}

if (!isset($_SERVER['APP_ENV'])) {
if (file_exists(__DIR__.'/../.env')) {
(new Dotenv())->load(__DIR__.'/../.env');
} else {
(new Dotenv())->load(__DIR__.'/../.env.install');
}
}

$input = new ArgvInput();
$env = $input->getParameterOption(['--env', '-e'], $_SERVER['APP_ENV'] ?? 'dev');
$debug = ($_SERVER['APP_DEBUG'] ?? true) !== '0' && !$input->hasParameterOption(['--no-debug', '']);

if ($debug && class_exists(Debug::class)) {
Debug::enable();
}

$kernel = new Kernel($env, $debug);
$application = new Application($kernel);
$application->run($input);
bin/console (END)
red
投稿日時: 2019/7/9 21:24
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインをインストールできません。
PHP Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /home/drugpure/drugpure.jp/public_html/bin/console on line 15


↑このエラーはPHPのバージョンが低い時に出るエラーなので、Xサーバーも、sshでデフォルトのPHPはバージョンが低いんでしょうね。

こういう作業が必要にだと思います
https://minory.org/xserver-ssh-php7.html


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

chankotaro
投稿日時: 2019/7/10 14:54
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
Re: プラグインをインストールできません。
ありがとうございます。

PHPのバージョンをあげて、

composer update symfony/flex --no-plugins --no-scripts
を行いましたが、以下のメッセージが返ってきました。
次に行うべきことがあれば宜しくお願い致します。

Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Package symfony/lts is abandoned, you should avoid using it. Use symfony/flex instead.
Generating optimized autoload files
Warning: Ambiguous class resolution, "Eccube\Entity\Product" was found in both "$baseDir . '/app/proxy/entity/Product.php" and "/src/Eccube/Entity/Product.php", the first will be used.


あと、無理やり
bin/console eccube:plugin:install --code=RecommendedProduct4
を行ったら、以下のエラーメッセージが返ってきました。

Error thrown while running command "eccube:plugin:install --code=RecommendedProduct4". Message: "/app/Plugin/RecommendedProduct4/composer.json not found." ["exception" => Eccube\Exception\PluginException { …},"command" => "eccube:plugin:install --code=RecommendedProduct4","message" => "/app/Plugin/RecommendedProduct4/composer.json not found."] ["file" => "/vendor/symfony/console/EventListener/ErrorListener.php","line" => 46,"class" => "Symfony\Component\Console\EventListener\ErrorListener","function" => "onConsoleError","uid" => "e35459d","user_id" => "N/A","session_id" => "N/A"]

In PluginService.php line 438:

/app/Plugin/RecommendedProduct4/composer.json not found.
red
投稿日時: 2019/7/10 15:44
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインをインストールできません。
なるほど。
そもそも、ダウンロードに失敗しているんですね。

bin/console eccube:composer:require ec-cube/RecommendedProduct4
bin/console eccube:plugin:install --code=RecommendedProduct4

とすると動きそうな気がします。


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

chankotaro
投稿日時: 2019/7/10 16:01
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
Re: プラグインをインストールできません。
ありがとうございます。

bin/console eccube:composer:require ec-cube/RecommendedProduct4
を行ったら以下のメッセージが返ってきました。どうやらまだうまくいってなさそうです。

<warning>Deprecation warning: require.ec-cube/CartClearV4 is invalid, it should not contain uppercase characters. Please use ec-cube/cartclearv4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ECCUBE4LineLoginIntegration is invalid, it should not contain uppercase characters. Please use ec-cube/eccube4lineloginintegration instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/MailMagazine4 is invalid, it should not contain uppercase characters. Please use ec-cube/mailmagazine4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Maker4 is invalid, it should not contain uppercase characters. Please use ec-cube/maker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/RecommendedProducts4 is invalid, it should not contain uppercase characters. Please use ec-cube/recommendedproducts4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SprocketTag is invalid, it should not contain uppercase characters. Please use ec-cube/sprockettag instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>

In InitCommand.php line 751:

Could not find a matching version of package ec-cube/RecommendedProduct4. Check the package spell
ing, your version constraint and that the package is available in a stability which matches your
minimum-stability (stable).


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

15:59:53 ERROR [console] Error thrown while running command "eccube:composer:require 'ec-cube/RecommendedProduct4'". Message: "" ["exception" => Eccube\Exception\PluginException { …},"command" => "eccube:composer:require 'ec-cube/RecommendedProduct4'","message" => ""] ["file" => "/vendor/symfony/console/EventListener/ErrorListener.php","line" => 46,"class" => "Symfony\Component\Console\EventListener\ErrorListener","function" => "onConsoleError","uid" => "3d8e594","user_id" => "N/A","session_id" => "N/A"]

In ComposerApiService.php line 308:

[Eccube\Exception\PluginException]


eccube:composer:require [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command> <package> [<version>]
red
投稿日時: 2019/7/10 16:14
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1353
Re: プラグインをインストールできません。
ちょっと間違えました。

管理画面のプラグイン一覧でコードのところにRecommendedProducts4とあると思いますが、このプラグインは有効化出来ますか?


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

chankotaro
投稿日時: 2019/7/10 16:33
対応状況: −−−
半人前
登録日: 2019/5/25
居住地:
投稿: 17
Re: プラグインをインストールできません。
このプラグインは有効化できない状態です。

ステータスのところに何も表示されていません。
(1) 2 »
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

ec-cube.co

統計情報

総メンバー数は51,314名です
総投稿数は93,553件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1986
4
468
1863
5
yuh
1604
6
red
1353
7
umebius
1296
8
h_tanaka
924
9
fukap
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
780
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.