バージョン選択

フォーラム

メニュー

オンライン状況

73 人のユーザが現在オンラインです。 (56 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 73
もっと...

サイト内検索

質問 > 管理機能 > サイトリリース後、プラグインがインストールできなくなった

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
masakazu
投稿日時: 2019/8/5 11:46
対応状況: −−−
新米
登録日: 2019/8/5
居住地:
投稿: 1
サイトリリース後、プラグインがインストールできなくなった
▼テンプレート
[EC-CUBE] 4.0.2
[レンタルサーバ] Conoha VPS
[OS] CentOS 7.6
[PHP] 7.1.29
[データベース] MySQL 10.0.33-MariaDB
[WEBサーバ] Apache/2.4.6
[導入プラグインの有無] どのプラグインでも発生
[現象]
サイトリリース後に、オーナーズストアから新規にプラグインをインストールしようとしたところ、
「システムエラーが発生しました。」と表示されるようになってしまいました。

構築時はそのようなことがなくプラグインのインストールができたのですが、
リリースしてから、別の新しいプラグインのインストールを試したところ、エラーとなってしまってます。

構築時から特にこれといった変更はしておらず、しいていえば、パーミッションを見直したくらいかな...
と思っており、プラグインに関わりそうなフォルダを再確認しても、特に問題はないかと思ってます。

色々とサイトを調べて、以下の確認はしましたが、改善されませんでした。
・xdebugは最初から無効設定
・memory_limit 128M -> 512Mや1024Mに変更
・max_execution_time 30 -> 180に変更
・composer.json/composer.lock 書き込み権限あるかの確認
・デバッグモード(APP_ENV=dev,APP_DEBUG=1)でのインストール

また、インストール後にMySQLユーザーの権限変更なども行ってません。
Conohaのサーバーの契約もメモリ1Gプランから4Gプランへと変更してみても、同様のエラーのままでした。

エラー内容は以下に記載させて頂きます。
エラー特定する方法など、どなたか教えて頂けましたら幸いです。
どうぞ宜しくお願いいたします。


システムエラーが発生しました。

ログを確認
**************** FacebookAdsExtention ****************
<warning>Deprecation warning: require.ec-cube/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SSProductDetailPage is invalid, it should not contain uppercase characters. Please use ec-cube/ssproductdetailpage instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SalesReport4 is invalid, it should not contain uppercase characters. Please use ec-cube/salesreport4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>
[148.4MiB/18.86s] Using version ^1.0 for ec-cube/FacebookAdsExtention
[148.4MiB/18.87s] ./composer.json has been updated
[148.7MiB/18.92s] <warning>Deprecation warning: require.ec-cube/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.</warning>
[148.7MiB/18.92s] <warning>Deprecation warning: require.ec-cube/SSProductDetailPage is invalid, it should not contain uppercase characters. Please use ec-cube/ssproductdetailpage instead. Make sure you fix this as Composer 2.0 will error.</warning>
[148.7MiB/18.92s] <warning>Deprecation warning: require.ec-cube/SalesReport4 is invalid, it should not contain uppercase characters. Please use ec-cube/salesreport4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[148.7MiB/18.92s] <warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>
[152.4MiB/19.27s] Loading composer repositories with package information
[153.1MiB/20.39s] Updating dependencies (including require-dev)
[533.9MiB/34.21s] Package operations: 1 install, 0 updates, 0 removals
[533.9MiB/34.21s]   - Installing ec-cube/facebookadsextention (1.0.0): [533.9MiB/34.21s] Loading from cache[533.9MiB/34.21s] 

In LibraryInstaller.php line 134:
                                                                  
  Package is not installed: ec-cube/facebookadsextention-1.0.0.0  
                                                                  

require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] 
[--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...
kazumi
投稿日時: 2019/8/7 13:24
対応状況: −−−
常連
登録日: 2019/4/15
居住地:
投稿: 36
Re: サイトリリース後、プラグインがインストールできなくなった
@ masakazuさん

・デバッグモード(APP_ENV=dev,APP_DEBUG=1)でのインストール


デバックモードですが、上記の設定を以下のように変更しても改善しないでしょうか。


APP_ENV=prod
APP_DEBUG=0


もし、上記で改善しないのであれば、以下の記事も参考になるかと思います。

https://qiita.com/nanasess/items/583683eb94947aebea44
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


ec-cube.co

統計情報

総メンバー数は48,195名です
総投稿数は92,882件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1908
4
468
1818
5
yuh
1600
6
red
1333
7
umebius
1296
8
fukap
907
9
h_tanaka
881
10
tsuji
852
11
shutta
835
12 ramrun 789
13
tao_s
758
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.