バージョン選択

フォーラム

メニュー

オンライン状況

90 人のユーザが現在オンラインです。 (72 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 90
もっと...

サイト内検索

質問 > 管理機能 > プラグインがインストールできない

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
chako79
投稿日時: 2019/8/12 12:36
対応状況: 解決済
半人前
登録日: 2017/1/10
居住地:
投稿: 11
プラグインがインストールできない
▼テンプレート
[EC-CUBE]新規ストール 4.02
[レンタルサーバ] Xサーバー
[OS] win10
[PHP] PHP7.1.28 / 7.2.17
[データベース] MySQL 5.7.x
[ブラウザ] Chrome/Edge/safari いずれも最新版
[導入プラグインの有無] 会員ランクプラグイン for EC-CUBE4(有料)、【ver4】LINEログイン連携プラグイン
[カスタマイズの有無] 特になし。デフォルトの状態です。
[現象]

●プラグイン一覧には表示されますが[ステータス][アップデート]の欄が空欄でそこから先に進めません。
同様の症状でスレッドが多くたっていたので下記を試しましたがどれも無理でした。

【試したこと】

1. php.iniの設定を変更する
 ・memory_limit 128M -> 512Mに変更
 ・max_execution_time 30 -> 180に変更
 ・composer.json/composer.lock 書き込み権限あるかの確認:606にしています。
 ・xdebug > サーバー管理画面から確認ができない

2. envファイルの書き換えでデバッグモード
  (APP_ENV=dev,APP_DEBUG=1)に変更してもしなくてもインストールはできない

3. DBにdtb_pluginテーブルはあるが中身は空

4. Xサーバー側のPHPのversionの変更
  同じ環境で同じ症状の方がブログにて[PHP7.1.28にすることで問題が解決した]とあったので試してみるが私の方では効果なし

5. EC-CUBE管理画面からのキャッシュの削除もしたが変化なし


このような状態です。

色んなサーバーでEC-CUBE4系を入れて問題が多発していたので今回は、EC-CUBE 4系対応サーバ一覧にあったXサーバーで試したものの上記のような状態です。
しかも4万を超える高額プラグインを購入しましたのでインストールできないと困ります。

chako79
投稿日時: 2019/9/6 12:05
対応状況: −−−
半人前
登録日: 2017/1/10
居住地:
投稿: 11
自己解決しました
すごく簡単なことで解決しましたので報告します

サーバー側のWAFをすべてOFFにしましたところ、問題なくインストールできました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

ec-cube.co

統計情報

総メンバー数は49,518名です
総投稿数は93,188件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1967
4
468
1818
5
yuh
1602
6
red
1343
7
umebius
1296
8
fukap
907
9
h_tanaka
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
774
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.