バージョン選択

フォーラム

メニュー

オンライン状況

69 人のユーザが現在オンラインです。 (49 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 68
red もっと...

サイト内検索

プラグイン > その他 > EC-CUBE2.17.0α決済モジュールについて

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
bkfmc351
投稿日時: 2019/8/19 17:31
対応状況: −−−
新米
登録日: 2019/8/19
居住地:
投稿: 1
EC-CUBE2.17.0α決済モジュールについて
EC-CUBE2.17.0αへのバージョンアップを検討中ですが、
バージョンアップされた方で、そのまま使用可能な決済モジュールはありますでしょうか?
tao_s
投稿日時: 2019/9/17 19:30
対応状況: −−−
仙人
登録日: 2008/8/20
居住地: 東京
投稿: 780
Re: EC-CUBE2.17.0α決済モジュールについて
PHPのバージョンによりけりだと思いますが、おそらくほとんどのモジュールがそのままではPHP7系には対応していないと思います。


----------------
EC-CUBEカスタマイズ相談してください。
緊急のEC-CUBEの障害対応
EC-CUBEカスタマイズブログ

kazz_oga
投稿日時: 2019/10/29 18:26
対応状況: −−−
一人前
登録日: 2013/8/5
居住地: 東京都北区赤羽西
投稿: 98
Re: EC-CUBE2.17.0α決済モジュールについて
当方は2.17移行中です(2019年10月23日のinprove/php7をmarge)。

当方の決済モジュール
EC-CUBEペイメント決済モジュール(2.13系) Version.4.3.24

warningメッセージはでましたが次の点を修正し、決済ができることを開発環境では確認済みです(修正は他のカスタマイズ部分も含めて全体的に直しています)
・count(): Parameter must be an array or an object
  count()に入る前にis_nul()l,empty()で確認
・関数のパラメータの数が合わない
  少ない方の関数のパラメータを増やして数を一致させた

Invalid argument supplied for foreach() onのwarningも出ていましたが、count()を対応したら出なくなりました。

<現在残っているメッセージ> 実行結果には影響なさそうです
Warning(E_WARNING): session_cache_limiter(): Cannot change cache limiter when session is active on

決済以外のプラグインではjQueryの競合が発生しました。こちらはひとつひとつ解決するしかありませんでしたが
kazz_oga
投稿日時: 2019/10/30 15:58
対応状況: −−−
一人前
登録日: 2013/8/5
居住地: 東京都北区赤羽西
投稿: 98
Re: EC-CUBE2.17.0α決済モジュールについて
うまくいなない事象を確認しました

あらたなスレッドにしました。
「2.17 決済モジュールで「モジュールファイルの取得に失敗しました。」」
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は53,997名です
総投稿数は94,125件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
2014
4
468
1908
5
yuh
1610
6
umebius
1398
7
red
1376
8
h_tanaka
939
9
fukap
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
780
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.