バージョン選択

フォーラム

メニュー

オンライン状況

47 人のユーザが現在オンラインです。 (26 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 46
468 もっと...

サイト内検索

プラグイン > 開発について > 外部依存関係の使用方法はどうですか

開発について

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
bjj
投稿日時: 2020/2/12 17:53
対応状況: −−−
新米
登録日: 2020/2/12
居住地:
投稿: 1
外部依存関係の使用方法はどうですか
[EC-CUBE] EC-CUBE4
こんにちわ。
プラグインを開発時、質問があります。
外部依存ある場合、設定ファイルに何を設定すればいいでしょうか?

下記はプラグインのcomposer.jsonファイル:

```
{
"name": "ec-cube/my-plugin",
"version": "0.1.0",
"description": "my-plugin test",
"type": "eccube-plugin",
"require": {
"ec-cube/plugin-installer": "~0.0.7",
"xxx/xxx-php-sdk": "~1.0.0"
},
"extra": {
"code": "MyPlugin"
}
}
```

プラグインはパッケージ `xxx / xxx-php-sdk` を依存しています。
しかし、プラグインをインストール時、依存をインストールしません。
red
投稿日時: 2020/2/13 10:00
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1391
Re: 外部依存関係の使用方法はどうですか
https://github.com/EC-CUBE/ec-cube/pull/4067
この修正を取り込んで、コマンド実行でプラグインをインストールするといいです


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は59,022名です
総投稿数は95,064件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
2035
4
468
1976
5
yuh
1612
6
umebius
1562
7
red
1391
8
h_tanaka
970
9
fukap
907
10
tsuji
863
11
shutta
835
12 ramrun 789
13
tao_s
783
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.