バージョン選択

フォーラム

メニュー

オンライン状況

17 人のユーザが現在オンラインです。 (13 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 17
もっと...

サイト内検索

質問 > その他 > composerでライブラリがインストールできない

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
shinobu
投稿日時: 2020/9/2 15:37
対応状況: 解決済
新米
登録日: 2020/8/12
居住地:
投稿: 4
composerでライブラリがインストールできない
bin/console eccube:composer:require knpuniversity/oauth2-client-bundle

上記のコマンドを実行したら
下記のようなエラーが発生して
ライブラリがインストールできません

こちらの解決方法わかりますか

<warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>

In RemoteFilesystem.php line 737:

The 'https://package-api.ec-cube.net/packages.json' URL could not be accessed: HTTP/1.1 403


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

15:37:09 ERROR [console] Error thrown while running command "eccube:composer:require 'knpuniversity/oauth2-client-bundle'". Message: "" ["exception" => Eccube\Exception\PluginException { …},"command" => "eccube:composer:require 'knpuniversity/oauth2-client-bundle'","message" => ""] ["file" => "/home/xs749336/xs749336.xsrv.jp/public_html/test/vendor/symfony/console/EventListener/ErrorListener.php","line" => 46,"class" => "Symfony\Component\Console\EventListener\ErrorListener","function" => "onConsoleError","uid" => "71d58d8","user_id" => "N/A","session_id" => "N/A"]

In ComposerApiService.php line 308:

[Eccube\Exception\PluginException]


eccube:composer:require [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command> <package> [<version>]

red
投稿日時: 2020/9/2 17:23
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1422
Re: composerでライブラリがインストールできない
認証キー設定とかでしょうか


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は65,915名です
総投稿数は98,047件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
468
2597
4
nanasess
2101
5
umebius
1717
6
yuh
1612
7
red
1422
8
h_tanaka
1038
9
fukap
907
10
tsuji
863
11
shutta
835
12
tao_s
792
13 ramrun 789
14 karin 657
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.