バージョン選択

フォーラム

メニュー

オンライン状況

35 人のユーザが現在オンラインです。 (19 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 35
もっと...

サイト内検索

質問 > 管理機能 > 管理画面>システム設定 SSLを強制 にチェックが出来ない

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
okaret
投稿日時: 2020/11/13 22:05
対応状況: 確認中
新米
登録日: 2020/11/13
居住地:
投稿: 3
管理画面>システム設定 SSLを強制 にチェックが出来ない
ECCUBEのバージョン4をインストールしました。

システム設定や、認証キーの設定が出来なため、
管理画面>システム設定で、SSLを強制 にチェックを入れようとしたところ、
disabled でチェックが出来ない状況です。

https:// でアクセスをしておりますが、
商品の登録画面などでは、リンク、フォームの送信先が、https:// となりますが、
システム設定などでは、リンク先が、http:// となります。

インストールのみした状態で、ECCUBEの設定は、触っておりませんので、
サーバのApacheの設定の問題でしょうか。

インストール時も、https:// でアクセスしたのですが、SSLを使用するのチェックが押せなかったです。

468
投稿日時: 2020/11/14 11:21
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 2701
Re: 管理画面>システム設定 SSLを強制 にチェックが出来ない
>https:// でアクセスをしておりますが、
>商品の登録画面などでは、リンク、フォームの送信先が、https:// となりますが、
>システム設定などでは、リンク先が、http:// となります。

こちらは管理画面にログインする時はhttps://~でアクセスしているにも関わらず
サイドメニューからシステム設定に遷移すると(メニューをクリックする操作でしょうか?)
http://のURLに遷移するという事でしょうか?

https://でアクセスした状態からhttp://に遷移するというのは
デフォルトでは確認した事がありませんので
その点が不思議なのですが、例えばシステム設定画面に遷移した後、
ブラウザのアドレスバーにてhttps://~となるように「s」を手入力した場合どうなりますか?
通常であれば、https://の状態でシステム設定画面が表示されると思うのですが...


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

okaret
投稿日時: 2020/11/14 12:23
対応状況: −−−
新米
登録日: 2020/11/13
居住地:
投稿: 3
Re: 管理画面>システム設定 SSLを強制 にチェックが出来ない
> こちらは管理画面にログインする時はhttps://~でアクセスしているにも関わらず
> サイドメニューからシステム設定に遷移すると(メニューをクリックする操作でしょうか?)
> http://のURLに遷移するという事でしょうか?

はい、管理画面にログインする時は、https:// でアクセスしていますが、
サイドメニューから各コンテンツに移動すると、http:// になります。(商品登録などもそうですが、こちらは登録が出来ます。)
管理画面ログイン後の画面で、HTMLのソースを見ますと、href="http://xxx.com" となっています。

あと、サーバ自体に、http:// のアクセスは、https:// にリダイレクト?の設定になっているかと思います。

>例えばシステム設定画面に遷移した後、
>ブラウザのアドレスバーにてhttps://~となるように「s」を手入力した場合どうなりますか?
>通常であれば、https://の状態でシステム設定画面が表示されると思うのですが...

ブラウザのアドレスバーで、手入力で、https:// を入力しますと、http:// に戻されてしまうような気がします。
(このサイトの接続は完全には保護されていないと表示されます。)
また、アドレスバーに、カーソルを合わせると、自動で、https:// になるのですが、
リターンキーをクリックして、ページを再描画すると、http:// に戻ってしまいます。


umebius
投稿日時: 2020/11/14 16:07
対応状況: −−−
登録日: 2016/7/22
居住地: 東京日本橋
投稿: 1793
Re: 管理画面>システム設定 SSLを強制 にチェックが出来ない
ロードバランサやリバースプロキシを使用されているということはございますでしょうか?


----------------
EC-CUBE4系 カスタマイズ ECのプロがシステム特急案件承ります。
EC-CUBE開発 リモートで働くエンジニア募集中

okaret
投稿日時: 2020/11/14 17:16
対応状況: −−−
新米
登録日: 2020/11/13
居住地:
投稿: 3
Re: 管理画面>システム設定 SSLを強制 にチェックが出来ない
>ロードバランサやリバースプロキシを使用されているということはございますでしょうか?

はい、詳細はわからないですが、使用されているかと思われます。

サーバ管理者に原因を説明して、設定の変更等をしていただくことになりますでしょうか。
umebius
投稿日時: 2020/11/14 22:02
対応状況: −−−
登録日: 2016/7/22
居住地: 東京日本橋
投稿: 1793
Re: 管理画面>システム設定 SSLを強制 にチェックが出来ない
仮にロードバランサを使用しているとして、ロードバランサを使用しなくてもインフラ設計上問題ないなら使用をやめるのは1つの手かと思います。

この問題はアプリケーション側で対応も可能で、4系では.env等でTRUSTED_PROXIESの設定を行ってやる必要があります。
(初期状態ではコメントアウトされていると思います)

3系の設定になりますがドキュメントに記載されています。
https://doc.ec-cube.net/quickstart_proxy

ただAWS(ELB)のようにIPが固定ではない場合は別の方法を取る場合があります。(セキュリティグループでEC2へのリクエストをELBからのみに制限した上で)
https://symfony.com/doc/current/deployment/proxies.html#but-what-if-the-ip-of-my-reverse-proxy-changes-constantly


----------------
EC-CUBE4系 カスタマイズ ECのプロがシステム特急案件承ります。
EC-CUBE開発 リモートで働くエンジニア募集中

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は67,511名です
総投稿数は98,889件です

投稿数ランキング

1
seasoft
7333
2
AMUAMU
2712
3
468
2701
4
nanasess
2116
5
umebius
1793
6
yuh
1612
7
red
1427
8
h_tanaka
1051
9
fukap
907
10
tsuji
863
11
shutta
835
12
tao_s
792
13 ramrun 789
14 karin 657
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.