バージョン選択

フォーラム

メニュー

オンライン状況

27 人のユーザが現在オンラインです。 (17 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 27
もっと...

サイト内検索

質問 > 管理機能 > オーナーズストアのプラグインがインストールできない

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
Locke
投稿日時: 2020/11/16 15:42
対応状況: −−−
新米
登録日: 2012/1/7
居住地:
投稿: 4
オーナーズストアのプラグインがインストールできない
▼テンプレート
[EC-CUBE] 4.0.4
[レンタルサーバ] CoreServer
[OS] Ubuntu
[PHP] 7.1.33
[データベース] MySQL 5.7.29
[WEBサーバ] Apache
[ブラウザ] Firefox/82.0
[導入プラグインの有無] 無し(これから)
[カスタマイズの有無] 無し
[現象]
 管理画面-オーナーズストアから「関連商品プラグイン」というプラグインをインストールしようとすると、「インストール確認」というタイトル及び「システムエラーが発生しました」という内容のダイアログが表示され、インストールができません。
この状態ではブラウザの閉じるボタンがすぐには反応しないのですが、しばらく放置していると、InternalServerErrorの画面になります。
site---logには以下のように残っています。

[2020-11-16 11:28:15] app.INFO [N/A] [11ef253] [1] [Eccube\Log\Logger:log:68] - PROCESS END ["admin_store_plugin_install_confirm"] [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:28:15] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - LOGIC END ["admin_store_plugin_install_confirm"] [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:28:15] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - <warning>Deprecation warning: require.ec-cube/ProductDisplayRank4 is invalid, it should not contain uppercase characters. Please use ec-cube/productdisplayrank4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Recommend4 is invalid, it should not contain uppercase characters. Please use ec-cube/recommend4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug</warning> <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2</warning> name : ec-cube/plugin-installer descrip. : EC-CUBE plugin installer. keywords : versions : 0.0.8, 0.0.7, 0.0.6 type : composer-plugin license : MIT License (MIT) (OSI approved) https://spdx.org/licenses/MIT.html#licenseText source : [git] https://github.com/EC-CUBE/eccube-plugin-installer.git 6185cd43ae0dd0423bebc9bb900d096356340f80 dist : [zip] https://api.github.com/repos/EC-CUBE/eccube-plugin-installer/zipball/6185cd43ae0dd0423bebc9bb900d096356340f80 6185cd43ae0dd0423bebc9bb900d096356340f80 names : ec-cube/plugin-installer autoload psr-0 Eccube => src/ requires composer-plugin-api ^1.0 {"command":"info","package":"ec-cube/plugin-installer","version":"~0.0.6","--available":true,"--working-dir":"/virtual/ansuz/public_html/www.we-ne.site","--no-ansi":true} [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:28:12] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - <warning>Deprecation warning: require.ec-cube/ProductDisplayRank4 is invalid, it should not contain uppercase characters. Please use ec-cube/productdisplayrank4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Recommend4 is invalid, it should not contain uppercase characters. Please use ec-cube/recommend4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug</warning> {"command":"config","setting-key":"repositories.eccube","setting-value":["{\"type\":\"composer\",\"url\":\"https:\\/\\/package-api.ec-cube.net\",\"options\":{\"http\":{\"header\":[\"X-ECCUBE-KEY: e42cu8CF2TWA0NlWTxl5l8E1rBBiMM2VQjdpc19O\"]}}}"],"--working-dir":"/virtual/ansuz/public_html/www.we-ne.site","--no-ansi":true} [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:28:11] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - <warning>Deprecation warning: require.ec-cube/ProductDisplayRank4 is invalid, it should not contain uppercase characters. Please use ec-cube/productdisplayrank4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Recommend4 is invalid, it should not contain uppercase characters. Please use ec-cube/recommend4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug</warning> <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2</warning> name : ec-cube/RelatedProduct4 descrip. : 関連商品プラグイン keywords : versions : 4.0.1 type : eccube-plugin source : [] dist : [tar] https://package-api.ec-cube.net/ec-cube/RelatedProduct4/4.0.1/RelatedProduct4-4.0.1.tgz names : ec-cube/relatedproduct4 requires ec-cube/plugin-installer ~0.0.6 {"command":"info","package":"ec-cube/RelatedProduct4","version":"4.0.1","--available":true,"--working-dir":"/virtual/ansuz/public_html/www.we-ne.site","--no-ansi":true} [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:27:59] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - <warning>Deprecation warning: require.ec-cube/ProductDisplayRank4 is invalid, it should not contain uppercase characters. Please use ec-cube/productdisplayrank4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Recommend4 is invalid, it should not contain uppercase characters. Please use ec-cube/recommend4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning> <warning>You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug</warning> {"command":"config","setting-key":"repositories.eccube","setting-value":["{\"type\":\"composer\",\"url\":\"https:\\/\\/package-api.ec-cube.net\",\"options\":{\"http\":{\"header\":[\"X-ECCUBE-KEY: e42cu8CF2TWA0NlWTxl5l8E1rBBiMM2VQjdpc19O\"]}}}"],"--working-dir":"/virtual/ansuz/public_html/www.we-ne.site","--no-ansi":true} [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:27:58] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - http get_info {"url":"https://package-api.ec-cube.net/plugin/1761","content_type":"application/json;charset=UTF-8","http_code":200,"header_size":413,"request_size":191,"filetime":-1,"ssl_verify_result":0,"redirect_count":0,"total_time":0.59033800000000003,"namelookup_time":0.0041289999999999999,"connect_time":0.023438000000000001,"pretransfer_time":0.066320000000000004,"size_upload":0,"size_download":845,"speed_download":1431,"speed_upload":0,"download_content_length":-1,"upload_content_length":0,"starttransfer_time":0.59029900000000002,"redirect_time":0,"redirect_url":"","primary_ip":"133.242.233.183","certinfo":[],"primary_port":443,"local_ip":"202.172.26.42","local_port":59146,"message":""} [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:27:58] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - LOGIC START ["admin_store_plugin_install_confirm"] [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:27:58] php.INFO [96ec378f] [11ef253] [1] [Symfony\Component\Debug\ErrorHandler:handleError:532] - User Deprecated: The "Eccube\Service\Composer\ComposerApiService" service is private, getting it from the container is deprecated since Symfony 3.2 and will fail in 4.0. You should either make the service public, or stop using the container directly and use dependency injection instead. {"exception":"[object] (ErrorException(code: 0): User Deprecated: The \"Eccube\\Service\\Composer\\ComposerApiService\" service is private, getting it from the container is deprecated since Symfony 3.2 and will fail in 4.0. You should either make the service public, or stop using the container directly and use dependency injection instead. at /virtual/ansuz/public_html/www.we-ne.site/vendor/symfony/dependency-injection/Container.php:282)"} [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:27:58] admin.INFO [96ec378f] [11ef253] [1] [Eccube\Log\Logger:log:64] - PROCESS START ["admin_store_plugin_install_confirm"] [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:27:58] request.INFO [N/A] [11ef253] [N/A] [Symfony\Component\HttpKernel\EventListener\RouterListener:onKernelRequest:123] - Matched route "admin_store_plugin_install_confirm". {"route":"admin_store_plugin_install_confirm","route_parameters":{"_controller":"Eccube\\Controller\\Admin\\Store\\OwnerStoreController::doConfirm","id":"1761","_route":"admin_store_plugin_install_confirm"},"request_uri":"http://www.we-ne.site/kanri/store/plugin/api/install/1761/confirm","method":"GET"} [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]
[2020-11-16 11:27:58] admin.INFO [N/A] [11ef253] [N/A] [Eccube\Log\Logger:log:64] - INIT [] [GET, /kanri/store/plugin/api/install/1761/confirm, xxx.xxx.xxx.xxx, http://www.we-ne.site/kanri/store/plugin/api/search/page/5, Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0]

ec-cubeをインストールして、すぐにプラグインをインストールしても、状況は変わりません。
何が原因でインストールできないのでしょうか?
また対応方法を教えていただけますと助かります。
468
投稿日時: 2020/11/16 21:42
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 2701
Re: オーナーズストアのプラグインがインストールできない
以下のページに対処方法がまとめられています。
https://doc4.ec-cube.net/plugin_error

サーバスペックの関係でエラーが出ている場合もありますので
サーバを乗り換える必要があるかもしれません。
(共用レンタルサーバの場合、解決できない場合もあるかと思います)


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

NMAKINO
投稿日時: 2020/11/17 9:02
対応状況: −−−
新米
登録日: 2018/9/21
居住地:
投稿: 1
Re: オーナーズストアのプラグインがインストールできない
私も先日AWSにて同じような症状になりました
SSHでの接続は可能なサーバーでしょうか?
私の場合はAWSでしたが
1. SSHで接続しサーバーにSWAP領域を作成しました。
2. 以下のURLに記載されているようにコマンドラインを使用してインストールを実行しました

https://qiita.com/nanasess/items/791c9ec98f69ada93ea0

これで、私の場合は解決致しました。
参考に慣れば幸いです。
Locke
投稿日時: 2020/11/18 16:44
対応状況: −−−
新米
登録日: 2012/1/7
居住地:
投稿: 4
Re: オーナーズストアのプラグインがインストールできない
ありがとうございます。

参考にするページは見たことがありましたが、コマンドラインの使い方がよくわからなかったので、他のサイトなどに書かれていることだけを試していました。
今回、書かれているようにまずキャッシュのクリアから行いましたが、多分いきなりつまづいているように見えます。

コンソールに表示された内容の初めの部分だけ貼り付けてみます。

php bin/console cache:clear --no-warmup
PHP Notice: Undefined index: argv in /virtual/xxxxxx/public_html/www.xxxx.site/vendor/symfony/console/Input/ArgvInput.php on line 53
PHP Stack trace:
PHP 1. {main}() /virtual/xxxxxx/public_html/www.xxxx.site/bin/console:0
PHP 2. Symfony\Component\Console\Input\ArgvInput->__construct() /virtual/xxxxxx/public_html/www.xxxx.site/bin/console:26
PHP Warning: array_shift() expects parameter 1 to be array, null given in /virtual/xxxxxx/public_html/www.xxxx.site/vendor/symfony/console/Input/ArgvInput.php on line 57
PHP Stack trace:
PHP 1. {main}() /virtual/xxxxxx/public_html/www.xxxx.site/bin/console:0
PHP 2. Symfony\Component\Console\Input\ArgvInput->__construct() /virtual/xxxxxx/public_html/www.xxxx.site/bin/console:26
PHP 3. array_shift() /virtual/xxxxxx/public_html/www.xxxx.site/vendor/symfony/console/Input/ArgvInput.php:57
PHP Warning: Invalid argument supplied for foreach() in /virtual/xxxxxx/public_html/www.xxxx.site/vendor/symfony/console/Input/ArgvInput.php on line 302

この後スタックとレースが続いて、その後ろにコマンド・ヘルプが表示されます。
そもそものコマンドの使い方が違うのでしょうか?

レンタルサーバーの問題かもしれませんが、何かお判りのことがあれば教えていただけませんか?
よろしくお願いします。
Locke
投稿日時: 2020/11/30 16:14
対応状況: −−−
新米
登録日: 2012/1/7
居住地:
投稿: 4
Re: オーナーズストアのプラグインがインストールできない
すみません、説明不足の点がありました。

キャッシュのクリアについては、こちらに投稿前に管理画面から、またFTPの両方で試していました。
しかし、効果は全くなかったので、プラグインのインストールをコマンドラインで行うことにしてみました。
結果は前にお伝えした通りです。

コマンドラインの使い方が違っているのでしょうか?
(貼り付けた1行目が入力したコマンドです)

よろしくお願いします。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は67,511名です
総投稿数は98,889件です

投稿数ランキング

1
seasoft
7333
2
AMUAMU
2712
3
468
2701
4
nanasess
2116
5
umebius
1793
6
yuh
1612
7
red
1427
8
h_tanaka
1051
9
fukap
907
10
tsuji
863
11
shutta
835
12
tao_s
792
13 ramrun 789
14 karin 657
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.