バージョン選択

フォーラム

メニュー

オンライン状況

36 人のユーザが現在オンラインです。 (15 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 36
もっと...

サイト内検索

質問 > その他 > ver2.17を継続か、ver4で新規構築か

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
ComEcUser
投稿日時: 2021/1/28 17:44
対応状況: −−−
新米
登録日: 2020/8/22
居住地:
投稿: 7
ver2.17を継続か、ver4で新規構築か
現在、サイトで、EC-CUBE 2.17を使用しています。

2.17を使い続けるか、4をベースに同じ機能で作り直すか検討を進めています。
(両者はフレームワークが別なので、4にする場合、ほぼ新規構築という理解です)

4の方がパフォーマンス面などで優れているのは分かるのですが、2.17は開発元の公式サポートや、コミュニティサポートも継続しており、そこまで差し迫った理由がないので、判断に困っています。

2.17で、セキュリティやアーキテクチャ面など、何か決定的な欠点があれば、ご教示頂けないでしょうか。
例えば、2.17で使っているライブラリのサポートが切れてる、など。
coremobile
投稿日時: 2021/5/30 6:13
対応状況: −−−
一人前
登録日: 2018/8/30
居住地:
投稿: 107
Re: ver2.17を継続か、ver4で新規構築か
好き嫌いくらいの問題かと思います。
symphonyが好きであれば4ですね。
2はエスケープ忘れのリスクが付きまとうのがネックですが、ちゃんとソース管理していれば問題ないです。
nanasess
投稿日時: 2021/6/2 12:50
対応状況: −−−
登録日: 2006/9/9
居住地: 大阪
投稿: 2147
Re: ver2.17を継続か、ver4で新規構築か
先日、2.17 でエスケープ漏れがあった場合でも、危険なタグはエスケープする修正が取り込まれました。
https://github.com/EC-CUBE/ec-cube2/pull/458

性能は 2.13 の頃より大幅に改善されていますので、単純に性能比較した場合は4系よりもパフォーマンス良いかと。
https://github.com/EC-CUBE/ec-cube2/pull/296

2.17 のライブラリは、 GitHub で継続して保守されているものを使用しています。
4.1系で使用している Symfony3.4 のサポート期限は今年の11月までです。
https://symfony.com/releases/3.4

もうすぐ、Symfony4.4 を採用した EC-CUBE4.1がリリースされると思いますが、 PHP7.4 のサポート期限が来年11月に迫っているため、その頃には EC-CUBE5系? がリリースされるかもしれません。(あくまでも個人的な予想です)


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
スキルニル株式会社

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は71,640名です
総投稿数は101,383件です

投稿数ランキング

1
seasoft
7333
2
468
2999
3
AMUAMU
2712
4
nanasess
2147
5
umebius
2006
6
yuh
1612
7
red
1450
8
h_tanaka
1080
9
tsuji
936
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.