バージョン選択

フォーラム

メニュー

オンライン状況

20 人のユーザが現在オンラインです。 (13 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 19
masterR もっと...

サイト内検索

プラグイン > 開発について > 関連商品プラグインについて インストールが失敗する。

開発について

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
hegurin
投稿日時: 2021/2/5 15:48
対応状況: 開発中
新米
登録日: 2021/2/5
居住地:
投稿: 1
関連商品プラグインについて インストールが失敗する。
▼テンプレート
[EC-CUBE]
4.0.4 新規インストール

[レンタルサーバ]
Linux 4.18.0-147.5.1.el8_1.x86_64 #1 SMP Wed Feb 5 02:00:39 UTC 2020 x86_64

[OS] 使用しているOS名、バージョン
NAME="CentOS Linux"
VERSION="8 (Core)"

[PHP] 使用しているPHPのバージョン
PHP Version 7.4.8

[データベース] 使用しているDB名、バージョン
MySQL 8.0.21

[WEBサーバ] 使用しているWEBサーバ名、バージョン
Apache

[ブラウザ] 使用しているブラウザ名、バージョン
chrome

[導入プラグインの有無] あれば導入プラグインを記載
https://www.ec-cube.net/products/detail.php?product_id=1761

[カスタマイズの有無] あればカスタマイズ内容を記載(できるだけ具体的に)


[現象] 再現手順や、どのような現象が発生しているかなど、具体的に

関連商品プラグインについて
https://www.ec-cube.net/products/detail.php?product_id=1761

当プラグインをインストールしようとするとエラーになり利用できませんでした。
何が原因なのか、どう対処すればよいのか教示いただけるでしょうか。


【インストール画面からのエラーログ】
何度か試しましたが、2種類のエラーログが出力されています。


**************** RelatedProduct4 ****************
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>504 Gateway Timeout</title>
</head><body>
<h1>Gateway Timeout</h1>
<p>The gateway did not receive a timely response
from the upstream server or application.</p>
</body></html>



**************** RelatedProduct4 ****************
<warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[31.5MiB/1.44s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[210.5MiB/3.22s] Using version ^4.0 for ec-cube/RelatedProduct4
[210.5MiB/3.23s] ./composer.json has been updated
[210.8MiB/3.34s] <warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[214.1MiB/3.52s] Loading composer repositories with package information
[215.2MiB/4.82s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[215.3MiB/4.83s] Updating dependencies (including require-dev)
[644.0MiB/49.01s] Package operations: 41 installs, 0 updates, 0 removals
[644.0MiB/49.71s] - Installing ec-cube/relatedproduct4 (4.0.1): [644.0MiB/49.83s] Loading from cache[644.0MiB/49.83s]
[640.7MiB/49.86s]
Installation failed, reverting ./composer.json to its original content.

In LibraryInstaller.php line 134:

Package is not installed: ec-cube/relatedproduct4-4.0.1.0


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...


{"success":false,"log":"\u003Cwarning\u003EDeprecation warning: require.ec-cube\/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube\/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[31.5MiB\/1.44s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https:\/\/getcomposer.org\/2\u003C\/warning\u003E\n[210.5MiB\/3.22s] Using version ^4.0 for ec-cube\/RelatedProduct4\n[210.5MiB\/3.23s] .\/composer.json has been updated\n[210.8MiB\/3.34s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube\/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[214.1MiB\/3.52s] Loading composer repositories with package information\n[215.2MiB\/4.82s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https:\/\/getcomposer.org\/2\u003C\/warning\u003E\n[215.3MiB\/4.83s] Updating dependencies (including require-dev)\n[644.0MiB\/49.01s] Package operations: 41 installs, 0 updates, 0 removals\n[644.0MiB\/49.71s] - Installing ec-cube\/relatedproduct4 (4.0.1): [644.0MiB\/49.83s] Loading from cache[644.0MiB\/49.83s] \n[640.7MiB\/49.86s] \nInstallation failed, reverting .\/composer.json to its original content.\n\nIn LibraryInstaller.php line 134:\n \n Package is not installed: ec-cube\/relatedproduct4-4.0.1.0 \n \n\nrequire [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [\u003Cpackages\u003E]...\n\n"}

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は71,530名です
総投稿数は101,307件です

投稿数ランキング

1
seasoft
7333
2
468
2998
3
AMUAMU
2712
4
nanasess
2147
5
umebius
2000
6
yuh
1612
7
red
1449
8
h_tanaka
1080
9
tsuji
936
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.