バージョン選択

フォーラム

メニュー

オンライン状況

21 人のユーザが現在オンラインです。 (15 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 21
もっと...

サイト内検索

質問 > その他 > GMO EC-CUBEペイメント決済プラグイン(4.0系)のインストールエラー

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
kasafumi
投稿日時: 2021/3/1 17:57
対応状況: −−−
新米
登録日: 2021/2/26
居住地:
投稿: 4
GMO EC-CUBEペイメント決済プラグイン(4.0系)のインストールエラー
▼テンプレート
[EC-CUBE] 4.0.3 新規
[レンタルサーバ] GMO ALTUS
[OS]  CentOS 7
[PHP] 7.2.34
[データベース] PostgreSQL 10.16
[WEBサーバ] Apache 2.4.6
[ブラウザ]   Firefox
[導入プラグインの有無] なし
[カスタマイズの有無] あり
[現象] GMOペイメント決済プラグインをインストールすると下記エラーが発生。
ComposerのバージョンでWarningが出ているので影響しているのかとselfupdateコマンドで1系にしたり2系にしたりして試したが状況は変わらず。お分かりになる方いましたらご教示よろしくお願い致します。


**************** GmoPaymentGateway4 ****************
[12.2MiB/1.08s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[191.5MiB/2.16s] Using version ^1.0 for ec-cube/GmoPaymentGateway4
[191.5MiB/2.16s] ./composer.json has been updated
[191.9MiB/2.18s] <warning>Deprecation warning: require.ec-cube/GmoPaymentGateway4 is invalid, it should not contain uppercase characters. Please use ec-cube/gmopaymentgateway4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[195.8MiB/2.58s] Loading composer repositories with package information
[197.0MiB/3.64s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[197.0MiB/3.64s] Updating dependencies (including require-dev)
[628.0MiB/29.16s] Package operations: 1 install, 0 updates, 0 removals
[628.0MiB/29.16s] - Installing ec-cube/gmopaymentgateway4 (1.0.8): [628.0MiB/29.16s] Loading from cache[628.0MiB/29.16s]
[624.8MiB/29.17s]
Installation failed, reverting ./composer.json to its original content.

In LibraryInstaller.php line 134:

Package is not installed: ec-cube/gmopaymentgateway4-1.0.8.0


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...


{"success":false,"log":"[12.2MiB\/1.08s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https:\/\/getcomposer.org\/2\u003C\/warning\u003E\n[191.5MiB\/2.16s] Using version ^1.0 for ec-cube\/GmoPaymentGateway4\n[191.5MiB\/2.16s] .\/composer.json has been updated\n[191.9MiB\/2.18s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/GmoPaymentGateway4 is invalid, it should not contain uppercase characters. Please use ec-cube\/gmopaymentgateway4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[195.8MiB\/2.58s] Loading composer repositories with package information\n[197.0MiB\/3.64s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https:\/\/getcomposer.org\/2\u003C\/warning\u003E\n[197.0MiB\/3.64s] Updating dependencies (including require-dev)\n[628.0MiB\/29.16s] Package operations: 1 install, 0 updates, 0 removals\n[628.0MiB\/29.16s] - Installing ec-cube\/gmopaymentgateway4 (1.0.8): [628.0MiB\/29.16s] Loading from cache[628.0MiB\/29.16s] \n[624.8MiB\/29.17s] \nInstallation failed, reverting .\/composer.json to its original content.\n\nIn LibraryInstaller.php line 134:\n \n Package is not installed: ec-cube\/gmopaymentgateway4-1.0.8.0 \n \n\nrequire [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [\u003Cpackages\u003E]...\n\n"}

kasafumi
投稿日時: 2021/3/2 12:15
対応状況: 解決済
新米
登録日: 2021/2/26
居住地:
投稿: 4
Re: GMO EC-CUBEペイメント決済プラグイン(4.0系)のインストールエラー
自己レスです。
本質的な原因は不明ですが、以下の手順で解決しました。

1.動作済みの開発環境から「app/plugin/GmoPaymentGateway4」フォルダごと本番環境へコピーする。
2.「bin/console eccube:plugin:install --code=GmoPaymentGateway4」
コマンドを投入する。
  ⇒gen -> /tmp/proxy_U1VQa4zJehoy/src/Eccube/Entity/Customer.php
gen -> /tmp/proxy_U1VQa4zJehoy/src/Eccube/Entity/OrderItem.php
gen -> /tmp/proxy_U1VQa4zJehoy/src/Eccube/Entity/Order.php
gen -> /tmp/proxy_U1VQa4zJehoy/src/Eccube/Entity/ProductClass.php
gen -> /tmp/proxy_U1VQa4zJehoy/src/Eccube/Entity/Product.php
gen -> /tmp/proxy_U1VQa4zJehoy/src/Eccube/Entity/Payment.php

// Clearing the cache for the prod environment with debug
// false

[OK] Cache for the "prod" environment (debug=false) was successfully cleared.

[OK] Installed.
という結果で表示され、管理画面で見るとインストール済みとなった。
3.管理画面から有効化を行う。

以上です。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は71,659名です
総投稿数は101,392件です

投稿数ランキング

1
seasoft
7333
2
468
2999
3
AMUAMU
2712
4
nanasess
2147
5
umebius
2006
6
yuh
1612
7
red
1450
8
h_tanaka
1080
9
tsuji
936
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.