バージョン選択

フォーラム

メニュー

オンライン状況

13 人のユーザが現在オンラインです。 (7 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 13
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > プラグインがインストールできません、、

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
snow.1203
投稿日時: 2021/5/7 21:38
対応状況: −−−
新米
登録日: 2018/8/22
居住地:
投稿: 9
プラグインがインストールできません、、
▼テンプレート
[EC-CUBE] 4.0.5、新規インストール
[レンタルサーバ] さくらインターネット スタンダードプラン 共有サーバ
[OS] macOS Catalina 10.15.2
[PHP] PHP Version 7.3.27
[データベース] MySQL 5.7
[ブラウザ] グーグルクローム 90.0.4430.85

[現象] インストール後、商品をアップしました。その後決済システム(zeus)や商品並び替えのプラグインをインストールしようとしたところインストールができません、、

具体的にはインストールが完了しました、と出るのですが有効化等はできないのでインストールは出来ていないのが現状です。。

キャッシュかと思い、消したりしているのですがそれでも変わりありません。

インストール時のバグかと思い、念のためフォメイン直下に別フォルダを作り、新たにeccubeをインストールしてみましたが、こちらも同じ現象が起こりました。。

またバージョンの問題かと思い古いバージョン(4.0.3)をインストールしてプラグインをインストールしようとするとこちらではシステムエラーが発生しました。と出てしまいます。。

当方eccube2から使っていて複数のeccubeをインストールしたことはあるのですが今回のようにどうしようもなくなってしまったのは初です。状況的にキャッシュかバージョンの問題のような気がするのですが全くわかりません。

二年前にeccube4.03でショップを作った時は問題なくプラグインはインストールできていたのですが。。(今もそのショップは同じドメインの別フォルダで稼働中です)(ちなみに同じドメイン内で複数ショップをeccubeで動かしています)

どなたかお力添えいただけたら幸いでございます。
coremobile
投稿日時: 2021/5/8 13:26
対応状況: −−−
一人前
登録日: 2018/8/30
居住地:
投稿: 107
Re: プラグインがインストールできません、、
インストール時や有効化時にエラーログは出力されていませんか?
snow.1203
投稿日時: 2021/5/8 14:49
対応状況: −−−
新米
登録日: 2018/8/22
居住地:
投稿: 9
Re: プラグインがインストールできません、、
ご返信ありがとうございます!

インストール時に今まで気にしてなかったのですが、

mod_rewrite が有効になっているか不明です。
× [推奨] apc拡張モジュールが有効になっていません。

が出てきています。。

こちらが原因ぽいでしょうか?
snow.1203
投稿日時: 2021/5/8 19:13
対応状況: −−−
新米
登録日: 2018/8/22
居住地:
投稿: 9
Re: プラグインがインストールできません、、
追記なのですがインストールを押して完了すると以下のようなログが表示されます。(インストールはされてません)
分かる方ご教授いただければ幸いです、、

**************** ZeusPayment4 ****************
<warning>Deprecation warning: require.ec-cube/SortProduct is invalid, it should not contain uppercase characters. Please use ec-cube/sortproduct instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SortProduct4Plus is invalid, it should not contain uppercase characters. Please use ec-cube/sortproduct4plus instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ZeusPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/zeuspayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[13.7MiB/1.35s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[200.4MiB/2.95s] Using version ^1.0 for ec-cube/ZeusPayment4
[200.4MiB/2.95s] ./composer.json has been updated
[200.8MiB/3.27s] <warning>Deprecation warning: require.ec-cube/SortProduct is invalid, it should not contain uppercase characters. Please use ec-cube/sortproduct instead. Make sure you fix this as Composer 2.0 will error.</warning>
[200.8MiB/3.27s] <warning>Deprecation warning: require.ec-cube/SortProduct4Plus is invalid, it should not contain uppercase characters. Please use ec-cube/sortproduct4plus instead. Make sure you fix this as Composer 2.0 will error.</warning>
[200.8MiB/3.27s] <warning>Deprecation warning: require.ec-cube/ZeusPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/zeuspayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[204.6MiB/4.19s] <warning>Dependency "ec-cube/plugin-installer" is also a root requirement, but is not explicitly whitelisted. Ignoring.</warning>
[204.4MiB/4.19s] Loading composer repositories with package information
[205.7MiB/5.63s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[205.7MiB/5.63s] Updating dependencies (including require-dev)
[650.5MiB/39.31s] Nothing to install or update
[647.7MiB/39.38s] <warning>Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.</warning>
[647.7MiB/39.38s] <warning>Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.</warning>
[647.7MiB/39.38s] <warning>Package easycorp/easy-log-handler is abandoned, you should avoid using it. No replacement was suggested.</warning>
[647.7MiB/39.38s] <warning>Package facebook/webdriver is abandoned, you should avoid using it. Use php-webdriver/webdriver instead.</warning>
[647.7MiB/39.38s] <warning>Package fzaninotto/faker is abandoned, you should avoid using it. No replacement was suggested.</warning>
[647.7MiB/39.38s] <warning>Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.</warning>
[647.7MiB/39.38s] <warning>Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.</warning>
[647.7MiB/39.38s] <warning>Package sensio/generator-bundle is abandoned, you should avoid using it. Use symfony/maker-bundle instead.</warning>
[647.7MiB/39.38s] <warning>Package setasign/fpdi-tcpdf is abandoned, you should avoid using it. No replacement was suggested.</warning>
[647.7MiB/39.38s] <warning>Package twig/extensions is abandoned, you should avoid using it. No replacement was suggested.</warning>
[647.7MiB/39.38s] <warning>Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.</warning>
[647.7MiB/39.38s] <warning>Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.</warning>
[648.5MiB/40.18s] Generating optimized autoload files
[649.7MiB/44.94s] Memory usage: 649.69MiB (peak: 753.48MiB), time: 44.94s
snow.1203
投稿日時: 2021/5/13 14:43
対応状況: −−−
新米
登録日: 2018/8/22
居住地:
投稿: 9
Re: プラグインがインストールできません、、
こちら色々調べていますが、いまだに解決できず、、わかりそうな方いたら是非アドバイスいただけますと幸いです!!!
red
投稿日時: 2021/5/13 15:05
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1453
Re: プラグインがインストールできません、、
・モジュール版のPHPを使う
・共有レンサバは避ける
・sshでコマンドラインからコマンド叩く
ぐらいしか対処法はないと思います


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

snow.1203
投稿日時: 2021/5/18 17:02
対応状況: −−−
新米
登録日: 2018/8/22
居住地:
投稿: 9
Re: プラグインがインストールできません、、
やはりそうなんですかね、、、ご教授ありがとうございます。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は73,080名です
総投稿数は102,130件です

投稿数ランキング

1
seasoft
7333
2
468
3078
3
AMUAMU
2712
4
nanasess
2180
5
umebius
2030
6
yuh
1612
7
red
1453
8
h_tanaka
1090
9
tsuji
936
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.