バージョン選択

フォーラム

メニュー

オンライン状況

28 人のユーザが現在オンラインです。 (11 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 28
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > 有料のプラグインがインストールできない

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
tanakasan
投稿日時: 2021/10/5 17:13
対応状況: −−−
新米
登録日: 2020/5/26
居住地:
投稿: 8
有料のプラグインがインストールできない
▼テンプレート
[EC-CUBE]4.0.6-p1
[レンタルサーバ]CPI
[PHP]7.3

上記の環境で管理画面から有料のプラグインをインストールしようとしたところ500エラーが発生してインストールできない状態が続いております。
無料のプラグインは問題なくインストールできるのですが、有料プラグイン(6つほど購入)が軒並みインストールできません。

認証キーも問題なく設定しているのと、コマンドからインストールを試みたのですが、そちらもできませんでした。


インストール時に以下のようなエラーメッセージが出ます。

Changed CWD to /usr/home/html/shop
Reading ./composer.json
Loading config file ./composer.json
Executing command (/usr/home/html/shop): git branch --no-color --no-abbrev -v
Executing command (/usr/home/html/shop): git describe --exact-match --tags
Executing command (/usr/home/html/shop): git log --pretty="%H" -n1 HEAD
Executing command (/usr/home/html/shop): hg branch
Executing command (/usr/home/html/shop): fossil branch list
Executing command (/usr/home/html/shop): fossil tag list
Executing command (/usr/home/html/shop): svn info --xml
<warning>Deprecation warning: require.ec-cube/AdminSecurity4 is invalid, it should not contain uppercase characters. Please use ec-cube/adminsecurity4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/CheckProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/checkproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ContactManagement4 is invalid, it should not contain uppercase characters. Please use ec-cube/contactmanagement4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Coupon4 is invalid, it should not contain uppercase characters. Please use ec-cube/coupon4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/MGSearchProduct is invalid, it should not contain uppercase characters. Please use ec-cube/mgsearchproduct instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/OrderBulkDelete4 is invalid, it should not contain uppercase characters. Please use ec-cube/orderbulkdelete4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/OrderBySale4 is invalid, it should not contain uppercase characters. Please use ec-cube/orderbysale4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ProductContact4 is invalid, it should not contain uppercase characters. Please use ec-cube/productcontact4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Recommend4 is invalid, it should not contain uppercase characters. Please use ec-cube/recommend4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SalesReport4 is invalid, it should not contain uppercase characters. Please use ec-cube/salesreport4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SimpleMaintenance is invalid, it should not contain uppercase characters. Please use ec-cube/simplemaintenance instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Taba2FA is invalid, it should not contain uppercase characters. Please use ec-cube/taba2fa instead. Make sure you fix this as Composer 2.0 will error.</warning>
Failed to initialize global composer: Composer could not find the config file: /usr/home/html/shop/app/Plugin/.composer/composer.json
To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ "Getting Started" section
Reading /usr/home/html/shop/vendor/composer/installed.json
Loading plugin Symfony\Flex\Flex_composer_tmp0
Loading plugin UpdateHelper\ComposerPlugin_composer_tmp1
Loading plugin Eccube\Composer\EccubePluginInstallerPlugin_composer_tmp2
Loading plugin PackageVersions\Installer_composer_tmp3
Running 1.9.1 (2019-11-01 17:20:17) with PHP 7.2.34 on FreeBSD / 11.4-RELEASE-p9
Downloading https://package-api.ec-cube.net/packages.json
Retrying download: SSL certificate problem: certificate has expired
Downloading https://package-api.ec-cube.net/packages.json
Retrying download: SSL certificate problem: certificate has expired
Downloading https://package-api.ec-cube.net/packages.json
Retrying download: SSL certificate problem: certificate has expired
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---package-api.ec-cube.net/packages.json from cache
<warning>The "https://package-api.ec-cube.net/packages.json" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed</warning>
<warning>https://package-api.ec-cube.net could not be fully loaded, package information was loaded from the local cache and may be out of date</warning>
Downloading https://repo.packagist.org/packages.json
<warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
Writing /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/packages.json into cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2013.json from cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2014.json from cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2015.json from cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2016.json from cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2017.json from cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2018.json from cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2019.json from cache
Downloading http://repo.packagist.org/p/provider-2020%240d3a1cfa8f88444b6509d639e8e257f0eb831353ab0b0458c54954b2667988c0.json
Writing /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2020.json into cache
Downloading http://repo.packagist.org/p/provider-2021-01%245eeb352ea6dff92413e380f4526d15bbed6c6c2c9dd1fa568e74450226cd1853.json
Writing /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2021-01.json into cache
Downloading http://repo.packagist.org/p/provider-2021-04%24d8b7aeb6a9eb2502a3d14d1e88119612cf20ed3bab76bad738be5412856e3ccb.json
Writing /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2021-04.json into cache
Downloading http://repo.packagist.org/p/provider-2021-07%24ccd533f4d38acfb6861d38e9304b7ba14f45c3f72a5c340af0f07d4ee8082a7c.json
Writing /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-2021-07.json into cache
Reading /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-archived.json from cache
Downloading http://repo.packagist.org/p/provider-latest%24ae7b726c83dfc687d754e8261add38c345cbf990518de58409c77c2230094598.json
Writing /usr/home/html/shop/app/Plugin/.composer/cache/repo/https---repo.packagist.org/p-provider-latest.json into cache
Package ec-cube/SheebDlc4 not found in /usr/home//html/shop/composer.json

原因がわからないのですが、おわかりになりますでしょうか?
Histandard
投稿日時: 2021/10/14 17:25
対応状況: −−−
新米
登録日: 2019/11/27
居住地:
投稿: 8
Re: 有料のプラグインがインストールできない
はじめまして。

他のプラグインですが、インストールができずにまったく同じ現象で同じエラーとなっており、色々調べておりこちらにたどり着きました。

まだ自分も解決はできず、エラーを調べていた感じですが、以下の箇所のSSL通信で失敗をしているようです。

<warning>The "https://package-api.ec-cube.net/packages.json" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed</warning>

自分の場合はSSL証明書を確認しても問題はなさそうに見えるのですが、なぜ駄目なのかが分からずです。
Histandard
投稿日時: 2021/10/20 19:09
対応状況: −−−
新米
登録日: 2019/11/27
居住地:
投稿: 8
Re: 有料のプラグインがインストールできない
こちら、私の方は解決ができました。

エラーの通りでSSLの証明書の問題だったようです。

私の場合はこちらの記事が問題となっていました。
https://japan.zdnet.com/article/35177496/
tanakasan
投稿日時: 2021/10/21 3:34
対応状況: −−−
新米
登録日: 2020/5/26
居住地:
投稿: 8
Re: 有料のプラグインがインストールできない
やはりSSL証明書の問題でしたか。
ちなみにどのような対応を行ったのでしょうか?
Histandard
投稿日時: 2021/10/21 9:45
対応状況: −−−
新米
登録日: 2019/11/27
居住地:
投稿: 8
Re: 有料のプラグインがインストールできない
当方はあまりこのあたりは詳しくはない為、色々と試してみてなんとかできたという感じでしたので、これでできるという確証はありませんが、このような流れでした。

1、Let's EncryptのISRG Root X1のルート証明書のpemファイルをダウンロード( https://letsencrypt.org/certificates/

2、サーバーのcert.pemに追加をする必要があるので、ダウンロードしたpemを以下に設置
/etc/pki/ca-trust/source/anchors

※直接cert.pemに追加だと証明書の更新コマンド叩くと消えたので、別の箇所に設置する必要がありました。また、ここはサーバーによって設置場所が違うかもです。

3,古いルート証明書(DST Root CA X3)が残った状態となっているので、これを消さないと動かなかったので消す。(ここがハマりました・・)
/usr/share/pki/ca-trust-source/ca-bundle.trust.p11-kit

※私の場合はここでしたがOSによって場所が違うかもです。grepかけて探してみると良いかもしれません。

4、最後に証明書の更新コマンドを叩く
update-ca-trust extract

5、nginx再起動

以上です。
Histandard
投稿日時: 2021/10/21 9:53
対応状況: −−−
新米
登録日: 2019/11/27
居住地:
投稿: 8
Re: 有料のプラグインがインストールできない
もうひとつ、これも関係するのかわかりませんが、
私の場合はopensslの設定の記載がなかったので、php.iniに以下を追記しました。

curl.cainfo =/etc/pki/ca-trust/extracted/pem/tls-ca-bundle.pem
openssl.cafile=/etc/pki/ca-trust/extracted/openssl/ca-bundle.trust.crt

※ここのSSL証明書の場所もサーバーによって違うかもです。絶対パスで指定する必要があります。


スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は73,404名です
総投稿数は102,492件です

投稿数ランキング

1
seasoft
7333
2
468
3112
3
AMUAMU
2712
4
nanasess
2187
5
umebius
2036
6
yuh
1615
7
red
1454
8
h_tanaka
1140
9
tsuji
936
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.