バージョン選択

フォーラム

メニュー

オンライン状況

29 人のユーザが現在オンラインです。 (14 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 28
rrr2nd2 もっと...

サイト内検索

その他 > バージョンアップ > クロネコヤマト カード・後払い一体型決済サービスのアップデートができません。

バージョンアップ

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
HYHR
投稿日時: 2021/11/30 16:33
対応状況: −−−
半人前
登録日: 2020/6/12
居住地:
投稿: 14
クロネコヤマト カード・後払い一体型決済サービスのアップデートができません。
[EC-CUBE]4.0.6 新規インストール後アップデート
[レンタルサーバ]WADAX
[PHP] 7.3.4
[データベース] MySQL 5.7.24-log
[WEBサーバ] Apache
[ブラウザ] Google Chrome
[現象] クロネコヤマト カード・後払い一体型決済サービスのアップデートを1.2.2から1.4へアップロードを試みましたが、更新処理中の時点でシステムエラーが発生しました。ログは下記のとおりです。

**************** Disable ****************
**************** Upgrade ****************
<warning>Deprecation warning: require.ec-cube/Api is invalid, it should not contain uppercase characters. Please use ec-cube/api instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/EccubeUpdater405to406 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater405to406 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SEOAllOne is invalid, it should not contain uppercase characters. Please use ec-cube/seoallone instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/YamatoPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/yamatopayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[32.9MiB/1.48s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[231.9MiB/3.02s] ./composer.json has been updated
[232.3MiB/3.09s] <warning>Deprecation warning: require.ec-cube/Api is invalid, it should not contain uppercase characters. Please use ec-cube/api instead. Make sure you fix this as Composer 2.0 will error.</warning>
[232.3MiB/3.09s] <warning>Deprecation warning: require.ec-cube/EccubeUpdater405to406 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater405to406 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[232.3MiB/3.09s] <warning>Deprecation warning: require.ec-cube/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.</warning>
[232.3MiB/3.09s] <warning>Deprecation warning: require.ec-cube/SEOAllOne is invalid, it should not contain uppercase characters. Please use ec-cube/seoallone instead. Make sure you fix this as Composer 2.0 will error.</warning>
[232.3MiB/3.09s] <warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[232.3MiB/3.09s] <warning>Deprecation warning: require.ec-cube/YamatoPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/yamatopayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[235.9MiB/3.21s] <warning>Dependency "ec-cube/plugin-installer" is also a root requirement, but is not explicitly whitelisted. Ignoring.</warning>
[235.7MiB/3.21s] Loading composer repositories with package information
[237.3MiB/5.54s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[237.4MiB/5.55s] Updating dependencies
[720.9MiB/21.48s] <warning>Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.</warning>
[720.9MiB/21.48s] <warning>Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.</warning>
[720.9MiB/21.48s] <warning>Package easycorp/easy-log-handler is abandoned, you should avoid using it. No replacement was suggested.</warning>
[720.9MiB/21.48s] <warning>Package sensio/generator-bundle is abandoned, you should avoid using it. Use symfony/maker-bundle instead.</warning>
[720.9MiB/21.48s] <warning>Package setasign/fpdi-tcpdf is abandoned, you should avoid using it. No replacement was suggested.</warning>
[720.9MiB/21.48s] <warning>Package swiftmailer/swiftmailer is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[720.9MiB/21.48s] <warning>Package symfony/inflector is abandoned, you should avoid using it. Use use `EnglishInflector` from the String component instead instead.</warning>
[720.9MiB/21.48s] <warning>Package twig/extensions is abandoned, you should avoid using it. No replacement was suggested.</warning>
[720.9MiB/21.48s] <warning>Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.</warning>
[720.9MiB/21.48s] <warning>Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.</warning>
[722.0MiB/21.49s] Generating optimized autoload files
[724.9MiB/25.61s] <warning>Warning: Ambiguous class resolution, "Eccube\Entity\Shipping" was found in both "$baseDir . '/app/proxy/entity/src/Eccube/Entity/Shipping.php" and "/home/1506962763/gdefence-com/public_html/cp-bin/eccube4/src/Eccube/Entity/Shipping.php", the first will be used.</warning>
[724.9MiB/25.61s] <warning>Warning: Ambiguous class resolution, "Eccube\Entity\Order" was found in both "$baseDir . '/app/proxy/entity/src/Eccube/Entity/Order.php" and "/home/1506962763/gdefence-com/public_html/cp-bin/eccube4/src/Eccube/Entity/Order.php", the first will be used.</warning>
[724.9MiB/25.61s] <warning>Warning: Ambiguous class resolution, "Eccube\Entity\Product" was found in both "$baseDir . '/app/proxy/entity/src/Eccube/Entity/Product.php" and "/home/1506962763/gdefence-com/public_html/cp-bin/eccube4/src/Eccube/Entity/Product.php", the first will be used.</warning>
[723.2MiB/26.53s] Memory usage: 723.24MiB (peak: 842.83MiB), time: 26.53s

**************** Schema Update ****************
**************** Update ****************
<br />
<b>Fatal error</b>: require(): Failed opening required '/home/1506962763/gdefence-com/public_html/cp-bin/eccube4/var/cache/prod/doctrine/orm/Proxies/__CG__EccubeEntityPayment.php' (include_path='.:/usr/local/php73/share/pear') in <b>/home/1506962763/gdefence-com/public_html/cp-bin/eccube4/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php</b> on line <b>206</b><br />
<!doctype html>
<html lang="ja">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<title>システムエラーが発生しました。</title>
<meta name="robots" content="noindex,nofollow"/>
<link rel="icon" href="/cp-bin/eccube4/html/template/admin/assets/img/favicon.ico">
<link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet" integrity="sha384-wvfXpqpZZVQGK6TAh5PVlGOfQNHSoD2xbE+QkPxCAFlNEevoEH3Sl0sibVcOQVnN" crossorigin="anonymous">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.3.1/css/all.css">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css">
<link rel="stylesheet" href="/cp-bin/eccube4/html/template/admin/assets/css/bootstrap.css">
<script src="https://code.jquery.com/jquery-3.3.1.min.js" integrity="sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=" crossorigin="anonymous"></script>
</head>
<body id="error-page" class="bg-light">

<div class="c-container">
<div class="c-contentsArea">


<div class="container" style="margin-top: 150px;">
<div class="row">
<div class="col-12 col-sm-6 offset-sm-3">

<div class="text-center p-5 bg-white">
<h3><i class="fa fa-exclamation-triangle fa-lg ml-1"></i>システムエラーが発生しました。</h3>
<p>大変お手数ですが、サイト管理者までご連絡ください。</p>
<a href="/cp-bin/eccube4/gjpsakai/" class="btn btn-info btn-lg">ログイン画面へ</a>
</div>
</div>
</div>
</div>

</div>
</div>

<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.7/umd/popper.min.js" integrity="sha384-UO2eT0CpHqdSJQ6hJty5KVphtPhzWj9WO1clHTMGa3JDZwrnQq4sF86dIHNDz0W1" crossorigin="anonymous"></script>
<script src="https://stackpath.bootstrapcdn.com/bootstrap/4.3.1/js/bootstrap.min.js" integrity="sha384-JjSmVgyd0p3pXB1rRibZUAYoIIy6OrQ6VrjIEaFf/nJGzIxFDsf4x0xIM+B07jRM" crossorigin="anonymous"></script>
<script src="/cp-bin/eccube4/html/template/admin/assets/js/function.js"></script>
</body>
</html>

どうしたら正常にアップデートができるかご教授のほどよろしくお願いします。
Buchiii
投稿日時: 2021/12/1 17:27
対応状況: −−−
半人前
登録日: 2020/10/9
居住地:
投稿: 23
Re: クロネコヤマト カード・後払い一体型決済サービスのアップデートができません。
HYHR 様

直接のエラー原因は以下の箇所のようです。

```
<b>Fatal error</b>: require(): Failed opening required '/home/1506962763/gdefence-com/public_html/cp-bin/eccube4/var/cache/prod/doctrine/orm/Proxies/__CG__EccubeEntityPayment.php' (include_path='.:/usr/local/php73/share/pear') in
```

Proxyのキャッシュ関連のエラーかと思いますため、
以下のページにも記載されている以下コマンドを実行いただければ
改善しないでしょうか?

https://doc4.ec-cube.net/quickstart/cli


```
cd {EC-CUBEのディレクトリ}
bin/console cache:clear --no-warmup
bin/console eccube:generate:proxies
```

ご確認お願いいたします。
HYHR
投稿日時: 2021/12/1 18:24
対応状況: −−−
半人前
登録日: 2020/6/12
居住地:
投稿: 14
Re: クロネコヤマト カード・後払い一体型決済サービスのアップデートができません。
メッセージありがとうございます。
全くの素人で申し訳ございませんが、コマンドの実行の仕方がよくわかりません。
windowsのアクセサリにある、コマンドプロンプトみたいな何かソフトをインストールする必要があるのか。
また、EC-CUBEのルートディレクトリは、どの部分を入力すればいいのかをご教授いただければ幸いです。

恐れ入りますが、よろしくお願いします。
HYHR
投稿日時: 2021/12/2 12:41
対応状況: −−−
半人前
登録日: 2020/6/12
居住地:
投稿: 14
Re: クロネコヤマト カード・後払い一体型決済サービスのアップデートができません。
コマンドラインにつき、いろいろ調べてみましたが、私がEC-CUBE 4をインストールしているWADAXの共用サーバーでは、コマンドラインは使用できませんとなっておりました。
コマンドラインを使用しない方法をご教授いただければ幸いです。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン

右上バナー


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は74,046名です
総投稿数は103,388件です

投稿数ランキング

1
seasoft
7333
2
468
3153
3
AMUAMU
2712
4
nanasess
2193
5
umebius
2052
6
yuh
1664
7
red
1462
8
h_tanaka
1170
9
tsuji
942
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.