バージョン選択

フォーラム

メニュー

オンライン状況

29 人のユーザが現在オンラインです。 (12 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 29
もっと...

サイト内検索

質問 > 管理機能 > クーポンプラグインが導入できない

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
daisuke888
投稿日時: 2022/8/8 12:36
対応状況: −−−
新米
登録日: 2022/8/8
居住地:
投稿: 1
クーポンプラグインが導入できない
▼テンプレート
[EC-CUBE] EC-CUBEのバージョン 4.0.6-p1
[レンタルサーバ] さくら
[現象] クーポンプラグインをインストールすると以下エラー文が出てきてインストールできません。
対処法ご存知の方いらっしゃればご教示いただけると幸いです。
よろしくお願い致します。

**************** Coupon4 ****************
<warning>Deprecation warning: require.ec-cube/Coupon4 is invalid, it should not contain uppercase characters. Please use ec-cube/coupon4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/PayPalCheckout is invalid, it should not contain uppercase characters. Please use ec-cube/paypalcheckout instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[10.4MiB/1.32s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[10.4MiB/1.33s] Info from https://repo.packagist.org: [37;44m#StandWith[30;43mUkraine[0m
[223.1MiB/2.95s] Using version ^4.1 for ec-cube/Coupon4
[223.1MiB/2.95s] ./composer.json has been updated
[223.5MiB/3.01s] <warning>Deprecation warning: require.ec-cube/Coupon4 is invalid, it should not contain uppercase characters. Please use ec-cube/coupon4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[223.5MiB/3.01s] <warning>Deprecation warning: require.ec-cube/PayPalCheckout is invalid, it should not contain uppercase characters. Please use ec-cube/paypalcheckout instead. Make sure you fix this as Composer 2.0 will error.</warning>
[223.5MiB/3.01s] <warning>Deprecation warning: require.ec-cube/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube/productreview4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[223.5MiB/3.01s] <warning>Deprecation warning: require.ec-cube/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.4MiB/3.15s] Loading composer repositories with package information
[228.1MiB/4.44s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[228.1MiB/4.44s] Info from https://repo.packagist.org: [37;44m#StandWith[30;43mUkraine[0m
[228.2MiB/4.44s] Updating dependencies
[760.3MiB/36.14s] Package operations: 1 install, 0 updates, 0 removals
[760.3MiB/36.14s] - Installing ec-cube/coupon4 (4.1.1): [756.9MiB/36.81s]
Installation failed, reverting ./composer.json to its original content.

In LibraryInstaller.php line 134:

Package is not installed: ec-cube/coupon4-4.1.1.0


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...


{"success":false,"log":"\u003Cwarning\u003EDeprecation warning: require.ec-cube\/Coupon4 is invalid, it should not contain uppercase characters. Please use ec-cube\/coupon4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/PayPalCheckout is invalid, it should not contain uppercase characters. Please use ec-cube\/paypalcheckout instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube\/productreview4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube\/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[10.4MiB\/1.32s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https:\/\/blog.packagist.com\/deprecating-composer-1-support\/\u003C\/warning\u003E\n[10.4MiB\/1.33s] Info from https:\/\/repo.packagist.org: \u001b[37;44m#StandWith\u001b[30;43mUkraine\u001b[0m\n[223.1MiB\/2.95s] Using version ^4.1 for ec-cube\/Coupon4\n[223.1MiB\/2.95s] .\/composer.json has been updated\n[223.5MiB\/3.01s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/Coupon4 is invalid, it should not contain uppercase characters. Please use ec-cube\/coupon4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[223.5MiB\/3.01s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/PayPalCheckout is invalid, it should not contain uppercase characters. Please use ec-cube\/paypalcheckout instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[223.5MiB\/3.01s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/ProductReview4 is invalid, it should not contain uppercase characters. Please use ec-cube\/productreview4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[223.5MiB\/3.01s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube\/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.4MiB\/3.15s] Loading composer repositories with package information\n[228.1MiB\/4.44s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https:\/\/blog.packagist.com\/deprecating-composer-1-support\/\u003C\/warning\u003E\n[228.1MiB\/4.44s] Info from https:\/\/repo.packagist.org: \u001b[37;44m#StandWith\u001b[30;43mUkraine\u001b[0m\n[228.2MiB\/4.44s] Updating dependencies\n[760.3MiB\/36.14s] Package operations: 1 install, 0 updates, 0 removals\n[760.3MiB\/36.14s] - Installing ec-cube\/coupon4 (4.1.1): [756.9MiB\/36.81s] \nInstallation failed, reverting .\/composer.json to its original content.\n\nIn LibraryInstaller.php line 134:\n \n Package is not installed: ec-cube\/coupon4-4.1.1.0 \n \n\nrequire [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [\u003Cpackages\u003E]...\n\n"}
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン



統計情報

総メンバー数は75,694名です
総投稿数は104,547件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2205
5
umebius
2085
6
yuh
1664
7
red
1547
8
h_tanaka
1189
9
tsuji
942
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.