バージョン選択

フォーラム

メニュー

オンライン状況

24 人のユーザが現在オンラインです。 (9 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 24
もっと...

サイト内検索

質問 > フロント機能 > プラグインインストール時のエラー

フロント機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
ttbn
投稿日時: 2023/1/7 14:17
対応状況: −−−
新米
登録日: 2023/1/7
居住地:
投稿: 2
プラグインインストール時のエラー
▼テンプレート
[EC-CUBE]
4.x系、新規インストール

[レンタルサーバー]
ConoHa

[OS]
Windows

[現象]
ConoHaサーバーをお借りしてEccubeを運用しています。
管理画面からブラウザのオーナーズストアへ行き、「カテゴリー並び替えプラグイン for EC-CUBE4.2」をインストールしようと思いましたが、以下のようなエラーが表示されインストールができませんでした。

過去の質問等を拝見いたしましたが、どこを直してよいかわからず困惑しております。
もし解決法などわかる方がいましたらご教授いただけましたら幸いです。

(初めての投稿で至らぬ点がありましたら申し訳ありません)

[エラー内容]
**************** CategorySort42 ****************
<warning>A script named compile would override a Composer command and has been skipped</warning>
<warning>A script named auto-scripts would override a Composer command and has been skipped</warning>
<warning>A script named installer-scripts would override a Composer command and has been skipped</warning>
[6.1MiB/0.74s] Using version ^1.1 for ec-cube/categorysort42
[6.1MiB/0.74s] ./composer.json has been updated
[8.3MiB/0.80s] Running composer update ec-cube/categorysort42 --with-dependencies
[10.5MiB/0.81s] Loading composer repositories with package information
[11.3MiB/1.40s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[11.5MiB/1.41s] Updating dependencies
[13.4MiB/1.43s] Your requirements could not be resolved to an installable set of packages.
[13.4MiB/1.43s]
Problem 1
- lcobucci/jwt 4.2.1 requires ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.
- league/oauth2-server-bundle v0.3.0 requires league/oauth2-server ^8.3 -> satisfiable by league/oauth2-server[8.3.5].
- ec-cube/api42 4.2.3 requires league/oauth2-server-bundle ^0.3 -> satisfiable by league/oauth2-server-bundle[v0.3.0].
- league/oauth2-server 8.3.5 requires lcobucci/jwt ^3.4.6 || ^4.0.4 -> satisfiable by lcobucci/jwt[4.2.1].
- ec-cube/api42 is locked to version 4.2.3 and an update of this package was not requested.

To enable extensions, verify that they are enabled in your .ini files:
- /opt/alt/php81/etc/php.ini
- /opt/alt/php81/link/conf/alt_php.ini
You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.
Alternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.
[13.4MiB/1.43s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
[11.9MiB/1.43s] You can also try re-running composer require with an explicit version constraint, e.g. "composer require ec-cube/CategorySort42:*" to figure out if any version is installable, or "composer require ec-cube/CategorySort42:^2.1" if you know which you need.
[11.9MiB/1.43s]
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
[11.8MiB/1.43s] Memory usage: 11.83MiB (peak: 13.76MiB), time: 1.43s

{"success":false,"log":"\u003Cwarning\u003EA script named compile would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named auto-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named installer-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n[6.1MiB\/0.74s] Using version ^1.1 for ec-cube\/categorysort42\n[6.1MiB\/0.74s] .\/composer.json has been updated\n[8.3MiB\/0.80s] Running composer update ec-cube\/categorysort42 --with-dependencies\n[10.5MiB\/0.81s] Loading composer repositories with package information\n[11.3MiB\/1.40s] \u003Cwarning\u003EDependency ec-cube\/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.\u003C\/warning\u003E\n[11.5MiB\/1.41s] Updating dependencies\n[13.4MiB\/1.43s] Your requirements could not be resolved to an installable set of packages.\n[13.4MiB\/1.43s] \n Problem 1\n - lcobucci\/jwt 4.2.1 requires ext-sodium * -\u003E it is missing from your system. Install or enable PHP\u0027s sodium extension.\n - league\/oauth2-server-bundle v0.3.0 requires league\/oauth2-server ^8.3 -\u003E satisfiable by league\/oauth2-server[8.3.5].\n - ec-cube\/api42 4.2.3 requires league\/oauth2-server-bundle ^0.3 -\u003E satisfiable by league\/oauth2-server-bundle[v0.3.0].\n - league\/oauth2-server 8.3.5 requires lcobucci\/jwt ^3.4.6 || ^4.0.4 -\u003E satisfiable by lcobucci\/jwt[4.2.1].\n - ec-cube\/api42 is locked to version 4.2.3 and an update of this package was not requested.\n\nTo enable extensions, verify that they are enabled in your .ini files:\n - \/opt\/alt\/php81\/etc\/php.ini\n - \/opt\/alt\/php81\/link\/conf\/alt_php.ini\nYou can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.\nAlternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.\n[13.4MiB\/1.43s] \u003Cwarning\u003ERunning update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.\u003C\/warning\u003E\n[11.9MiB\/1.43s] You can also try re-running composer require with an explicit version constraint, e.g. \u0022composer require ec-cube\/CategorySort42:*\u0022 to figure out if any version is installable, or \u0022composer require ec-cube\/CategorySort42:^2.1\u0022 if you know which you need.\n[11.9MiB\/1.43s] \nInstallation failed, reverting .\/composer.json and .\/composer.lock to their original content.\n[11.8MiB\/1.43s] Memory usage: 11.83MiB (peak: 13.76MiB), time: 1.43s\n"}
mcontact
投稿日時: 2023/1/7 21:04
対応状況: −−−
仙人
登録日: 2022/1/22
居住地:
投稿: 364
Re: プラグインインストール時のエラー
EC-CUBE4.x系の何のバージョンなのか、正確に記載がないので細かな事が解りませんので、正しくバージョンを記入する様にしましょう。
とりあえず、「カテゴリー並び替えプラグイン for EC-CUBE4.2」がEC-CUBE4.2系なので4.2系として回答すると...
下記のスレッドと同じです。
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=27171&forum=11&post_id=107744#forumpost107744


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

ttbn
投稿日時: 2023/1/10 16:41
対応状況: −−−
新米
登録日: 2023/1/7
居住地:
投稿: 2
Re: プラグインインストール時のエラー
返信をくださりありがとうございます。
以前の質問を見過ごしておりました。

情報不足で大変失礼いたしました。
EC-CUBEのバージョンは4.2系になります。

以前の質問を拝見したのですが、sodium extensionのインストール方法に苦戦しています。
ConoHaなのでphp.iniに記述し呼び出す方法はわかりましたが、その前の手順でどこにライブラリを記述するのか、等で悩んでしまいました。

ここまでくるとEC-CUBEではなくサーバー側に問い合わせたほうがいいでしょうか…?
mcontact
投稿日時: 2023/1/10 18:47
対応状況: −−−
仙人
登録日: 2022/1/22
居住地:
投稿: 364
Re: プラグインインストール時のエラー
共有型レンタルサーバーの場合は、sodium extensionをインストールするのは難しいと思います。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン



統計情報

総メンバー数は78,122名です
総投稿数は106,053件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2280
5
umebius
2085
6
yuh
1745
7
red
1558
8
h_tanaka
1301
9
tsuji
957
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.