バージョン選択

フォーラム

メニュー

オンライン状況

165 人のユーザが現在オンラインです。 (162 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 164
essert もっと...

サイト内検索

質問 > 管理機能 > 配送方法設定拡張プラグイン導入について

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
shota82
投稿日時: 2023/9/22 13:29
対応状況: −−−
新米
登録日: 2021/11/18
居住地:
投稿: 6
配送方法設定拡張プラグイン導入について
▼テンプレート
[EC-CUBE] 4.0.5
[レンタルサーバ] さくらスタンダード
[OS] 使用しているOS名、バージョン
[PHP] 7.4.33
[データベース] MySQL 5.7.40-log
[WEBサーバ] 使用しているWEBサーバ名、バージョン
[ブラウザ] 使用しているブラウザ名、バージョン
[導入プラグインの有無] 配送方法設定拡張プラグイン for EC-CUBE4.0~4.1
[カスタマイズの有無] 無
[現象]

配送方法設定拡張プラグイン導入を進める中で、プラグインの設定(歯車マーク)や導入した際に追加された項目を押すと「ページがみつかりません。」となり、設定ができずそこから先に進めることができません。

キャッシュクリアや導入前の状態に戻し、コマンドラインにてプラグインインストールを試みたのですが結果は変わりませんでした。
メモリに問題がある可能性も考え、php.iniにてmemory_limitも上げてインストールしてみたのですが同じく先に進めることができませんでした。

■参考にさせていただいたサイト
https://doc4.ec-cube.net/plugin_error
https://qiita.com/nanasess/items/791c9ec98f69ada93ea0

ECCUBEに明るくなく拙い文章で大変恐縮なのですが、何かヒントになる事でもご教授頂けないかと思い投稿させて頂きました。
よろしくお願いいたします。



導入時のログは下記になります。

――――――――――――――――――――――――――――――――――――
% bin/console eccube:composer:require ec-cube/DeliveryPlus4
[33.8MiB/1.51s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[33.8MiB/1.51s] Info from https://repo.packagist.org: #StandWithUkraine
[125.8MiB/3.69s] Using version ^1.1 for ec-cube/DeliveryPlus4
[125.9MiB/3.69s] ./composer.json has been updated
[126.2MiB/3.87s] <warning>Deprecation warning: require.ec-cube/DeliveryPlus4 is invalid, it should not contain uppercase characters. Please use ec-cube/deliveryplus4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[129.8MiB/4.09s] Loading composer repositories with package information
[131.7MiB/5.46s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[131.7MiB/5.46s] Info from https://repo.packagist.org: #StandWithUkraine
[131.8MiB/5.46s] Updating dependencies (including require-dev)
[583.5MiB/62.52s] Package operations: 1 install, 0 updates, 0 removals
[583.5MiB/62.52s] - Installing ec-cube/deliveryplus4 (1.1.6): [583.5MiB/62.52s] Loading from cache[583.5MiB/62.52s]
[579.0MiB/63.66s] <warning>Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.66s] <warning>Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.</warning>
[579.0MiB/63.66s] <warning>Package easycorp/easy-log-handler is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.66s] <warning>Package facebook/webdriver is abandoned, you should avoid using it. Use php-webdriver/webdriver instead.</warning>
[579.0MiB/63.66s] <warning>Package fzaninotto/faker is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.66s] <warning>Package php-cs-fixer/diff is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.66s] <warning>Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.66s] <warning>Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.66s] <warning>Package sensio/framework-extra-bundle is abandoned, you should avoid using it. Use Symfony instead.</warning>
[579.0MiB/63.67s] <warning>Package sensio/generator-bundle is abandoned, you should avoid using it. Use symfony/maker-bundle instead.</warning>
[579.0MiB/63.67s] <warning>Package setasign/fpdi-tcpdf is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.67s] <warning>Package swiftmailer/swiftmailer is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[579.0MiB/63.67s] <warning>Package symfony/class-loader is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.67s] <warning>Package symfony/debug is abandoned, you should avoid using it. Use symfony/error-handler instead.</warning>
[579.0MiB/63.67s] <warning>Package symfony/inflector is abandoned, you should avoid using it. Use EnglishInflector from the String component instead.</warning>
[579.0MiB/63.67s] <warning>Package symfony/security is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.67s] <warning>Package symfony/swiftmailer-bundle is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[579.0MiB/63.67s] <warning>Package symfony/web-server-bundle is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.67s] <warning>Package twig/extensions is abandoned, you should avoid using it. No replacement was suggested.</warning>
[579.0MiB/63.67s] <warning>Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.</warning>
[579.0MiB/63.67s] <warning>Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.</warning>
[579.8MiB/63.69s] Writing lock file
[579.8MiB/63.69s] Generating optimized autoload files
[582.4MiB/65.02s] <warning>Warning: Ambiguous class resolution, "Eccube\Entity\Cart" was found in both "$baseDir . '/app/proxy/entity/src/Eccube/Entity/Cart.php" and "/home/○○○○/www/src/Eccube/Entity/Cart.php", the first will be used.</warning>
[582.4MiB/65.03s] <warning>Warning: Ambiguous class resolution, "Eccube\Entity\Delivery" was found in both "$baseDir . '/app/proxy/entity/src/Eccube/Entity/Delivery.php" and "/home/○○○○/www/src/Eccube/Entity/Delivery.php", the first will be used.</warning>
[582.4MiB/65.03s] <warning>Warning: Ambiguous class resolution, "Eccube\Entity\Product" was found in both "$baseDir . '/app/proxy/entity/src/Eccube/Entity/Product.php" and "/home/○○○○/www/src/Eccube/Entity/Product.php", the first will be used.</warning>
[582.4MiB/65.03s] <warning>Warning: Ambiguous class resolution, "Eccube\Entity\ProductClass" was found in both "$baseDir . '/app/proxy/entity/src/Eccube/Entity/ProductClass.php" and "/home/○○○○/www/src/Eccube/Entity/ProductClass.php", the first will be used.</warning>
[580.7MiB/65.62s] Memory usage: 580.65MiB (peak: 718.17MiB), time: 65.62s

――――――――――――――――――――――――――――――――――――
mcontact
投稿日時: 2023/9/22 14:23
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1351
Re: 配送方法設定拡張プラグイン導入について
プラグイン提供元がサポートしているなら、プラグイン提供元にお問い合わせした方が早い気がします。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

h_tanaka
投稿日時: 2023/9/26 15:27
対応状況: −−−
登録日: 2016/7/22
居住地: 愛媛県
投稿: 1682
Re: 配送方法設定拡張プラグイン導入について
プラグインを強制削除してみてください。

・ dtb_plugin のプラグインの対象プラグインのレコードを削除する。

・ SSH ログインし、 app/Plugin 配下の対象プラグインのディレクトリを削除する。
$ rm -rf ​​app/Plugin/[plugin_code]

・ composer.json に対象プラグインの記述があれば削除する。

・プロキシを再生成する。
$ rm -f app/proxy/entity/src/Eccube/Entity/*.php
$ composer dump-autoload
$ php bin/console eccube:generate:proxies



----------------
EC-CUBE 《プラチナ》ランクパートナー
トエビス株式会社 田中 宏典
EC-CUBEの機能やデザインのカスタマイズ承ります。

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,117名です
総投稿数は110,319件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1682
8
red
1571
9
mcontact
1351
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.