バージョン選択

フォーラム

メニュー

オンライン状況

33 人のユーザが現在オンラインです。 (27 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 33
もっと...

サイト内検索

プラグイン > その他 > プラグインのアップデートが失敗する

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
nanana723
投稿日時: 2023/10/23 23:15
対応状況: 開発中
常連
登録日: 2023/4/6
居住地:
投稿: 36
プラグインのアップデートが失敗する
■ECCUBEバージョン
4.1.2-p1

■phpバージョン
7.4.33

■サーバー
エックスサーバー

■導入プラグイン
データ移行プラグイン(バージョン:4.1.0)
商品追加ポイント設定プラグイン for EC-CUBE 4(バージョン:1.2.1)
新規会員登録時ポイント付与プラグイン for EC-CUBE 4.0〜4.1(バージョン:2.0.1)
商品おすすめ順並び替えプラグイン for EC-CUBE4(バージョン:1.1.0)
商品レビュー管理プラグイン(バージョン:4.1.0)
おすすめ商品管理プラグイン(バージョン:4.1.0)
関連商品プラグイン(バージョン:4.1.0)
売上集計プラグイン(バージョン:4.1.0)
ソニーペイメントサービス決済プラグイン(バージョン:1.0.2)

■状況
ECCUBE4.1にてソニーペイメントサービス決済プラグイン1.0.2を使用中ですが、最新バージョン(1.0.4)へのアップデートが完了できません。

ソニーペイメントさんに問い合わせをしたところ、アップデートに関しては責任外となるので開発コミュニティで質問して欲しいとの回答をいただきました。

https://doc4.ec-cube.net/plugin_error
上記の内容を参考に、ソニーペイメント以外のプラグインを全て無効化し、管理画面でメンテナンスモードに切り替えることとSSHで/root/var/cache/*のキャッシュの削除を行ってみましたが状況は変わりませんでした。

アップデート画面でログとして表示されるのは下記の内容です。

[アップデート画面ログ]
**************** Disable ****************
**************** Upgrade ****************
[90.0MiB/1.62s] ./composer.json has been updated
[90.6MiB/1.96s] Running composer update ec-cube/slnpayment41 --with-dependencies
[93.5MiB/1.99s] Loading composer repositories with package information
[95.3MiB/3.02s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[95.5MiB/3.05s] Updating dependencies
[96.6MiB/3.07s] Nothing to modify in lock file
[97.3MiB/3.11s] Installing dependencies from lock file
[98.0MiB/3.12s] Nothing to install, update or remove
[98.4MiB/3.15s] <warning>Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.</warning>
[98.4MiB/3.15s] <warning>Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.</warning>
[98.4MiB/3.15s] <warning>Package easycorp/easy-log-handler is abandoned, you should avoid using it. No replacement was suggested.</warning>
[98.4MiB/3.15s] <warning>Package setasign/fpdi-tcpdf is abandoned, you should avoid using it. No replacement was suggested.</warning>
[98.4MiB/3.15s] <warning>Package swiftmailer/swiftmailer is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[98.4MiB/3.15s] <warning>Package symfony/inflector is abandoned, you should avoid using it. Use EnglishInflector from the String component instead.</warning>
[98.4MiB/3.15s] <warning>Package twig/extensions is abandoned, you should avoid using it. No replacement was suggested.</warning>
[98.4MiB/3.15s] <warning>Package fzaninotto/faker is abandoned, you should avoid using it. No replacement was suggested.</warning>
[98.4MiB/3.15s] <warning>Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.</warning>
[98.4MiB/3.15s] Generating optimized autoload files
[116.6MiB/8.57s] <warning>Class Eccube\Entity\Product located in ./app/proxy/entity/src/Eccube/Entity/Product.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[116.6MiB/8.57s] <warning>Class Eccube\Entity\Customer located in ./app/proxy/entity/src/Eccube/Entity/Customer.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[116.6MiB/8.57s] <warning>Class Eccube\Entity\BaseInfo located in ./app/proxy/entity/src/Eccube/Entity/BaseInfo.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[116.6MiB/8.57s] <warning>Class Eccube\Entity\Order located in ./app/proxy/entity/src/Eccube/Entity/Order.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[116.6MiB/8.57s] <warning>Class Eccube\Entity\OrderItem located in ./app/proxy/entity/src/Eccube/Entity/OrderItem.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[130.1MiB/9.83s] composer/package-versions-deprecated: Generating version class...
[130.1MiB/9.83s] composer/package-versions-deprecated: ...done generating version class
[130.1MiB/9.84s] Carbon 1 is deprecated, see how to migrate to Carbon 2.
[130.1MiB/9.84s] https://carbon.nesbot.com/docs/#api-carbon-2
[130.1MiB/9.84s] You can run './vendor/bin/upgrade-carbon' to get help in updating carbon and other frameworks and libraries that depend on it.
[112.8MiB/9.94s] 104 packages you are using are looking for funding.
[112.8MiB/9.94s] Use the `composer fund` command to find out more!
[113.4MiB/10.20s]
[113.4MiB/10.20s] Run composer recipes at any time to see the status of your Symfony recipes.
[113.4MiB/10.20s]
[113.5MiB/14.48s] Memory usage: 113.53MiB (peak: 150.67MiB), time: 14.48s

**************** Schema Update ****************
以下、500 Internal Server ErrorのHTMLの内容

ログの内容がいまいちよくわからず、アップデートが失敗する原因と対策でここを確認するといいという点があればご指摘いただければ幸いです。
よろしくお願いいたします。
h_tanaka
投稿日時: 2023/10/26 12:39
対応状況: −−−
登録日: 2016/7/22
居住地: 愛媛県
投稿: 1702
Re: プラグインのアップデートが失敗する
EC-CUBE Web API プラグイン(4.2系) が標準インストールされていないでしょうか?
同様の現象を確認したことがありますが、そのときはAPIプラグインで使用されている php_value がレンタルサーバーでは使用できないことが原因でした。
 
EC-CUBE Web API プラグイン(4.2系) を削除するか、
または、 .htaccess 内の php_value 指定をコメントアウトしてみてください。


----------------
EC-CUBE 《プラチナ》ランクパートナー
トエビス株式会社 田中 宏典
EC-CUBEの機能やデザインのカスタマイズ承ります。

nanana723
投稿日時: 2023/10/26 21:51
対応状況: 確認中
常連
登録日: 2023/4/6
居住地:
投稿: 36
Re: プラグインのアップデートが失敗する
ご回答いただきまして、ありがとうございます。

アイコンに4.0系という記載のあるものでしたが、標準で入っていたWeb APIは無効の状態でそのままになっていたのでご回答いただいた内容を試してみます。

また結果をご報告させていただきます。
nanana723
投稿日時: 2023/10/27 1:00
対応状況: −−−
常連
登録日: 2023/4/6
居住地:
投稿: 36
Re: プラグインのアップデートが失敗する
h_tanaka様

昨日はご回答いただきありがとうございました。
ご教授いただきました下記の内容を試してみました。

①.htaccess 内の php_value 指定をコメントアウト

<IfModule mod_php7.c>
	php_value upload_max_filesize 10M
</IfModule>


.htaccessのこの3行をコメントアウトしましたが、上手くいきませんでした。

②EC-CUBE Web API プラグイン(4.2系) を削除
こちらに入っているのはEC-CUBE Web API プラグイン(4.0系)でしたが、同様に試しました。

同じく標準で入っていたGoogle Merchant CenterがEC-CUBE Web API(4.0系)に依存しているというエラーメッセージが表示されたため、Google Merchant CenterとEC-CUBE Web API(4.0系)の両方を削除しました。
しかし、上手くいきませんでした。


アップデート画面でログとして表示されるものも、こちらのスレッドの最初の投稿時と変化がありません。

とはいえ、可能性を2つ試すことができ助かりました。
ありがとうございました。
nanana723
投稿日時: 2023/10/31 22:44
対応状況: 開発中
常連
登録日: 2023/4/6
居住地:
投稿: 36
Re: プラグインのアップデートが失敗する
追記です。

プラグインのアップデートはまだできていません。
他にも何か原因や対応方法として考えられることがございましたら、ご教授いただけますと幸いです。

よろしくお願いします。
nanana723
投稿日時: 2023/11/18 2:46
対応状況: 解決済
常連
登録日: 2023/4/6
居住地:
投稿: 36
Re: プラグインのアップデートが失敗する
こちらの件ですが、解決できました。

.htaccessに

AddHandler fcgid-script .cgi


の一文が入っていたため、上手くいかなかったようです。
改めまして、ご回答いただきありがとうございました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,867名です
総投稿数は110,501件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1702
8
red
1571
9
mcontact
1392
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.