バージョン選択

フォーラム

メニュー

オンライン状況

69 人のユーザが現在オンラインです。 (54 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 68
josefarly もっと...

サイト内検索

質問 > その他 > クーポンプラグインのアップデートでエラー

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
kggh
投稿日時: 2024/6/19 12:34
対応状況: −−−
半人前
登録日: 2024/3/8
居住地:
投稿: 25
クーポンプラグインのアップデートでエラー
▼テンプレート
[EC-CUBE]
4.2.3

[レンタルサーバ]
ローカルテスト環境

[OS]
Windows11(WSL2&Docker)

[PHP]
8.1.28

[Composer]
2.5.1

[現象]
オーナーズストアのプラグイン一覧から、クーポンプラグインのアップデートを行うと、以下のExceptionでアップデートが中断されてしまいます。

In RootPackageLoader.php line 160:
                                                                               
  [RuntimeException]                                                           
  require.ec-cube/Coupon42 is invalid, it should not contain uppercase charac  
  ters. Please use ec-cube/coupon42 instead. 


インストールされている4.2.4のcomposer.jsonの中身は、"name":"ec-cube\/coupon42"となっているのですが、アップデートしようとしている4.3.0での対応が必要なのでしょうか?

対処方法を教えていただけると助かります。
mcontact
投稿日時: 2024/6/19 19:18
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1393
Re: クーポンプラグインのアップデートでエラー
> インストールされている4.2.4のcomposer.jsonの中身は、"name":"ec-cube\/coupon42"となっているのですが、アップデートしようとしている4.3.0での対応が必要なのでしょうか?

app/Plugin/Coupon42/composer.jsonが「"name":"ec-cube\/coupon42"」となっていても問題ありません。
アップデート時にインストールログの項目があります。
そちらを確認頂くか、EC-CUBEログを確認してみてください。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

kggh
投稿日時: 2024/6/20 9:52
対応状況: −−−
半人前
登録日: 2024/3/8
居住地:
投稿: 25
Re: クーポンプラグインのアップデートでエラー
ご回答ありがとうございました。

site.logをのぞいてみましたが、上記エラーと同じログがありました。
その周りに上記エラー以外に、何か有用な情報があるのでしょうか?

エラーの内容的には、「大文字を使わない名称を利用してください」に見えたので、それを尋ねたつもりだったのですが、的が外れていますか?
mcontact
投稿日時: 2024/6/20 13:12
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1393
Re: クーポンプラグインのアップデートでエラー
> その周りに上記エラー以外に、何か有用な情報があるのでしょうか?
「アップデート時にインストールログの項目があります。」と記載しています。確認されましたか?

> エラーの内容的には、「大文字を使わない名称を利用してください」に見えたので、それを尋ねたつもりだったのですが、的が外れていますか?

記載のある、「"name":"ec-cube\/coupon42"」に大文字が含まれていますか?
含まれているのであれば、カスタマイズをされている様なので修正してください。

基本的に、オーナーズストアから購入時のidパラメータがない状態のcomposer.jsonは下記の内容と同じはずです。

https://github.com/EC-CUBE/coupon-plugin/blob/4.2/composer.json


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

kggh
投稿日時: 2024/6/20 14:59
対応状況: −−−
半人前
登録日: 2024/3/8
居住地:
投稿: 25
Re: クーポンプラグインのアップデートでエラー
>「アップデート時にインストールログの項目があります。」と記載しています。確認されましたか?

これは、アップデート確認のモーダルにある、「+ログを確認」のことをおっしゃっていますか?

もともとの投稿時に掲載したログは、そこから抜粋したものでしたので、
これ以外にログが表示される部分があるのだろうと想像して、site.logを探したのですが、そうではないのですね。

上記のことではないのであれば、お手数ですが、「インストールログ」の具体的な場所について教えていただけるとありがたいです。

>記載のある、「"name":"ec-cube\/coupon42"」に大文字が含まれていますか?

該当するプラグインへのカスタマイズはもちろん行っていません。

質問の意図がうまく伝えられず申し訳なかったですが、
大文字が入っていないように見えるのに、大文字を使わないでというExceptionが発生したので、
なぜだろう?とお尋ねしました。

composer.jsonとは別のところに原因があると考えましたが、いかがでしょう?
mcontact
投稿日時: 2024/6/24 20:32
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1393
Re: クーポンプラグインのアップデートでエラー
> これは、アップデート確認のモーダルにある、「+ログを確認」のことをおっしゃっていますか?

その通りです。


> composer.jsonとは別のところに原因があると考えましたが、いかがでしょう?

kgghさんがご使用の環境を見ていないので、
何とも言えないですがDocker+EC-CUBE4.2.3で構築した環境にてクーポンプラグインをアップデートしてみましたが、特に問題なくアップデート出来ているのでカスタマイズまたは他にインストールしているプラグインの影響かと思います。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,873名です
総投稿数は110,505件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1702
8
red
1571
9
mcontact
1393
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.