バージョン選択

フォーラム

メニュー

オンライン状況

28 人のユーザが現在オンラインです。 (18 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 28
もっと...

サイト内検索

質問 > フロント機能 > Warning:従来互換用の HTTP_Request が読み込まれました を止めたい

フロント機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
yosako
投稿日時: 2013/7/28 13:03
対応状況: −−−
一人前
登録日: 2011/12/3
居住地:
投稿: 101
Warning:従来互換用の HTTP_Request が読み込まれました を止めたい
バージョン2.12.5ですが、error.logに

2013/07/28 12:43:57 [/cart/index.php] Warning(E_USER_WARNING): 従来互換用の HTTP_Request が読み込まれました。 on [/home/xxxx/hoge.com/public_html/data/module/Request.php(30)] from xxx.xxx.xxx.xxx

という Warning が延々と書き込まれています。[/cart/index.php]のところは、/frontparts/login_check.php や /products/list.php などトランザクション毎に Warning が出ているようです。

この Warning を止めるにはどうしたらよいのでしょうか。
また、無視していても良いのでしょうか。

よろしくお願いします。
seasoft
投稿日時: 2013/7/28 17:08
対応状況: −−−
登録日: 2008/6/4
居住地:
投稿: 7333
Re: Warning:従来互換用の HTTP_Request が読み込まれました を止めたい
/home/xxxx/hoge.com/public_html/data/module/Request.php の 30行目かな。

サクッと行削除しても問題ないケースが多いと思いますが、念のため原因を調査・分析して把握しておくと安心かなと思います。

上述のファイル内に、主な原因を記載していたと思います。


----------------
Seasoft
こちらでの投稿は、アイディア程度に留めさせていただいております。
個別案件の作業は有償で承っております。お気軽にご相談ください。

yosako
投稿日時: 2013/7/28 18:31
対応状況: −−−
一人前
登録日: 2011/12/3
居住地:
投稿: 101
Re: Warning:従来互換用の HTTP_Request が読み込まれました を止めたい
seasoftさん

ありがとうございます。
Request.phpに書いてある意味がわからないので、何が原因かわかりません。

ここに書かれているように決済モジュールを無効化して試してみたいと思いますが、無効化する方法がわかりません。モジュールとしては、paypalウェブペイメントプラスとpaypal express checkoutの2つを入れています。paypal express checkoutについては導入しているだけで使用していませんが。

また、プラグインが関係しているのではないかと思い、すべてを無効化しても、すべての画面遷移の度にエラーが書き込まれているような状態です。

2.11.5からのアップグレードをしているのですが、2.11.5ではこのようなメッセージにはお目にかかったことがなかったので、すっきりしません。

2.11.5のRequest.phpと2.12.5のRequest.phpを比較すると2.11.5にあった
require_once DATA_REALDIR . 'module/HTTP/Request.php';
が2.12.5では記述されていませんが、これでよいのですよね?

とりあえず、Request.phpの30行目をコメント化してみます。
seasoft
投稿日時: 2013/7/28 22:30
対応状況: −−−
登録日: 2008/6/4
居住地:
投稿: 7333
Re: Warning:従来互換用の HTTP_Request が読み込まれました を止めたい
> とりあえず、Request.phpの30行目をコメント化してみます。

はい。多くの場合、それでも良いと思います。


----------------
Seasoft
こちらでの投稿は、アイディア程度に留めさせていただいております。
個別案件の作業は有償で承っております。お気軽にご相談ください。

yosako
投稿日時: 2013/7/29 17:47
対応状況: 解決済
一人前
登録日: 2011/12/3
居住地:
投稿: 101
Re: Warning:従来互換用の HTTP_Request が読み込まれました を止めたい
seasoftさん

ありがとうございます。
seasoftさんのお墨付きがあれば安心です。

この問題が解決したら、新たに別なwarningが出るようになってしまいました。これは別途質問させていただきます。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は67,426名です
総投稿数は98,789件です

投稿数ランキング

1
seasoft
7333
2
AMUAMU
2712
3
468
2692
4
nanasess
2115
5
umebius
1788
6
yuh
1612
7
red
1427
8
h_tanaka
1051
9
fukap
907
10
tsuji
863
11
shutta
835
12
tao_s
792
13 ramrun 789
14 karin 657
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.