バージョン選択

フォーラム

メニュー

オンライン状況

36 人のユーザが現在オンラインです。 (18 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 36
もっと...

サイト内検索

質問 > その他 > ECCUBEにmegamenu.jsを設置しています。スマホで見た際にioniconsが表示されないのでどうやったら表示されるか教えていただきたいです

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
masterR
投稿日時: 2021/6/13 11:45
対応状況: −−−
新米
登録日: 2021/1/27
居住地:
投稿: 6
ECCUBEにmegamenu.jsを設置しています。スマホで見た際にioniconsが表示されないのでどうやったら表示されるか教えていただきたいです
▼テンプレート
[EC-CUBE]
EC-CUBEのバージョン:4.0.5

[レンタルサーバ]エックスサーバー
[OS] 64 ビット オペレーティング システム、x64 ベース プロセッサ
[PHP] PHP Version 7.4.13
[データベース] MySQL5.7 バージョン 5.7.x
[WEBサーバ] エックスサーバー
[ブラウザ] 使用しているブラウザ名、バージョン
[導入プラグインの有無]
・ダウンロードコンテンツ販売 プラグイン
XSS脆弱性修正プラグインなど

[カスタマイズの有無] 特にカスタマイズはしてないです。
これからカスタマイズしようとしてストップしてます。

[現象]

はじめまして。
構築型のEC CUBEを使用させていただいています。

ECページにメガメニュー

Megamenu.js
https://codepen.io/riogrande/pen/MKXweV

を設置したくて

japascriptはわからないのですが
説明などを見ながら設置しようとしています。


自分のECサイト画面には
(完全じゃないですが)
メニューバーが
表示されたとおもいます。


パソコンで見る分には大丈夫なのですが
スマホで見た際には
メニュー最初のアイコンが×になっています。

このアイコンを表示させる方法をさぐっています。


ioniconsを使用しているのは承知しております。



megamenu.js設置方法の説明にはこちらのタグを↓

<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/1.12.0/jquery.min.js"></script>

<script src="js/megamenu.js"></script>


</body>の前に設置してくださいと書いてありましたので


default_frame.twigに
追加してみましたが表示されないのです。


記述方法が違うのだと気づき
いろいろ試してはいるものの
表示されずにいます。


javascriptやSymfony
aseet関数などほとんど知識が低いのですが

あちこちから情報を調べて
いる状態です。


現在の状態としましては
default_frame.twigに

<link rel="stylesheet" href="{{ asset('assets/css/●●●style.css') }}">
<script src="{{ asset('assets/js/megamenu.js') }}"></script>


category.twigにはこちらの
-------

<div class="menu-container">
<div class="menu">
<ul>
<li></li>
<li></li>
</ul>
</div>
</div>
------
<li></li>の中に表示したいメニューを記述しております。


また
ディベロッパーツールではindexの↓の箇所に404エラーが出ていたので

<link rel="stylesheet" href="/sh/html/template/default/assets/css/●●●style.css">
<script src="/sh/html/template/default/assets/js/megamenu.js"></script>

この↑のフォルダに
●●●style.css
/megamenu.js
を入れています。



自分の解決方法かな?」として思いつくのは

↓のスクリプトを
<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/1.12.0/jquery.min.js"></script>
aseet関数のリンク記述に変えて

default_frame.twigに追加記述してアップすると
表示されるのかな?

と思っているのですが
合っていますでしょうか。


でもその記述方法が
自分なりに試してもわからず
試しているうちに
サイトが一回表示されなくなり
バックアップで戻したという状態です。


初歩的な質問かもしれませんが
自分ではもうわからなくなり
こちらに質問させていただきました。


何かほかに足りない情報ありましたら
調べてきますので
解決方法を教えていただけるとありがたいです。

どうぞよろしくお願いいたします。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は73,348名です
総投稿数は102,428件です

投稿数ランキング

1
seasoft
7333
2
468
3107
3
AMUAMU
2712
4
nanasess
2187
5
umebius
2034
6
yuh
1614
7
red
1454
8
h_tanaka
1125
9
tsuji
936
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.