バージョン選択

フォーラム

メニュー

オンライン状況

39 人のユーザが現在オンラインです。 (30 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 39
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > php composer.phar requireエラー

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
casesan
投稿日時: 2022/1/7 17:32
対応状況: −−−
新米
登録日: 2021/12/8
居住地:
投稿: 4
php composer.phar requireエラー
▼テンプレート
[EC-CUBE]version:4.0.6 p1
[レンタルサーバ]さくらレンタルサーバー
[OS]docker
[PHP]7.4.25
[データベース]mysql 5.7.36
[WEBサーバ]FreeBSD
[ブラウザ]chrome
[導入プラグインの有無]
PGマルチペイメントサービス決済プラグイン
PGマルチペイメントサービス定期購入プラグイン
Web API
[カスタマイズの有無]
独自のプラグインあり
[現象]
php composer.phar require phpseclib/phpseclibをインストールしようとしたところ、
下記のエラーが発生しました。

require.ec-cube/Api is invalid, it should not contain uppercase characters.
Please use ec-cube/api instead.

このエラーの解決方法をご存じであれば教えていただけますでしょうか。
よろしくお願いいたします。
red
投稿日時: 2022/1/7 20:51
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1571
Re: php composer.phar requireエラー
php composer.phar self-update --1


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

casesan
投稿日時: 2022/1/11 9:34
対応状況: −−−
新米
登録日: 2021/12/8
居住地:
投稿: 4
Re: php composer.phar requireエラー
お世話になっております。

ご回答ありがとうございます。

ご教示いただいたコマンドを試しましたが、
コマンド実行時に同様のエラーが発生しております。

php composer.phar self-update --1
を行う前に何かやる必要があるのでしょうか?

エラー
require.ec-cube/Api is invalid, it should not contain uppercase characters.
Please use ec-cube/api instead.
red
投稿日時: 2022/1/11 9:55
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1571
Re: php composer.phar requireエラー
composerのバージョンはどうなっていますか?

php composer.phar -V


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

casesan
投稿日時: 2022/1/11 11:48
対応状況: −−−
新米
登録日: 2021/12/8
居住地:
投稿: 4
Re: php composer.phar requireエラー
お世話になっております。

今回のエラーが解決いたしました。

conposer.jsonのec-cube/APIに関連する部分を一度消してから、
php composer.phar self-update --1
を行ったところ、問題なくダウングレードできました。

その後、
php composer.phar require phpseclib/phpseclib
もインストールすることができました。

いろいろとご回答いただき、誠にありがとうございます。

また、
最後の質問についてですが、
エラー中に同様のコマンドを叩きましたところ、
下記のエラーが出ておりました。

require.ec-cube/Api is invalid, it should not contain uppercase characters.
Please use ec-cube/api instead.
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,091名です
総投稿数は110,310件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1681
8
red
1571
9
mcontact
1350
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.