バージョン選択

フォーラム

メニュー

オンライン状況

38 人のユーザが現在オンラインです。 (11 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 38
もっと...

サイト内検索

質問 > フロント機能 > PHP7.4.33を8.1にバージョン引き上げは可能でしょうか?

フロント機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
codama
投稿日時: 2022/12/2 16:05
対応状況: −−−
常連
登録日: 2020/8/3
居住地:
投稿: 56
PHP7.4.33を8.1にバージョン引き上げは可能でしょうか?
いつもお世話になっております。
以下のシステムで、4.1.2を稼働していますが、同じサーバーにWord-Press611も稼働しています。

サーバーにおいてWord-Press側のPHPバージョンを8.1に引き上げるように、何度も勧告を受けていますが、EC-CUBE4.12の運用に問題なくPHPをアップデートすることは可能なのでしょうか?

主体はECCUBEなので、トラブルは避けたく、ご教示何卒よろしくお願いします。

EC-CUBE 4.1.2
サーバーOS Linux plesk-1037049-14589.domain.tld 3.10.0 #1 SMP Thu Sep 23 18:26:47 MSK 2021 x86_64
DBサーバー MySQL 5.5.68-MariaDB
WEBサーバー nginx/1.20.2
PHP 7.4.33
mcontact
投稿日時: 2022/12/2 20:43
対応状況: −−−
仙人
登録日: 2022/1/22
居住地:
投稿: 340
Re: PHP7.4.33を8.1にバージョン引き上げは可能でしょうか?
> サーバーにおいてWord-Press側のPHPバージョンを8.1に引き上げるように、何度も勧告を受けていますが、EC-CUBE4.12の運用に問題なくPHPをアップデートすることは可能なのでしょうか?

下記の二か所に記載の公式サイト情報としては、まだ対応していません。
もしアップデートするのであれば、EC-CUBE本体以外にプラグインが対応しているかも確認が必要になりますので、テストサーバ等を用意して、確認される事をオススメ致します。
https://doc4.ec-cube.net/quickstart/requirement
https://www.ec-cube.net/developers/
nanasess
投稿日時: 2022/12/5 0:17
対応状況: −−−
登録日: 2006/9/9
居住地:
投稿: 2279
Re: PHP7.4.33を8.1にバージョン引き上げは可能でしょうか?
EC-CUBE4.1系は PHP7.4 までの対応となります。
PHP8 に対応したい場合は、EC-CUBE4.2系をご利用ください。

EC-CUBE4.1 と 4.2 はプラグインの互換性がなく、単純にバージョンアップできません。
新たにEC-CUBE4.2のサイトを構築していただき、4.1 のサイトからデータ移行する必要があります。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン



統計情報

総メンバー数は77,978名です
総投稿数は105,958件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2279
5
umebius
2085
6
yuh
1736
7
red
1557
8
h_tanaka
1301
9
tsuji
957
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.