バージョン選択

フォーラム

メニュー

オンライン状況

49 人のユーザが現在オンラインです。 (30 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 49
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > データ移行プラグイン インストール失敗について

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
puyopuyo
投稿日時: 2022/1/27 12:09
対応状況: −−−
新米
登録日: 2022/1/27
居住地:
投稿: 3
データ移行プラグイン インストール失敗について
▼テンプレート
[EC-CUBE] EC-CUBEのバージョン4.0、新規インストール
[レンタルサーバ] コアサーバー
[OS]
[PHP] 7.4
[データベース] MySQL
[導入プラグインの有無] なし
[カスタマイズの有無] なし
[現象]オーナーズストアより、データ移行プラグインのインストールをしようとすると、エラーが出て中断します。
対応可能でしょうか。

[24.9MiB/1.26s] Using version ^4.1 for ec-ube/datamigration4
[25.0MiB/1.26s] ./composer.json has been updated
[27.6MiB/1.44s] Running composer update ec-cube/datamigration4 --with-dependencies
[29.9MiB/1.47s] Loading composer repositories with package information
[31.0MiB/2.27s] <warning>Dependency "ec-cube/plugin-installer" is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[31.6MiB/3.18s] Updating dependencies
[33.8MiB/3.22s] Your requirements could not be resolved to an installable set of packages.
[33.8MiB/3.22s]
Problem 1
- phpunit/php-code-coverage 6.1.4 requires ext-xmlwriter * -> it is missing from your system. Install or enable PHP's xmlwriter extension.
- codeception/codeception 4.1.22 requires codeception/phpunit-wrapper >6.0.15 <6.1.0 | ^6.6.1 | ^7.7.1 | ^8.1.1 | ^9.0 -> satisfiable by codeception/phpunit-wrapper[7.8.2].
- codeception/phpunit-wrapper 7.8.2 requires phpunit/php-code-coverage ^6.0 -> satisfiable by phpunit/php-code-coverage[6.1.4].
- codeception/codeception is locked to version 4.1.22 and an update of this package was not requested.

To enable extensions, verify that they are enabled in your .ini files:
- /virtual/hamatra/public_html/.fast-cgi-bin/php74.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
[33.8MiB/3.22s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
[32.2MiB/3.22s]
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
[32.2MiB/3.22s] Memory usage: 32.19MiB (peak: 33.9MiB), time: 3.22s

{"success":false,"log":"[24.9MiB\/1.26s] Using version ^4.1 for ec-cube\/datamigration4\n[25.0MiB\/1.26s] .\/composer.json has been updated\n[27.6MiB\/1.44s] Running composer update ec-cube\/datamigration4 --with-dependencies\n[29.9MiB\/1.47s] Loading composer repositories with package information\n[31.0MiB\/2.27s] \u003Cwarning\u003EDependency \u0022ec-cube\/plugin-installer\u0022 is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.\u003C\/warning\u003E\n[31.6MiB\/3.18s] Updating dependencies\n[33.8MiB\/3.22s] Your requirements could not be resolved to an installable set of packages.\n[33.8MiB\/3.22s] \n Problem 1\n - phpunit\/php-code-coverage 6.1.4 requires ext-xmlwriter * -\u003E it is missing from your system. Install or enable PHP\u0027s xmlwriter extension.\n - codeception\/codeception 4.1.22 requires codeception\/phpunit-wrapper \u003E6.0.15 \u003C6.1.0 | ^6.6.1 | ^7.7.1 | ^8.1.1 | ^9.0 -\u003E satisfiable by codeception\/phpunit-wrapper[7.8.2].\n - codeception\/phpunit-wrapper 7.8.2 requires phpunit\/php-code-coverage ^6.0 -\u003E satisfiable by phpunit\/php-code-coverage[6.1.4].\n - codeception\/codeception is locked to version 4.1.22 and an update of this package was not requested.\n\nTo enable extensions, verify that they are enabled in your .ini files:\n - \/virtual\/hamatra\/public_html\/.fast-cgi-bin\/php74.ini\nYou can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.\n[33.8MiB\/3.22s] \u003Cwarning\u003ERunning update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.\u003C\/warning\u003E\n[32.2MiB\/3.22s] \nInstallation failed, reverting .\/composer.json and .\/composer.lock to their original content.\n[32.2MiB\/3.22s] Memory usage: 32.19MiB (peak: 33.9MiB), time: 3.22s\n"}
red
投稿日時: 2022/1/27 22:08
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1498
Re: データ移行プラグイン インストール失敗について
- phpunit/php-code-coverage 6.1.4 requires ext-xmlwriter * -> it is missing from your system. Install or enable PHP's xmlwriter extension.

と書かれていますよ


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

puyopuyo
投稿日時: 2022/1/28 14:02
対応状況: 確認中
新米
登録日: 2022/1/27
居住地:
投稿: 3
Re: データ移行プラグイン インストール失敗について
ありがとうございます。
phpinfoでは、XMLWriter enabledになっています。
php.iniで有効にしたりしましたが、同じエラーが出ます。
お手上げ状態です。
puyopuyo
投稿日時: 2022/1/28 14:16
対応状況: 解決済
新米
登録日: 2022/1/27
居住地:
投稿: 3
Re: データ移行プラグイン インストール失敗について
インストールできました。
なぜできたかよくわかりません。

ありがとうございました。
red
投稿日時: 2022/1/28 14:21
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1498
Re: データ移行プラグイン インストール失敗について
よくわからないですけど、よかったです


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン



統計情報

総メンバー数は74,621名です
総投稿数は104,051件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2202
5
umebius
2074
6
yuh
1664
7
red
1498
8
h_tanaka
1188
9
tsuji
942
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.