バージョン選択

フォーラム

メニュー

オンライン状況

42 人のユーザが現在オンラインです。 (19 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 41
eccube_hm もっと...

サイト内検索

質問 > 管理機能 > 4.04-4.05アップデートプラグインがインストールできない

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
susumu
投稿日時: 2022/9/5 17:18
対応状況: −−−
一人前
登録日: 2018/12/17
居住地:
投稿: 75
4.04-4.05アップデートプラグインがインストールできない
▼テンプレート
[EC-CUBE] EC-CUBEのバージョン、40.4 アップデートで4.04
[レンタルサーバ] さくらインターネット
[OS] 使用しているOS名、Mac 10.14.6 サーバのOSは FreeBSD 13.0?
[PHP] 使用しているPHPのバージョン7.4.30
[データベース] 使用しているDB名、MySQL5.7
[WEBサーバ] 使用しているWEBサーバ名、バージョン
[ブラウザ] 使用しているブラウザ名、バージョン
[導入プラグインの有無] EccubeUpdater403to404 ソニーペイメントサービス決済プラグイン
[現象] EC-CUBEアップデートプラグイン(4.0.4〜4.0.5)をインストールしようとしたらエラーが出ました。
以下エラーログです お手数ですが対処方法を教えていただけると助かります
**************** EccubeUpdater404to405 ****************
<warning>Deprecation warning: require.ec-cube/CategoryExtensionB is invalid, it should not contain uppercase characters. Please use ec-cube/categoryextensionb instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/EccubeUpdater400to401 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater400to401 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/EccubeUpdater401to402 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater401to402 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/EccubeUpdater402to403 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater402to403 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/EccubeUpdater403to404 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater403to404 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ProductContactB is invalid, it should not contain uppercase characters. Please use ec-cube/productcontactb instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SEO4 is invalid, it should not contain uppercase characters. Please use ec-cube/seo4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SameCategoryProduct is invalid, it should not contain uppercase characters. Please use ec-cube/samecategoryproduct instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[12.0MiB/1.30s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[12.0MiB/1.30s] Info from https://repo.packagist.org: [37;44m#StandWith [30;43mUkraine[0m
[226.0MiB/3.30s] Using version ^1.0 for ec-cube/EccubeUpdater404to405
[225.9MiB/3.30s] ./composer.json has been updated
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/CategoryExtensionB is invalid, it should not contain uppercase characters. Please use ec-cube/categoryextensionb instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/EccubeUpdater400to401 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater400to401 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/EccubeUpdater401to402 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater401to402 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/EccubeUpdater402to403 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater402to403 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/EccubeUpdater403to404 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater403to404 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/EccubeUpdater404to405 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubeupdater404to405 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/ProductContactB is invalid, it should not contain uppercase characters. Please use ec-cube/productcontactb instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/SEO4 is invalid, it should not contain uppercase characters. Please use ec-cube/seo4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/SameCategoryProduct is invalid, it should not contain uppercase characters. Please use ec-cube/samecategoryproduct instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[226.3MiB/3.37s] <warning>Deprecation warning: require.ec-cube/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[229.9MiB/3.61s] Loading composer repositories with package information
[231.8MiB/4.98s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
[231.8MiB/4.98s] Info from https://repo.packagist.org: [37;44m#StandWith [30;43mUkraine [0m
[231.8MiB/4.98s] Updating dependencies (including require-dev)
[768.8MiB/75.27s] Package operations: 1 install, 0 updates, 0 removals
[768.8MiB/75.27s] - Installing ec-cube/eccubeupdater404to405 (1.0.0): [768.8MiB/75.27s] Downloading[768.8MiB/76.77s] (100%)[768.8MiB/77.11s]
[765.6MiB/78.63s]
Installation failed, reverting ./composer.json to its original content.

In LibraryInstaller.php line 134:

Package is not installed: ec-cube/eccubeupdater404to405-1.0.0.0


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...


{"success":false,"log":"\u003Cwarning\u003EDeprecation warning: require.ec-cube\/CategoryExtensionB is invalid, it should not contain uppercase characters. Please use ec-cube\/categoryextensionb instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater400to401 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater400to401 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater401to402 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater401to402 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater402to403 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater402to403 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater403to404 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater403to404 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube\/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube\/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/ProductContactB is invalid, it should not contain uppercase characters. Please use ec-cube\/productcontactb instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/SEO4 is invalid, it should not contain uppercase characters. Please use ec-cube\/seo4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/SameCategoryProduct is invalid, it should not contain uppercase characters. Please use ec-cube\/samecategoryproduct instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube\/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n\u003Cwarning\u003EDeprecation warning: require.ec-cube\/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube\/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[12.0MiB\/1.30s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https:\/\/blog.packagist.com\/deprecating-composer-1-support\/\u003C\/warning\u003E\n[12.0MiB\/1.30s] Info from https:\/\/repo.packagist.org: \u001b[37;44m#StandWith\u001b[30;43mUkraine\u001b[0m\n[226.0MiB\/3.30s] Using version ^1.0 for ec-cube\/EccubeUpdater404to405\n[225.9MiB\/3.30s] .\/composer.json has been updated\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/CategoryExtensionB is invalid, it should not contain uppercase characters. Please use ec-cube\/categoryextensionb instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater400to401 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater400to401 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater401to402 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater401to402 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater402to403 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater402to403 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater403to404 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater403to404 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/EccubeUpdater404to405 is invalid, it should not contain uppercase characters. Please use ec-cube\/eccubeupdater404to405 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/FacebookAdsExtention is invalid, it should not contain uppercase characters. Please use ec-cube\/facebookadsextention instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube\/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/ProductContactB is invalid, it should not contain uppercase characters. Please use ec-cube\/productcontactb instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/SEO4 is invalid, it should not contain uppercase characters. Please use ec-cube\/seo4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/SameCategoryProduct is invalid, it should not contain uppercase characters. Please use ec-cube\/samecategoryproduct instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/Securitychecker4 is invalid, it should not contain uppercase characters. Please use ec-cube\/securitychecker4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[226.3MiB\/3.37s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/SlnPayment4 is invalid, it should not contain uppercase characters. Please use ec-cube\/slnpayment4 instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[229.9MiB\/3.61s] Loading composer repositories with package information\n[231.8MiB\/4.98s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https:\/\/blog.packagist.com\/deprecating-composer-1-support\/\u003C\/warning\u003E\n[231.8MiB\/4.98s] Info from https:\/\/repo.packagist.org: \u001b[37;44m#StandWith\u001b[30;43mUkraine\u001b[0m\n[231.8MiB\/4.98s] Updating dependencies (including require-dev)\n[768.8MiB\/75.27s] Package operations: 1 install, 0 updates, 0 removals\n[768.8MiB\/75.27s] - Installing ec-cube\/eccubeupdater404to405 (1.0.0): [768.8MiB\/75.27s] Downloading[768.8MiB\/76.77s] (100%)[768.8MiB\/77.11s] \n[765.6MiB\/78.63s] \nInstallation failed, reverting .\/composer.json to its original content.\n\nIn LibraryInstaller.php line 134:\n \n Package is not installed: ec-cube\/eccubeupdater404to405-1.0.0.0 \n \n\nrequire [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [\u003Cpackages\u003E]...\n\n"}
完了
sfujiya
投稿日時: 2022/9/16 6:19
対応状況: −−−
常連
登録日: 2018/12/20
居住地:
投稿: 44
Re: 4.04-4.05アップデートプラグインがインストールできない
composerのバージョンは幾つを使っていますか?
susumu
投稿日時: 2022/9/16 12:17
対応状況: −−−
一人前
登録日: 2018/12/17
居住地:
投稿: 75
Re: 4.04-4.05アップデートプラグインがインストールできない
バージョンの確認はどこを見るのでしょうか
mcontact
投稿日時: 2022/9/26 9:58
対応状況: −−−
長老
登録日: 2022/1/22
居住地:
投稿: 189
Re: 4.04-4.05アップデートプラグインがインストールできない
引用:

susumuさんは書きました:
バージョンの確認はどこを見るのでしょうか


composerのバージョンは、下記のサイトの様にコマンドを実行する事で確認できます。
https://agohack.com/composer-command-list/
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン



統計情報

総メンバー数は76,814名です
総投稿数は105,219件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2275
5
umebius
2085
6
yuh
1669
7
red
1556
8
h_tanaka
1195
9
tsuji
942
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.