バージョン選択

フォーラム

メニュー

オンライン状況

32 人のユーザが現在オンラインです。 (19 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 32
もっと...

サイト内検索

バグ報告 > その他 > ECCUBE(ダウンロード版)プラグインがインストールできない

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
trtl
投稿日時: 2023/3/6 10:18
対応状況: −−−
新米
登録日: 2023/3/6
居住地:
投稿: 4
ECCUBE(ダウンロード版)プラグインがインストールできない
▼テンプレート
[EC-CUBE] EC-CUBEのバージョン、新規インストールかアップデートか、等
[レンタルサーバ] エックスサーバー

[OS] Linux sv206.xbiz.ne.jp 4.4.0-233-generic #267-Ubuntu SMP Thu Aug 11 22:47:51 UTC 2022 x86_64

[PHP] 7.4.33 (Core, date, libxml, openssl, pcre, sqlite3, zlib, bz2, calendar, ctype, curl, hash, fileinfo, filter, ftp, gettext, gmp, SPL, iconv, session, standard, posix, pspell, Reflection, Phar, shmop, SimpleXML, sockets, mbstring, sysvmsg, sysvsem, sysvshm, tokenizer, xml, zip, mysqlnd, cgi-fcgi, apcu, bcmath, dba, dom, gd, imagick, imap, intl, json, ldap, exif, mcrypt, mysqli, PDO, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, soap, xmlreader, xmlrpc, xmlwriter, xsl, Zend OPcache)
[データベース] 使用しているDB名、バージョン
[WEBサーバ] Apache

[ブラウザ] Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/110.0.0.0 Safari/537.36

[導入プラグインの有無] あれば導入プラグインを記載
[カスタマイズの有無] あればカスタマイズ内容を記載(できるだけ具体的に)
[現象]


XSS脆弱性修正プラグイン(4.0.0〜4.0.5対応)
↑こちらと
関連商品プラグイン
↑こちらをインストールが出来ず困っております。。

どなたかご存じの方ご教示お願い致します。

mcontact
投稿日時: 2023/3/6 11:12
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1196
Re: ECCUBE(ダウンロード版)プラグインがインストールできない
> Call to a member function getItems() on null","/home/terratools/terratools-shop.com/public_html/app/Plugin/EccubePaymentLite4/EventListener/EventSubscriber/Front/Shopping/RemoveGuestPurchaseBtnWhenShoppingLogin.php

とエラーが記載されていますので、少なくとも、プラグイン名「EccubePaymentLite4」関係でエラーが発生している様です。
EC-CUBEのバージョンが記載されていないので、詳しくは解りませんが「XSS脆弱性修正プラグイン(4.0.0〜4.0.5対応)」と書かれるのでEC-CUBE4.0系と思いますが、サーバスペックによっては正常にプラグインがインストールできない場合もあります。
下記を参考にしてみてください。
https://qiita.com/nanasess/items/791c9ec98f69ada93ea0


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

trtl
投稿日時: 2023/3/6 11:57
対応状況: −−−
新米
登録日: 2023/3/6
居住地:
投稿: 4
Re: ECCUBE4.0.5(ダウンロード版)プラグインがインストールできない
仙人さま
ご返信頂きありがとうございます。

EC-CUBE
バージョン 4.0.5

再度試してみましたがうまくいかず
新しく下記エラーが出ました。



**************** XssFixer ****************
<warning>Deprecation warning: require.ec-cube/CategoryExtensionB is invalid, it should not contain uppercase characters. Please use ec-cube/categoryextensionb instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Coupon4 is invalid, it should not contain uppercase characters. Please use ec-cube/coupon4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/EccubePaymentLite4 is invalid, it should not contain uppercase characters. Please use ec-cube/eccubepaymentlite4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ExpressLink4 is invalid, it should not contain uppercase characters. Please use ec-cube/expresslink4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/MailMagazine4 is invalid, it should not contain uppercase characters. Please use ec-cube/mailmagazine4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/Maker4 is invalid, it should not contain uppercase characters. Please use ec-cube/maker4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ReceiptPdf2 is invalid, it should not contain uppercase characters. Please use ec-cube/receiptpdf2 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/RelatedProduct4 is invalid, it should not contain uppercase characters. Please use ec-cube/relatedproduct4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/ResizeImage4 is invalid, it should not contain uppercase characters. Please use ec-cube/resizeimage4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SEOAllOne is invalid, it should not contain uppercase characters. Please use ec-cube/seoallone instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/SalesReport4 is invalid, it should not contain uppercase characters. Please use ec-cube/salesreport4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/TaxManagement is invalid, it should not contain uppercase characters. Please use ec-cube/taxmanagement instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/XssFixer is invalid, it should not contain uppercase characters. Please use ec-cube/xssfixer instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/tbsFeaturePage is invalid, it should not contain uppercase characters. Please use ec-cube/tbsfeaturepage instead. Make sure you fix this as Composer 2.0 will error.</warning>
[13.3MiB/1.40s] <warning>Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/</warning>
mcontact
投稿日時: 2023/3/6 14:30
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1196
Re: ECCUBE4.0.5(ダウンロード版)プラグインがインストールできない
エラーログのとおり、

> Problem 1
> - The requested package ec-cube/eccubepaymentlite4 (locked at 1.0.5, required as 1.0.16) is satisfiable by ec-cube/EccubePaymentLite4[1.0.5] but these conflict with your requirements or minimum-stability.

EccubePaymentLite4周りでエラーが出ています。

きちんと、
> [導入プラグインの有無] あれば導入プラグインを記載
> [カスタマイズの有無] あればカスタマイズ内容を記載(できるだけ具体的に)

も記載することをオススメ致します。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

trtl
投稿日時: 2023/3/7 10:26
対応状況: −−−
新米
登録日: 2023/3/6
居住地:
投稿: 4
Re: ECCUBE4.0.5(ダウンロード版)プラグインがインストールできない
承知致しました。

導入プラグイン
・カテゴリページ/コンテンツ追加 for EC-CUBE4 1.0.1
CategoryExtensionB

・Coupon Plugin for EC-CUBE4 4.1.1
Coupon4

・メーカー管理プラグイン 4.0.1
Maker4

・領収書発行プラグイン 1.0.1
ReceiptPdf2

・画像リサイズプラグイン for EC-CUBE4 1.0.1
ResizeImage4

・売上集計プラグイン 4.0.1
SalesReport4

・SEOAllOne 1.0.7
SEOAllOne

・商品並び替えプラグイン 1.0.5
SortProduct

・TaxManagement 1.0.0
TaxManagement

・特集ページ作成 4.0.8
tbsFeaturePage


これから導入したいプラグイン
・関連商品プラグイン 4.1.0
RelatedProduct4

・XSS脆弱性修正プラグイン(4.0.0〜4.0.5対応) 1.0.0
XssFixer

難しいカスタムなどはしておりません。

trtl
投稿日時: 2023/3/7 11:51
対応状況: −−−
新米
登録日: 2023/3/6
居住地:
投稿: 4
Re: ECCUBE4.0.5(ダウンロード版)プラグインがインストールできない
何度も申し訳ございません。

sodium extension をインストールと
過去レスにあったのですが
方法も分からず躊躇しております。

可能であればご教示お願い致します。
mcontact
投稿日時: 2023/3/7 12:52
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1196
Re: ECCUBE4.0.5(ダウンロード版)プラグインがインストールできない
EC-CUBE4.0系には、『sodium extension』は基本的に関係ありません。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は87,705名です
総投稿数は109,436件です

投稿数ランキング

1
seasoft
7364
2
468
3217
3
AMUAMU
2712
4
nanasess
2302
5
umebius
2085
6
yuh
1807
7
h_tanaka
1597
8
red
1567
9
mcontact
1196
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
796
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.