バージョン選択

フォーラム

メニュー

オンライン状況

96 人のユーザが現在オンラインです。 (82 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 95
kainjersey もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > プラグインがインストールできません

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
thonma
投稿日時: 2022/12/20 17:17
対応状況: −−−
新米
登録日: 2022/12/20
居住地:
投稿: 2
プラグインがインストールできません
▼テンプレート
[EC-CUBE] EC-CUBE 4.2.0、新規インストール
[レンタルサーバ] XSERVER
[OS] Linux
[PHP] 7.4.33
[データベース] MySQL5.7
[WEBサーバ] 使用しているWEBサーバ名、バージョン
[ブラウザ] chrome 108.0.5359.125
[導入プラグインの有無] なし
[カスタマイズの有無] なし
[現象]
  稼働中のEC-CUBE(2.13.5)を
 XSERVERに移行しようとしていますが、XSERVER 側はEC-CUBE(4.2.0)のため、
 データ移行プラグイン(4.2系)を使用しようと思い、
 インストールを行ったところ、システムエラーになりました。

 エラー内容として
 『- lcobucci/jwt 4.2.1 requires ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.』
 があったため、XSERVER の php に sodium extension をインストールできるかを調べたところ、できなさそうなことが書いてありました。

 この場合、2.13.5 から 4.2.1 へのEC-CUBE ストアの移行はできないでしょうか。
 何か手はないでしょうか。

 どなたか、XSERVER への移行実績のある方などいましたら、教えていただけないでしょうか。
mcontact
投稿日時: 2022/12/20 17:24
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1401
Re: プラグインがインストールできません
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=27093&forum=2&post_id=107100#forumpost107100

こちらのやりとりの通り、API プラグインをアンインストールしてもインストールできないでしょうか?
thonma
投稿日時: 2022/12/20 17:48
対応状況: −−−
新米
登録日: 2022/12/20
居住地:
投稿: 2
Re: プラグインがインストールできません
解決しました。

プラグイン名「Web API」  ver 4.2.3 削除

まだ、EC-CUBE をインストールしただけだったし、ステータスが「無効」となっていたので、そのままにしてありました。

削除をしてから EC-CUBE Web API プラグイン(4.2系) を再度インストールしたら、正常終了しました。

ありがとうございました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,950名です
総投稿数は110,528件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1704
8
red
1571
9
mcontact
1401
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.