バージョン選択

フォーラム

メニュー

オンライン状況

92 人のユーザが現在オンラインです。 (82 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 92
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > EC-CUBEアップデートプラグインがインストールできない

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
tnbee
投稿日時: 2023/3/2 18:00
対応状況: 解決済
新米
登録日: 2023/3/2
居住地:
投稿: 6
EC-CUBEアップデートプラグインがインストールできない
▼テンプレート
[EC-CUBE] EC-CUBE4.2.0プラグイン
[レンタルサーバ] Xserver
[OS] 使用しているOS名、バージョン
[PHP] 使用しているPHPのバージョン
[データベース] 使用しているDB名、バージョン
[WEBサーバ] 使用しているWEBサーバ名、バージョン
[ブラウザ] 使用しているブラウザ名、バージョン
[導入プラグインの有無] あれば導入プラグインを記載
[カスタマイズの有無] EC-CUBE4.2.0 を新規導入直後(Xserverの簡単インストール機能を用い本日設置)

以下のようなエラーが出てしまい、インストールができませんでした。

注意事項にある以下について、どこに記載があるかが判明せず、原因になっているかもしれません。これらはどこに記載があるのでしょうか。

・xdebugが有効になっている→xdebugを無効にする
・memory_limitが128M→memory_limitを512Mに設定
・max_execution_timeが30→max_execution_timeを180に設定



[現象] **************** EccubeUpdater420to421 ****************
<warning>A script named compile would override a Composer command and has been skipped</warning>
<warning>A script named auto-scripts would override a Composer command and has been skipped</warning>
<warning>A script named installer-scripts would override a Composer command and has been skipped</warning>
[12.3MiB/0.70s] Using version ^1.0 for ec-cube/eccubeupdater420to421
[12.4MiB/0.71s] ./composer.json has been updated
[14.6MiB/0.77s] Running composer update ec-cube/eccubeupdater420to421 --with-dependencies
[16.7MiB/0.79s] Loading composer repositories with package information
[17.4MiB/1.48s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[17.7MiB/1.50s] Updating dependencies
[19.6MiB/1.52s] Your requirements could not be resolved to an installable set of packages.
[19.6MiB/1.52s]
Problem 1
- lcobucci/jwt 4.2.1 requires ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.
- league/oauth2-server-bundle v0.3.0 requires league/oauth2-server ^8.3 -> satisfiable by league/oauth2-server[8.3.5].
- ec-cube/api42 4.2.3 requires league/oauth2-server-bundle ^0.3 -> satisfiable by league/oauth2-server-bundle[v0.3.0].
- league/oauth2-server 8.3.5 requires lcobucci/jwt ^3.4.6 || ^4.0.4 -> satisfiable by lcobucci/jwt[4.2.1].
- ec-cube/api42 is locked to version 4.2.3 and an update of this package was not requested.

To enable extensions, verify that they are enabled in your .ini files:
- /etc/php-fpm/php74-php.ini
- /opt/php-7.4.33/etc/php.d/apcu.ini
- /opt/php-7.4.33/etc/php.d/bcmath.ini
- /opt/php-7.4.33/etc/php.d/dba.ini
- /opt/php-7.4.33/etc/php.d/dom.ini
- /opt/php-7.4.33/etc/php.d/gd.ini
- /opt/php-7.4.33/etc/php.d/imagick.ini
- /opt/php-7.4.33/etc/php.d/imap.ini
- /opt/php-7.4.33/etc/php.d/intl.ini
- /opt/php-7.4.33/etc/php.d/json.ini
- /opt/php-7.4.33/etc/php.d/ldap.ini
- /opt/php-7.4.33/etc/php.d/mbstring.ini
- /opt/php-7.4.33/etc/php.d/mcrypt.ini
- /opt/php-7.4.33/etc/php.d/mysqli.ini
- /opt/php-7.4.33/etc/php.d/pdo.ini
- /opt/php-7.4.33/etc/php.d/pdo_mysql.ini
- /opt/php-7.4.33/etc/php.d/pdo_pgsql.ini
- /opt/php-7.4.33/etc/php.d/pdo_sqlite.ini
- /opt/php-7.4.33/etc/php.d/pgsql.ini
- /opt/php-7.4.33/etc/php.d/soap.ini
- /opt/php-7.4.33/etc/php.d/xmlreader.ini
- /opt/php-7.4.33/etc/php.d/xmlrpc.ini
- /opt/php-7.4.33/etc/php.d/xmlwriter.ini
- /opt/php-7.4.33/etc/php.d/xsl.ini
You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.
Alternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.
[19.6MiB/1.52s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
[18.1MiB/1.52s] You can also try re-running composer require with an explicit version constraint, e.g. "composer require ec-cube/EccubeUpdater420to421:*" to figure out if any version is installable, or "composer require ec-cube/EccubeUpdater420to421:^2.1" if you know which you need.
[18.1MiB/1.52s]
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
[18.0MiB/1.52s] Memory usage: 18.02MiB (peak: 20.04MiB), time: 1.52s

{"success":false,"log":"\u003Cwarning\u003EA script named compile would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named auto-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named installer-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n[12.3MiB\/0.70s] Using version ^1.0 for ec-cube\/eccubeupdater420to421\n[12.4MiB\/0.71s] .\/composer.json has been updated\n[14.6MiB\/0.77s] Running composer update ec-cube\/eccubeupdater420to421 --with-dependencies\n[16.7MiB\/0.79s] Loading composer repositories with package information\n[17.4MiB\/1.48s] \u003Cwarning\u003EDependency ec-cube\/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.\u003C\/warning\u003E\n[17.7MiB\/1.50s] Updating dependencies\n[19.6MiB\/1.52s] Your requirements could not be resolved to an installable set of packages.\n[19.6MiB\/1.52s] \n Problem 1\n - lcobucci\/jwt 4.2.1 requires ext-sodium * -\u003E it is missing from your system. Install or enable PHP\u0027s sodium extension.\n - league\/oauth2-server-bundle v0.3.0 requires league\/oauth2-server ^8.3 -\u003E satisfiable by league\/oauth2-server[8.3.5].\n - ec-cube\/api42 4.2.3 requires league\/oauth2-server-bundle ^0.3 -\u003E satisfiable by league\/oauth2-server-bundle[v0.3.0].\n - league\/oauth2-server 8.3.5 requires lcobucci\/jwt ^3.4.6 || ^4.0.4 -\u003E satisfiable by lcobucci\/jwt[4.2.1].\n - ec-cube\/api42 is locked to version 4.2.3 and an update of this package was not requested.\n\nTo enable extensions, verify that they are enabled in your .ini files:\n - \/etc\/php-fpm\/php74-php.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/apcu.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/bcmath.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/dba.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/dom.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/gd.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/imagick.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/imap.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/intl.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/json.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/ldap.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/mbstring.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/mcrypt.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/mysqli.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/pdo.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/pdo_mysql.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/pdo_pgsql.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/pdo_sqlite.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/pgsql.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/soap.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/xmlreader.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/xmlrpc.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/xmlwriter.ini\n - \/opt\/php-7.4.33\/etc\/php.d\/xsl.ini\nYou can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.\nAlternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.\n[19.6MiB\/1.52s] \u003Cwarning\u003ERunning update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.\u003C\/warning\u003E\n[18.1MiB\/1.52s] You can also try re-running composer require with an explicit version constraint, e.g. \u0022composer require ec-cube\/EccubeUpdater420to421:*\u0022 to figure out if any version is installable, or \u0022composer require ec-cube\/EccubeUpdater420to421:^2.1\u0022 if you know which you need.\n[18.1MiB\/1.52s] \nInstallation failed, reverting .\/composer.json and .\/composer.lock to their original content.\n[18.0MiB\/1.52s] Memory usage: 18.02MiB (peak: 20.04MiB), time: 1.52s\n"}
mcontact
投稿日時: 2023/3/2 19:12
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1326
Re: EC-CUBEアップデートプラグインがインストールできない
まったく過去のスレッドにある内容と同じになります。
解決方法もスレッドに記載されている内容と同じです。
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=27171&forum=11&post_id=107744#forumpost107744


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

tnbee
投稿日時: 2023/3/6 11:59
対応状況: −−−
新米
登録日: 2023/3/2
居住地:
投稿: 6
Re: EC-CUBEアップデートプラグインがインストールできない
返信ありがとうございます。

Xserverに問い合わせたところ「sodium extension」の利用はできない」とのことでしたので、「web APIプラグイン」のアンインストールにて対応したく存じます。


経過追って報告いたします。
tnbee
投稿日時: 2023/3/6 17:15
対応状況: 解決済
新米
登録日: 2023/3/2
居住地:
投稿: 6
Re: EC-CUBEアップデートプラグインがインストールできない
web APIプラグインを削除してインストール、有効化できました。ありがとうございます。

ただ、デフォルトで入っている「web APIプラグイン」を外したことのデメリットが気になるところです。また、インストール、有効化した後に、「web APIプラグイン」を再インストールしてみたりしたいと思います。

取り急ぎ、本件自体は解決しました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は89,664名です
総投稿数は110,149件です

投稿数ランキング

1
seasoft
7367
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1657
8
red
1570
9
mcontact
1326
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.