バージョン選択

フォーラム

メニュー

オンライン状況

22 人のユーザが現在オンラインです。 (15 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 22
もっと...

サイト内検索

プラグイン > その他 > 「ゼウス決済プラグイン」がインストールできない

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
racoo
投稿日時: 2023/12/25 11:24
対応状況: 確認中
半人前
登録日: 2019/4/4
居住地:
投稿: 19
「ゼウス決済プラグイン」がインストールできない
▼テンプレート
[EC-CUBE]4.2.2
[レンタルサーバ]さくらレンタルサーバ
[OS]FreeBSD
[PHP]8.1.24
[データベース]MySQL 5.7.40
[WEBサーバ]Apache
[ブラウザ]Chrome
[導入プラグインの有無]ゼウス決済プラグイン(4.2系)
[カスタマイズの有無]なし
[現象]
プラグインをインストールしようとしたところ、下記エラーが表示されました。公式に問い合わせをしたところ、フォーラムで聞いてくれとのだったので、下記エラーについてわかる方いらっしゃいましたら教えていただきたいです。

**************** ZeusPayment42 ****************
<warning>A script named compile would override a Composer command and has been skipped</warning>
<warning>A script named auto-scripts would override a Composer command and has been skipped</warning>
<warning>A script named installer-scripts would override a Composer command and has been skipped</warning>
[6.3MiB/0.93s] Using version ^2.2 for ec-cube/zeuspayment42
[6.4MiB/0.93s] ./composer.json has been updated
[7.8MiB/1.08s] Running composer update ec-cube/zeuspayment42 --with-dependencies
[10.8MiB/1.11s] Loading composer repositories with package information
[11.7MiB/2.08s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[12.0MiB/2.12s] Updating dependencies
[13.8MiB/2.16s] Your requirements could not be resolved to an installable set of packages.
[13.8MiB/2.16s]
Problem 1
- lcobucci/jwt 4.2.1 requires ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.
- league/oauth2-server-bundle v0.3.0 requires league/oauth2-server ^8.3 -> satisfiable by league/oauth2-server[8.3.5].
- ec-cube/api42 4.2.3 requires league/oauth2-server-bundle ^0.3 -> satisfiable by league/oauth2-server-bundle[v0.3.0].
- league/oauth2-server 8.3.5 requires lcobucci/jwt ^3.4.6 || ^4.0.4 -> satisfiable by lcobucci/jwt[4.2.1].
- ec-cube/api42 is locked to version 4.2.3 and an update of this package was not requested.

To enable extensions, verify that they are enabled in your .ini files:
- /usr/local/php/8.1/etc/php.ini
- /usr/local/php/8.1/etc/conf.d/apcu.ini
- /usr/local/php/8.1/etc/conf.d/imagick.ini
- /usr/local/php/8.1/etc/conf.d/mcrypt.ini
- /usr/local/php/8.1/etc/conf.d/opcache.ini
You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.
Alternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.
[13.8MiB/2.16s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
[12.3MiB/2.17s] You can also try re-running composer require with an explicit version constraint, e.g. "composer require ec-cube/ZeusPayment42:*" to figure out if any version is installable, or "composer require ec-cube/ZeusPayment42:^2.1" if you know which you need.
[12.3MiB/2.17s]
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
[12.3MiB/2.17s] Memory usage: 12.28MiB (peak: 14.2MiB), time: 2.17s

{"success":false,"log":"\u003Cwarning\u003EA script named compile would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named auto-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named installer-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n[6.3MiB\/0.93s] Using version ^2.2 for ec-cube\/zeuspayment42\n[6.4MiB\/0.93s] .\/composer.json has been updated\n[7.8MiB\/1.08s] Running composer update ec-cube\/zeuspayment42 --with-dependencies\n[10.8MiB\/1.11s] Loading composer repositories with package information\n[11.7MiB\/2.08s] \u003Cwarning\u003EDependency ec-cube\/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.\u003C\/warning\u003E\n[12.0MiB\/2.12s] Updating dependencies\n[13.8MiB\/2.16s] Your requirements could not be resolved to an installable set of packages.\n[13.8MiB\/2.16s] \n Problem 1\n - lcobucci\/jwt 4.2.1 requires ext-sodium * -\u003E it is missing from your system. Install or enable PHP\u0027s sodium extension.\n - league\/oauth2-server-bundle v0.3.0 requires league\/oauth2-server ^8.3 -\u003E satisfiable by league\/oauth2-server[8.3.5].\n - ec-cube\/api42 4.2.3 requires league\/oauth2-server-bundle ^0.3 -\u003E satisfiable by league\/oauth2-server-bundle[v0.3.0].\n - league\/oauth2-server 8.3.5 requires lcobucci\/jwt ^3.4.6 || ^4.0.4 -\u003E satisfiable by lcobucci\/jwt[4.2.1].\n - ec-cube\/api42 is locked to version 4.2.3 and an update of this package was not requested.\n\nTo enable extensions, verify that they are enabled in your .ini files:\n - \/usr\/local\/php\/8.1\/etc\/php.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/apcu.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/imagick.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/mcrypt.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/opcache.ini\nYou can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.\nAlternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.\n[13.8MiB\/2.16s] \u003Cwarning\u003ERunning update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.\u003C\/warning\u003E\n[12.3MiB\/2.17s] You can also try re-running composer require with an explicit version constraint, e.g. \u0022composer require ec-cube\/ZeusPayment42:*\u0022 to figure out if any version is installable, or \u0022composer require ec-cube\/ZeusPayment42:^2.1\u0022 if you know which you need.\n[12.3MiB\/2.17s] \nInstallation failed, reverting .\/composer.json and .\/composer.lock to their original content.\n[12.3MiB\/2.17s] Memory usage: 12.28MiB (peak: 14.2MiB), time: 2.17s\n"}
mcontact
投稿日時: 2023/12/25 11:33
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1312
Re: 「ゼウス決済プラグイン」がインストールできない
まったく過去のスレッドにある内容と同じになります。
解決方法もスレッドに記載されている内容と同じです。
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=27171&forum=11&post_id=107744#forumpost107744


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

racoo
投稿日時: 2023/12/25 11:58
対応状況: 解決済
半人前
登録日: 2019/4/4
居住地:
投稿: 19
Re: 「ゼウス決済プラグイン」がインストールできない
ありがとうございます。
WebAPIのプラグインを削除したらインストールができました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は89,539名です
総投稿数は110,117件です

投稿数ランキング

1
seasoft
7367
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1656
8
red
1570
9
mcontact
1312
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.