バージョン選択

フォーラム

メニュー

オンライン状況

28 人のユーザが現在オンラインです。 (13 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 28
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > XREAサーバーでのプラグインインストール方法

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 古いものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
ank
投稿日時: 2021/3/17 22:26
対応状況: −−−
新米
登録日: 2021/3/17
居住地:
投稿: 2
XREAサーバーでのプラグインインストール方法
▼テンプレート
[EC-CUBE] 4.0.5
[レンタルサーバ] XREA
[OS] Linux s1005.xrea.com 4.4.0-197-generic #229-Ubuntu SMP Wed Nov 25 11:05:42 UTC 2020 x86_64
[PHP] 7.1.33
[データベース] MySQL 5.7.32-log
[WEBサーバ] Apache
[ブラウザ] Firefox Googlechrome
[導入プラグインの有無] 無し
[カスタマイズの有無] 無し
[現象] 管理画面のオーナーズストアからプラグインを購入しインストールを実行すると全てのプラグインでエラーが出てインストールが出来ません。
XREA自体がプラグインのインストールに対応していないのでしょうか?それとも別方法で対応できたりしますでしょうか?
PHPバージョンのせいかと思い、7.1-7.3まで試しましたが度のバージョンでも同じでした。
現在導入を検討しているプラグインは下記です。
・ ペイパル チェックアウト 決済プラグイン(4.0系)
・EC-CUBE 4.0 Web API プラグイン

エラー文章
**************** PayPalCheckout ****************
[10.0MiB/1.15s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[191.0MiB/2.52s] Using version ^1.0 for ec-cube/PayPalCheckout
[191.0MiB/2.52s] ./composer.json has been updated
[191.4MiB/2.68s] <warning>Deprecation warning: require.ec-cube/PayPalCheckout is invalid, it should not contain uppercase characters. Please use ec-cube/paypalcheckout instead. Make sure you fix this as Composer 2.0 will error.</warning>
[194.8MiB/2.81s] Loading composer repositories with package information
[195.9MiB/3.96s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[196.0MiB/3.96s] Updating dependencies (including require-dev)
[700.4MiB/21.08s] Your requirements could not be resolved to an installable set of packages.
[700.4MiB/21.08s]
Problem 1
- phpunit/php-code-coverage 5.3.2 requires ext-xmlwriter * -> the requested PHP extension xmlwriter is missing from your system.
- phpunit/php-code-coverage 5.3.2 requires ext-xmlwriter * -> the requested PHP extension xmlwriter is missing from your system.
- Installation request for phpunit/php-code-coverage (locked at 5.3.2) -> satisfiable by phpunit/php-code-coverage[5.3.2].

To enable extensions, verify that they are enabled in your .ini files:
- /virtual/jsahack/public_html/.fast-cgi-bin/php71.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
[625.0MiB/21.13s]
Installation failed, reverting ./composer.json to its original content.
[625.0MiB/21.13s] Memory usage: 625.01MiB (peak: 738.53MiB), time: 21.13s

{"success":false,"log":"[10.0MiB\/1.15s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https:\/\/getcomposer.org\/2\u003C\/warning\u003E\n[191.0MiB\/2.52s] Using version ^1.0 for ec-cube\/PayPalCheckout\n[191.0MiB\/2.52s] .\/composer.json has been updated\n[191.4MiB\/2.68s] \u003Cwarning\u003EDeprecation warning: require.ec-cube\/PayPalCheckout is invalid, it should not contain uppercase characters. Please use ec-cube\/paypalcheckout instead. Make sure you fix this as Composer 2.0 will error.\u003C\/warning\u003E\n[194.8MiB\/2.81s] Loading composer repositories with package information\n[195.9MiB\/3.96s] \u003Cwarning\u003EWarning from https:\/\/repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https:\/\/getcomposer.org\/2\u003C\/warning\u003E\n[196.0MiB\/3.96s] Updating dependencies (including require-dev)\n[700.4MiB\/21.08s] Your requirements could not be resolved to an installable set of packages.\n[700.4MiB\/21.08s] \n Problem 1\n - phpunit\/php-code-coverage 5.3.2 requires ext-xmlwriter * -\u003E the requested PHP extension xmlwriter is missing from your system.\n - phpunit\/php-code-coverage 5.3.2 requires ext-xmlwriter * -\u003E the requested PHP extension xmlwriter is missing from your system.\n - Installation request for phpunit\/php-code-coverage (locked at 5.3.2) -\u003E satisfiable by phpunit\/php-code-coverage[5.3.2].\n\n To enable extensions, verify that they are enabled in your .ini files:\n - \/virtual\/sample\/public_html\/.fast-cgi-bin\/php71.ini\n You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.\n[625.0MiB\/21.13s] \nInstallation failed, reverting .\/composer.json to its original content.\n[625.0MiB\/21.13s] Memory usage: 625.01MiB (peak: 738.53MiB), time: 21.13s\n"}

手動インストールの方法など、なにかしら解決方法があればご教授ください。宜しくお願いします。
スレッド表示 | 古いものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は71,530名です
総投稿数は101,307件です

投稿数ランキング

1
seasoft
7333
2
468
2998
3
AMUAMU
2712
4
nanasess
2147
5
umebius
2000
6
yuh
1612
7
red
1449
8
h_tanaka
1080
9
tsuji
936
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.