バージョン選択

フォーラム

メニュー

オンライン状況

23 人のユーザが現在オンラインです。 (13 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 23
もっと...

サイト内検索

質問 > その他 > データ移行プラグイン(4.2系)のインストールの仕方を教えてください

その他

新規スレッドを追加する

スレッド表示 | 古いものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
NIRT4GScag
投稿日時: 2022/11/4 14:13
対応状況: −−−
新米
登録日: 2022/10/20
居住地:
投稿: 8
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
nanasess様

APIプラグインをアンインストールして再度試してみた結果、無事 データ移行プラグイン を入れられました。
ありがとうございます。

composerとかについて詳しい人には自明のことなのかもですが、同じくそのあたりよくわからない人が辿り着いたとき用にちょっとメモです。

試しに再度 APIプラグインを入れ直してみたら、 composer.lock に書いてる lcobucci/jwt の version が 4.0.4 となってました。
また、 require のところからext-sodiumほか色々消えてました。

大本のeccube-4.2.0.zip のほうでは version が 4.2.1、require にはext-sodiumとか色々います。

APIプラグインの再インストール後は多分ext-sodiumが require と書いてないので、無効化してこのまま置いといてもいいかなと思います。
なにあったらその時考えます。

データ移行のプラグインが入っただけで、データ移行そのものについては未確認なのでまたコケるかもしれませんが、スレッドの主題自体は解決しましたので、再度となりますが閉じさせていただきます。

ありがとうございました。
NIRT4GScag
投稿日時: 2022/11/2 16:51
対応状況: −−−
新米
登録日: 2022/10/20
居住地:
投稿: 8
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
nanasess様

ご確認ありがとうございます。
該当プラグインを削除して再度試してみます!
nanasess
投稿日時: 2022/11/2 10:49
対応状況: −−−
登録日: 2006/9/9
居住地:
投稿: 2302
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
API プラグインが依存している lcobucci/jwt が ext-sodium を要求している模様です。
APIプラグインを使用しないのであれば、削除することでデータ移行プラグインも使用できると思います
NIRT4GScag
投稿日時: 2022/11/1 13:27
対応状況: −−−
新米
登録日: 2022/10/20
居住地:
投稿: 8
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
red 様

ありがとうございます。
red
投稿日時: 2022/11/1 10:44
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1567
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
sodiumを必要としているのはデータ移行プラグインではないと思います。


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

NIRT4GScag
投稿日時: 2022/11/1 9:59
対応状況: −−−
新米
登録日: 2022/10/20
居住地:
投稿: 8
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
その後どうなったかだけ記載しておきます。

・colorfulBox…sodium導入予定なし
・xserver(普通のレンタルのほう)…sodium導入予定なし

とのことで両サーバでは データ移行プラグイン(4.2系) は使えなさそうです。
colorfulBoxと似たようなところはあらかたsodiumなかったので同じような感じになるのではないでしょうか。特に問い合わせなどはしてないですが。

引き続きデータ移行プラグイン(4.2系) が使えるところを探すか、手作業でちまちま移す(とんでもない量あるけど)か、など考えます。

lcobucci/jwt や sodium が他のプラグインで必要とされないことを祈ります。
NIRT4GScag
投稿日時: 2022/10/21 12:07
対応状況: −−−
新米
登録日: 2022/10/20
居住地:
投稿: 8
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
nanasessさん

ご確認ありがとうございます。

ご指摘の通り、apacheかどうか、というか sodium extension があるとかないとかそういう感じな気もします。

現在詰まっている colorfulBox は開発用で想定していて、本番は別のvpsでの稼働を予定しているので、そちらはapache 且つ sodium extension が動く状態で使おうと思います。

laravelとかで問題になったことがなかったのでまったく盲点でした。
管理者に相談してみます。

ありがとうございました。
NIRT4GScag
投稿日時: 2022/10/21 12:06
対応状況: −−−
新米
登録日: 2022/10/20
居住地:
投稿: 8
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
mcontactさん

インストーラの備え付けのdockerの設定を使ってapache環境で試してみまして、データ移行プラグイン(4.2系)がインストールできました。
ありがとうございます。
nanasess
投稿日時: 2022/10/21 9:17
対応状況: −−−
登録日: 2006/9/9
居住地:
投稿: 2302
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
sodium extension がインストールされていない環境のようです。
通常は、PHPに標準で入っています。
サーバー管理者の方へお問い合わせください。
NIRT4GScag
投稿日時: 2022/10/21 9:04
対応状況: −−−
新米
登録日: 2022/10/20
居住地:
投稿: 8
Re: データ移行プラグイン(4.2系)のインストールの仕方を教えてください
mcontactさん

ご確認ありがとうございます。
apacheの環境で試して、またご報告いたします。



引用:

mcontactさんは書きました:
引用:

NIRT4GScagさんは書きました:
[WEBサーバ]
LiteSpeed 5


WebサーバがLiteSpeed の様ですが、EC-CUBE4.2は下記のサーバ環境ですが、Apacheを使っていないための影響ではないでしょうか?

https://doc4.ec-cube.net/quickstart/requirement
(1) 2 »
スレッド表示 | 古いものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は87,580名です
総投稿数は109,381件です

投稿数ランキング

1
seasoft
7361
2
468
3217
3
AMUAMU
2712
4
nanasess
2302
5
umebius
2085
6
yuh
1807
7
h_tanaka
1586
8
red
1567
9
mcontact
1189
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
796
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.