バージョン選択

フォーラム

メニュー

オンライン状況

36 人のユーザが現在オンラインです。 (28 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 36
もっと...

サイト内検索

バグ報告 > その他 > ゼウス決済プラグインがインストールできない

その他

新規スレッドを追加する

スレッド表示 | 古いものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
mcontact
投稿日時: 2022/11/7 15:56
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1392
Re: ゼウス決済プラグインがインストールできない
web APIプラグインをアンインストールして、ゼウス決済プラグインをインストールした後に、web APIプラグインを再インストールするとweb APIプラグインがバージョンアップされていて「sodium extension」が必要なくなっているらしいです。
今後はどうなるかは解らないけど....
rabupon
投稿日時: 2022/11/7 15:54
対応状況: −−−
常連
登録日: 2008/11/14
居住地:
投稿: 67
Re: ゼウス決済プラグインがインストールできない
ありがとうございます。
web APIをアンインストールで
インストールできました。
mcontact
投稿日時: 2022/11/7 13:37
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1392
Re: ゼウス決済プラグインがインストールできない
> 過去のフォーラムで「sodium extension」がインストールされていないのでは?という記載を見つけたので、サーバー会社に問い合わせを行ったところ、
> 「当サーバーのPHP環境ではSodium拡張機能をご利用いただけません。」と回答が来ました。

> このサーバーではプラグインをインストールできないのでしょうか?

https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=27093&forum=2&post_id=107100#forumpost107100

こちらのやりとりの通り、API プラグインをアンインストールしてもインストールできないでしょうか?
rabupon
投稿日時: 2022/11/7 12:43
対応状況: 解決済
常連
登録日: 2008/11/14
居住地:
投稿: 67
ゼウス決済プラグインがインストールできない
▼テンプレート
[EC-CUBE] 4.2
[レンタルサーバ] Xserver
[PHP] 7.4
[現象] XserverにEC-CUBEをインストールし
ゼウス決済プラグインをインストールするとエラーとなります。

エラーログは以下になります。


************** ZeusPayment42 ****************
<warning>A script named compile would override a Composer command and has been skipped</warning>
<warning>A script named auto-scripts would override a Composer command and has been skipped</warning>
<warning>A script named installer-scripts would override a Composer command and has been skipped</warning>
[12.1MiB/0.93s] Using version ^2.2 for ec-cube/zeuspayment42
[12.2MiB/0.93s] ./composer.json has been updated
[14.4MiB/0.98s] Running composer update ec-cube/zeuspayment42 --with-dependencies
[16.5MiB/1.00s] Loading composer repositories with package information
[17.1MiB/1.86s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[17.4MiB/1.87s] Updating dependencies
[19.3MiB/1.89s] Your requirements could not be resolved to an installable set of packages.
[19.3MiB/1.89s]
Problem 1
- lcobucci/jwt 4.2.1 requires ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.
- league/oauth2-server-bundle v0.3.0 requires league/oauth2-server ^8.3 -> satisfiable by league/oauth2-server[8.3.5].
- ec-cube/api42 4.2.3 requires league/oauth2-server-bundle ^0.3 -> satisfiable by league/oauth2-server-bundle[v0.3.0].
- league/oauth2-server 8.3.5 requires lcobucci/jwt ^3.4.6 || ^4.0.4 -> satisfiable by lcobucci/jwt[4.2.1].
- ec-cube/api42 is locked to version 4.2.3 and an update of this package was not requested.




過去のフォーラムで「sodium extension」がインストールされていないのでは?という記載を見つけたので、サーバー会社に問い合わせを行ったところ、
「当サーバーのPHP環境ではSodium拡張機能をご利用いただけません。」と回答が来ました。

このサーバーではプラグインをインストールできないのでしょうか?
スレッド表示 | 古いものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,867名です
総投稿数は110,501件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1702
8
red
1571
9
mcontact
1392
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.