バージョン選択

フォーラム

メニュー

オンライン状況

100 人のユーザが現在オンラインです。 (90 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 99
tokita もっと...

サイト内検索

その他 > その他 > 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました

その他

新規スレッドを追加する

スレッド表示 | 古いものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
ゲスト
投稿日時: 2006/10/2 0:24
対応状況: −−−
Re: 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
saratoga様、kaki様お返事ありがとうございます。
MySQL 4.1 以降、5.x 等が動作しているレンタルサーバを探してみます。
ありがとうございました。

kaki
投稿日時: 2006/9/29 21:41
対応状況: −−−
EC-CUBE開発チーム
登録日: 2006/9/11
居住地:
投稿: 146
Re: 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
>ゲスト様

saratoga様がご指摘されていますように、EC-CUBEではサブクエリを多用していますため、
MySQLのバージョンは4.1以降の対応となっております。
お手数ですが、MySQLのバージョンアップのご検討いただけますでしょうか。

以上、よろしくお願いいたします。
saratoga
投稿日時: 2006/9/29 12:22
対応状況: −−−
一人前
登録日: 2006/9/22
居住地: 大阪
投稿: 76
Re: 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
はじめての投稿になります。
Java での仕事ばかりなので、PHP は初心者ですが、
このパッケージを機会に勉強させて頂いています。

さて、このエラーについてですが、MySQL の 4.0.x では
サブクエリが使えないので、現状の INSERT 文だと
エラーになります。
対処方法としては、動的に生成している箇所を固定の
値に置き換えることで可能だと思います。

しかし、初期データのインポートだけの問題ではなく、
パッケージ内部のロジックでサブクエリを使用していたら
結局使えないです・・・。
パッケージの仕様として MySQL は 4.1 以上となっているので、
この辺の絡みもあるのではないでしょうか。

4.1 は文字の扱い方が違っていいところがあまりないので、
5.0 が使えればそちらへの移行がオススメです。
View が使えるのも 5.0 からですし。

見当違いのことを言っていたらご指摘下さい。
ゲスト
投稿日時: 2006/9/28 16:09
対応状況: −−−
Re: 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
はじめまして
試しにインストールしてみましたが MySQL Server 4.0.26 では駄目でした。
■データベースの初期化 のところでこけました。

>> DB Error: syntax error
[nativecode=1064 ** You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT bloc_id FROM dtb_bloc WHERE filename = 'best5'),0,'best5]

さくらインターネットのレンタルサーバで使えると嬉しかったりします。
ソフトウェア要件に合致していませんが以下の環境です。

サーバー OS: FreeBSD 4.10-RELEASE-p16
データベース: MySQL 4.0.26
MySQL Client API version: 4.0.24
PHP バージョン: 4.4.4
HTTP サーバー: Apache/1.3.37 (Unix)
GD バージョン: 2.0.28
kaki
投稿日時: 2006/9/23 14:45
対応状況: −−−
EC-CUBE開発チーム
登録日: 2006/9/11
居住地:
投稿: 146
Re: 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
>ゲスト様

EC-CUBEではサブクエリを多用していますので、
MySQLもサブクエリ対応以上のバージョンをであれば問題がないと思います。
(4.0での動作確認はしておりませんが、おそらくは難しいかと思います。)
ゲスト
投稿日時: 2006/9/23 4:43
対応状況: −−−
Re: 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
前バージョンで4.1に対応してたので、大丈夫なはずですよ。
ゲスト
投稿日時: 2006/9/23 3:34
対応状況: −−−
Re: 【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
質問です〜

MySQL5.0に対応とのコトですが、MySQL4.0〜4.1でも動作可能でしょうか?
kaki
投稿日時: 2006/9/22 16:05
対応状況: −−−
EC-CUBE開発チーム
登録日: 2006/9/11
居住地:
投稿: 146
【告知】 EC-CUBE 0.9.4 ベータ版をリリースしました
EC-CUBE 0.9.4 ベータ版をリリースしました

このたび、下記3点につきまして対応を致しました。
 ・MySQL5.0に対応致しました。
 ・インストール時にデータベースの初期化をSKIPできる機能を搭載しました。
 ・集計グラフのフォントを 「和田研細丸ゴシック20044(実装水準4)」に変更しました。

EC-CUBE開発チームとしましては、上記3点は深刻な問題として捉え、
改善するためのバージョンを緊急リリースいたしました。

0.9.3 ベータ版以前のバージョンをご利用のみなさまは 0.9.4 ベータ版にアップデートすることをお勧めいたします。
________________
EC-CUBE 開発チーム
スレッド表示 | 古いものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,949名です
総投稿数は110,527件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1704
8
red
1571
9
mcontact
1401
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.