バージョン選択

フォーラム

メニュー

オンライン状況

87 人のユーザが現在オンラインです。 (66 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 86
yokos もっと...

サイト内検索

 > プラグイン > EC-CUBE 定期購入プラグインの要件

プラグイン

新規スレッドを追加する

フラット表示 前のトピック | 次のトピック
投稿者 スレッド
DELIGHT
投稿日時: 2016/10/28 11:57
対応状況: −−−
仙人
登録日: 2010/2/3
居住地: 熊本県・九州・長野県・関東甲信越
投稿: 571
EC-CUBE 定期購入プラグインの要件
EC-CUBEペイメント 定期購入プラグインの問い合わせ先が不明ですのでこちらに書かせていただきます。届いて下さい。



https://www.ec-cube.net/products/detail.php?product_id=1094
上記ページ内に次のような記載があります。

引用:
本ページは定期購入プラグインのDLページとなります。
あらかじめ、EC-CUBEペイメント決済プラグイン(3.0系) version 1.1.5以上をインストールしておく必要があります。


しかし今回、決済プラグイン version 1.1.7及び定期購入プラグイン version 1.0.2の環境で定期購入プラグインの「受注管理 > 洗替会員管理 > 洗替データ作成」でエラーが発生するとのお問い合わせがありました。

調査したところ、決済プラグイン側の関数を参照している箇所で、当該関数が存在しないことが原因でした。
\Plugin\GmoPaymentGateway\Controller\Util\CommonUtil\getGmoMemberId()

手元に決済プラグインの全てのバージョンがある訳ではないのですが、決済プラグイン version 1.1.8〜version 1.1.10の間のどこかで当該関数が実装されたようです。



上記を踏まえた上で、定期購入プラグインの利用に必要な決済プラグインのバージョンを再検証していただきたく存じます。


----------------
+ DAISY inc. -------------------- +
EC-CUBE構築・カスタマイズサービス
EC・WEB構築などお気軽にご相談ください。

デイジー株式会社
http://daisy.link/

フラット表示 前のトピック | 次のトピック


題名 投稿者 日時
 » EC-CUBE 定期購入プラグインの要件 DELIGHT 2016/10/28 11:57
     Re: EC-CUBE 定期購入プラグインの要件 tao_s 2016/11/1 23:04
       Re: EC-CUBE 定期購入プラグインの要件 DELIGHT 2016/11/2 11:26
         Re: EC-CUBE 定期購入プラグインの要件 DELIGHT 2016/11/2 11:30

 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は56,823名です
総投稿数は94,637件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
2025
4
468
1951
5
yuh
1611
6
umebius
1495
7
red
1381
8
h_tanaka
944
9
fukap
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
783
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.