バージョン選択

フォーラム

メニュー

オンライン状況

46 人のユーザが現在オンラインです。 (23 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 46
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > プラグイン導入ができません

バグ報告・利用に関する質問

新規スレッドを追加する

フラット表示 前のトピック | 次のトピック
投稿者 スレッド
Eiji_sssu
投稿日時: 2022/9/20 12:09
対応状況: −−−
新米
登録日: 2022/9/20
居住地:
投稿: 3
プラグイン導入ができません
▼テンプレート
[EC-CUBE] 4.1.2新規インストール
[レンタルサーバ] さくらサーバー
[OS] Win10
[PHP] 8.0.21

[現象]
プラグインインストール時にエラーが発生します。(管理画面からオーナーズストアでの無料プラグインのインストール時)

色々調べてみたのですが、初心者なので勝手がわからず。。
詳しい方教えていただけますと幸いです。

以下エラー内容

**************** ProductImagesUploader ****************
[13.1MiB/1.03s] Using version ^4.1 for ec-cube/productimagesuploader
[13.1MiB/1.03s] ./composer.json has been updated
[15.7MiB/1.23s] Running composer update ec-cube/productimagesuploader --with-dependencies
[16.5MiB/1.31s] Loading composer repositories with package information
[17.9MiB/2.14s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[18.1MiB/2.22s] Updating dependencies
[19.9MiB/2.30s] Your requirements could not be resolved to an installable set of packages.
[19.9MiB/2.30s]
Problem 1
- Root composer.json requires php ^7.3 but your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 2
- doctrine/doctrine-cache-bundle is locked to version 1.4.0 and an update of this package was not requested.
- doctrine/doctrine-cache-bundle 1.4.0 requires php ^7.1 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 3
- doctrine/inflector is locked to version 1.3.1 and an update of this package was not requested.
- doctrine/inflector 1.3.1 requires php ^7.1 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 4
- doctrine/migrations is locked to version v1.8.1 and an update of this package was not requested.
- doctrine/migrations v1.8.1 requires php ^7.1 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 5
- doctrine/orm is locked to version 2.7.5 and an update of this package was not requested.
- doctrine/orm 2.7.5 requires php ^7.1 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 6
- dama/doctrine-test-bundle is locked to version v5.0.5 and an update of this package was not requested.
- dama/doctrine-test-bundle v5.0.5 requires php ^7.1 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 7
- fzaninotto/faker is locked to version v1.9.2 and an update of this package was not requested.
- fzaninotto/faker v1.9.2 requires php ^5.3.3 || ^7.0 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 8
- phpunit/phpunit is locked to version 7.5.20 and an update of this package was not requested.
- phpunit/phpunit 7.5.20 requires php ^7.1 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
Problem 9
- doctrine/inflector 1.3.1 requires php ^7.1 -> your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.
- symfony/maker-bundle v1.36.4 requires doctrine/inflector ^1.2|^2.0 -> satisfiable by doctrine/inflector[1.3.1].
- symfony/maker-bundle is locked to version v1.36.4 and an update of this package was not requested.

[19.9MiB/2.30s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
[18.5MiB/2.30s] You can also try re-running composer require with an explicit version constraint, e.g. "composer require ec-cube/ProductImagesUploader:*" to figure out if any version is installable, or "composer require ec-cube/ProductImagesUploader:^2.1" if you know which you need.
[18.5MiB/2.30s]
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
[18.5MiB/2.30s] Memory usage: 18.47MiB (peak: 20.01MiB), time: 2.3s

{"success":false,"log":"[13.1MiB\/1.03s] Using version ^4.1 for ec-cube\/productimagesuploader\n[13.1MiB\/1.03s] .\/composer.json has been updated\n[15.7MiB\/1.23s] Running composer update ec-cube\/productimagesuploader --with-dependencies\n[16.5MiB\/1.31s] Loading composer repositories with package information\n[17.9MiB\/2.14s] \u003Cwarning\u003EDependency ec-cube\/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.\u003C\/warning\u003E\n[18.1MiB\/2.22s] Updating dependencies\n[19.9MiB\/2.30s] Your requirements could not be resolved to an installable set of packages.\n[19.9MiB\/2.30s] \n Problem 1\n - Root composer.json requires php ^7.3 but your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 2\n - doctrine\/doctrine-cache-bundle is locked to version 1.4.0 and an update of this package was not requested.\n - doctrine\/doctrine-cache-bundle 1.4.0 requires php ^7.1 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 3\n - doctrine\/inflector is locked to version 1.3.1 and an update of this package was not requested.\n - doctrine\/inflector 1.3.1 requires php ^7.1 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 4\n - doctrine\/migrations is locked to version v1.8.1 and an update of this package was not requested.\n - doctrine\/migrations v1.8.1 requires php ^7.1 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 5\n - doctrine\/orm is locked to version 2.7.5 and an update of this package was not requested.\n - doctrine\/orm 2.7.5 requires php ^7.1 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 6\n - dama\/doctrine-test-bundle is locked to version v5.0.5 and an update of this package was not requested.\n - dama\/doctrine-test-bundle v5.0.5 requires php ^7.1 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 7\n - fzaninotto\/faker is locked to version v1.9.2 and an update of this package was not requested.\n - fzaninotto\/faker v1.9.2 requires php ^5.3.3 || ^7.0 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 8\n - phpunit\/phpunit is locked to version 7.5.20 and an update of this package was not requested.\n - phpunit\/phpunit 7.5.20 requires php ^7.1 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n Problem 9\n - doctrine\/inflector 1.3.1 requires php ^7.1 -\u003E your php version (8.0.21; overridden via config.platform, same as actual) does not satisfy that requirement.\n - symfony\/maker-bundle v1.36.4 requires doctrine\/inflector ^1.2|^2.0 -\u003E satisfiable by doctrine\/inflector[1.3.1].\n - symfony\/maker-bundle is locked to version v1.36.4 and an update of this package was not requested.\n\n[19.9MiB\/2.30s] \u003Cwarning\u003ERunning update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.\u003C\/warning\u003E\n[18.5MiB\/2.30s] You can also try re-running composer require with an explicit version constraint, e.g. \u0022composer require ec-cube\/ProductImagesUploader:*\u0022 to figure out if any version is installable, or \u0022composer require ec-cube\/ProductImagesUploader:^2.1\u0022 if you know which you need.\n[18.5MiB\/2.30s] \nInstallation failed, reverting .\/composer.json and .\/composer.lock to their original content.\n[18.5MiB\/2.30s] Memory usage: 18.47MiB (peak: 20.01MiB), time: 2.3s\n"}
フラット表示 前のトピック | 次のトピック


題名 投稿者 日時
 » プラグイン導入ができません Eiji_sssu 2022/9/20 12:09
     Re: プラグイン導入ができません red 2022/9/20 12:10
       Re: プラグイン導入ができません Eiji_sssu 2022/9/20 12:24
         Re: プラグイン導入ができません red 2022/9/20 13:12
           Re: プラグイン導入ができません Eiji_sssu 2022/9/20 14:03

 



ログイン



統計情報

総メンバー数は76,945名です
総投稿数は105,366件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2278
5
umebius
2085
6
yuh
1685
7
red
1556
8
h_tanaka
1195
9
tsuji
944
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.