バージョン選択

フォーラム

メニュー

オンライン状況

44 人のユーザが現在オンラインです。 (33 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 44
もっと...

PR

先着1,000社 プラグインダウンロード&お申込で1,000円分Amazonギフト券プレゼント amazon pay
広告掲載について

サイト内検索

質問 > その他 > EC-CUBE 3.n α5のインストールで「InvalidArgumentException」エラー(バージョンが見当たらない)

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
smito
投稿日時: 2018/6/7 16:27
対応状況: −−−
新米
登録日: 2018/6/7
居住地:
投稿: 2
EC-CUBE 3.n α5のインストールで「InvalidArgumentException」エラー(バージョンが見当たらない)
EC-CUBE3.n α5公開のニュース(https://www.ec-cube.net/news/detail.php?news_id=297)を見て、
記事内からリンクされているEC-CUBE 開発ドキュメント(http://doc3n.ec-cube.net/quickstart_install)の「インストール方法」を見て作業しているのですが、
"dev-experimental/sf"というバージョンが見当たらないようです。
どのバージョンを指定すればよいのか教えてください。
(もしくは、他のインストール方法があるなら、それでも結構です。)


以下、試したコマンドと、エラー内容です。
---------
# php composer.phar create-project --no-scripts ec-cube/ec-cube ec-cube "dev-experimental/sf"


[InvalidArgumentException]
Could not find package ec-cube/ec-cube with version dev-experimental/sf.
---------


(開発ドキュメント 左上のタイトルが「EC-CUBE 3.n-α4」となっているので、ここに書かれているインストール方法の情報はもう古いのかなという気はしています。)


以上、よろしくお願いいたします。
nanasess
投稿日時: 2018/6/8 1:01
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1735
Re: EC-CUBE 3.n α5のインストールで「InvalidArgumentException」エラー(バージョンが見当たらない)
experimental/sf ブランチが composer 経由で取得できなくなっているようです。

以下のように、 git clone してくればインストール可能です。

git clone -b experimental/sf https://github.com/EC-CUBE/ec-cube.git
cd ec-cube
composer install
bin/console eccube:install


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
有限会社 Loop AZ

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

smito
投稿日時: 2018/6/11 12:33
対応状況: −−−
新米
登録日: 2018/6/7
居住地:
投稿: 2
Re: EC-CUBE 3.n α5のインストールで「InvalidArgumentException」エラー(バージョンが見当たらない)
nanasess様
ご回答ありがとうございます。

なるほど、cloneで先に取得すればいいんですね。
composerで取得できない experimental/sf を使用していいものかわからなかったので、
公式から公開されている https://github.com/EC-CUBE/ec-cube/releases/tag/3.n-alpha5 を手動で配置し、
composer install することで、composer installは通りました。

ただ、私の環境(現在はWin10のxamppで試しています)では、環境変数などパスが通っていないのか
bin/console eccube:install が通らないので
(php bin/console eccube:instal とすれば通りますが、install途中で出てくる bin/console でエラーになってしまう)
Vagrantなどで環境を作ってから再挑戦したいと思います。
nanasess
投稿日時: 2018/6/11 12:59
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1735
Re: EC-CUBE 3.n α5のインストールで「InvalidArgumentException」エラー(バージョンが見当たらない)
https://github.com/EC-CUBE/ec-cube/releases/tag/3.n-alpha5 から、大量に変更が入っていますので experimental/sf を使っていただいた方が良いですね。

bin/console eccube:install が通らない場合は、以下でいかがでしょう?


bin/console doctrine:database:create
bin/console doctrine:schema:create
bin/console eccube:fixtures:load

bin/console eccube:fixtures:generate # (オプション)ダミーデータ生成


デフォルトでは、 SQLite3 でインストールされます。
PostgreSQL または MySQL を使用したい場合は、環境変数 DATABASE_URL を設定します。
(参考: http://doc3n.ec-cube.net/quickstart_install#データベースの種類を変更したい場合)


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
有限会社 Loop AZ

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

統計情報

総メンバー数は27,139名です
総投稿数は86,366件です

投稿数ランキング

1
seasoft
7331
2
AMUAMU
2712
3
nanasess
1735
4
yuh
1497
5
red
1161
6
umebius
1007
7
468
1004
8
fukap
907
9
shutta
827
10
tsuji
815
11 ramrun 789
12
tao_s
651
13 karin 647
14 sumida 641
15
homan
633
16 DELIGHT 571
17
h_tanaka
504
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© LOCKON CO.,LTD. All Rights Reserved.