バージョン選択

フォーラム

メニュー

オンライン状況

50 人のユーザが現在オンラインです。 (36 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 50
もっと...

サイト内検索

質問 > 管理機能 > プラグインのコンフィグが生成されない

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
cless03
投稿日時: 2018/11/29 10:59
対応状況: −−−
新米
登録日: 2012/7/16
居住地:
投稿: 6
プラグインのコンフィグが生成されない
▼テンプレート
[EC-CUBE] EC-CUBE4.0、新規インストール
[レンタルサーバ] レンタルサーバ名 mixhost
[OS] 使用しているOS名、バージョン Linux
[PHP] 使用しているPHPのバージョン php7.1.10
[データベース] 使用しているDB名、 MySQL 10.1.24-MariaDB-cll-lve
[WEBサーバ] 使用しているWEBサーバ名、litespeed
[ブラウザ] 使用しているブラウザ名、 Chrome最新版
[導入プラグインの有無] どのプラグインdめお発生
[カスタマイズの有無] なし
[現象] 再現手順や、どのような現象が発生しているかなど、具体的に


プラグインをインストールするとconfig画面が生成されません(歯車のアイコンがでない、直接URL打ち込んでもNG)。
どうしたらよろしいでしょうか?
nyorai
投稿日時: 2018/12/4 15:23
対応状況: −−−
長老
登録日: 2015/8/21
居住地:
投稿: 177
Re: プラグインのコンフィグが生成されない
キャッシュをクリアしてもでてこないでしょうか?
cless03
投稿日時: 2018/12/5 18:18
対応状況: −−−
新米
登録日: 2012/7/16
居住地:
投稿: 6
Re: プラグインのコンフィグが生成されない
出てこないです。
同じ環境の別サーバでは出てくるのですがインストールに失敗しているのでしょうか?

またアンインストールもできないです。ログがこちらになります。

[14.6MB/0.30s] <warning>Dependency "ec-cube/plugin-installer" is also a root requirement, but is not explicitly whitelisted. Ignoring.</warning>
[14.4MB/0.30s] Loading composer repositories with package information
[15.0MB/1.21s] Updating dependencies (including require-dev)
[337.6MB/16.30s] Package operations: 0 installs, 0 updates, 1 removal

In PluginInstaller.php line 106:

Undefined index: require


remove [--dev] [--no-progress] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--no-update-with-dependencies] [--ignore-platform-reqs] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] <packages> (<packages>)...
n.o
投稿日時: 2018/12/5 18:42
対応状況: −−−
常連
登録日: 2018/8/10
居住地:
投稿: 31
Re: プラグインのコンフィグが生成されない
便乗になりますが、私もプラグインのコンフィグ画面が表示されなくなりました。
EC-CUBE4.0.1、4.0.0どちらも表示されていません。

キャッシュ削除、URL直接アクセスどちらもNGです。
ご参考までに。
n.o
投稿日時: 2018/12/6 11:39
対応状況: −−−
常連
登録日: 2018/8/10
居住地:
投稿: 31
Re: プラグインのコンフィグが生成されない
補足します。

4.0.0環境は何故か今朝になって正常に表示されるようになりました。
4.0.1環境は依然コンフィグを表示できないでいます。

4.0.1環境を本体から再インストールしましたが症状は変わりませんでした。

なお、プラグインに関する一切の機能にアクセスできないようで、
プラグインの支払い方法を選択して決済しようとしたところ下記のエラーが発生します。

The "Plugin\決済方法のクラスパス" service or alias has been removed or inlined when the container was compiled.
 You should either make it public, or stop using the container directly and use dependency injection instead.

Container->get('Plugin\決済方法のクラスパス')
in Eccube/Controller/ShoppingController.php (line 715)

 *
 * @return PaymentMethodInterface
 */
private function createPaymentMethod(Order $Order, FormInterface $form)
{
    $PaymentMethod = $this->container->get($Order->getPayment()->getMethodClass());
    $PaymentMethod->setOrder($Order);
    $PaymentMethod->setFormType($form);
    return $PaymentMethod;
}

インストールは正常に行われており、dtb_pluginにも登録されていますが、
プラグインそのものがロードできていないように思います。
nanasess
投稿日時: 2018/12/6 12:01
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1857
Re: プラグインのコンフィグが生成されない
キャッシュの生成が中途半端なところで終わっている可能性がありますね。。。
コマンドラインから、キャッシュを再生成することはできますでしょうか?


bin/console cache:clear --no-warmup --env=<APP_ENVの値>
bin/console cache:warmup --env=<APP_ENVの値>


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
有限会社 Loop AZ

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

n.o
投稿日時: 2018/12/6 12:19
対応状況: −−−
常連
登録日: 2018/8/10
居住地:
投稿: 31
Re: プラグインのコンフィグが生成されない
nanasess様

ご返答ありがとうございます。
お教え頂いたコマンドを実行してみましたが
残念ながら結果は変わりませんでした。
nanasess
投稿日時: 2018/12/6 12:41
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1857
Re: プラグインのコンフィグが生成されない
デバッグモードにしてみるといかがでしょうか?
https://qiita.com/okazy/items/2e119e1a9f04250126cc


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
有限会社 Loop AZ

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

n.o
投稿日時: 2018/12/6 14:14
対応状況: −−−
常連
登録日: 2018/8/10
居住地:
投稿: 31
Re: プラグインのコンフィグが生成されない
既にデバッグモードで実行しています。
本番モードでもシステムエラーとなってしまいます。

マイページ用にプラグインの独自画面を定義しているのですが、
管理画面の[コンテンツ管理] > [ページ管理] > [独自ページ]を
選択すると例外が発生し、下記のメッセージが出力されます。

There are no registered paths for namespace "プラグインコード".


プラグインのnamespaceが登録されていないとのことですが、
何か心当たりは無いでしょうか?
n.o
投稿日時: 2018/12/7 11:04
対応状況: −−−
常連
登録日: 2018/8/10
居住地:
投稿: 31
Re: プラグインのコンフィグが生成されない
EC-CUBE4.0.1から4.0.0へ変更したところ、プラグインのコンフィグが表示され、
その他のプラグインの機能も正常に利用できるようになりました。

環境の影響もあると思いますが、4.0.1には何かしらの問題があり、
正常にプラグインが読み込まれない要因があるように思います。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

統計情報

総メンバー数は36,541名です
総投稿数は88,591件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1857
4
yuh
1528
5
468
1319
6
red
1199
7
umebius
1007
8
fukap
907
9
shutta
827
10
tsuji
815
11 ramrun 789
12
tao_s
667
13 karin 656
14 sumida 641
15
h_tanaka
638
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© LOCKON CO.,LTD. All Rights Reserved.