バージョン選択

フォーラム

メニュー

オンライン状況

36 人のユーザが現在オンラインです。 (26 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 36
もっと...

サイト内検索

質問 > その他 > ECCUBE3系のインストールについて

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
tetsurou
投稿日時: 2019/1/15 18:48
対応状況: 開発中
新米
登録日: 2019/1/15
居住地:
投稿: 9
ECCUBE3系のインストールについて
▼テンプレート
[EC-CUBE] 3.0.17
[レンタルサーバ] AWS
[OS] Windows10
[PHP] 7.2.11
[データベース] MySQL 5.7.24
[WEBサーバ] Apache 2.4.34
[ブラウザ] Chrome最新
[現象] インストールが出来ない

ご覧いただきありがとうございます。
よろしければ知恵をお借り頂きたく存じます。

現在上記の環境にてECCUBEのインストールを試みております。
ルートディレクトリにファイルをアップロードしてインストールを行おうとした所、下記のようなエラーが確認されました。


Fatal error: Uncaught Error: Class 'DOMDocument' not found in /var/www/html/ec/vendor/symfony/config/Util/XmlUtils.php:52 Stack trace: #0 /var/www/html/ec/vendor/symfony/translation/Loader/XliffFileLoader.php(123): Symfony\Component\Config\Util\XmlUtils::loadFile('/var/www/html/e...') #1 /var/www/html/ec/vendor/symfony/translation/Loader/XliffFileLoader.php(40): Symfony\Component\Translation\Loader\XliffFileLoader->parseFile('/var/www/html/e...') #2 /var/www/html/ec/vendor/symfony/translation/Translator.php(412): Symfony\Component\Translation\Loader\XliffFileLoader->load('/var/www/html/e...', 'ja', 'validators') #3 /var/www/html/ec/vendor/symfony/translation/Translator.php(302): Symfony\Component\Translation\Translator->doLoadCatalogue('ja') #4 /var/www/html/ec/vendor/symfony/translation/Translator.php(288): Symfony\Component\Translation\Translator->initializeCatalogue('ja') #5 /var/www/html/ec/vendor/symfony/translation/Translator.php(248): Symfony\Component\Translation\Translator->loadCatalogue('ja') #6 /var/www/html/ec in /var/www/html/ec/vendor/symfony/config/Util/XmlUtils.php on line 52


調べたところ、php-xmlが無い場合に上記のエラーが出る可能性があるとの事でしたが、php-xmlはインストールされている事を確認しております。

何かアドバイス・解決策を頂けますと幸いです。
何卒よろしくお願いいたします。
468
投稿日時: 2019/1/15 20:22
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1685
Re: ECCUBE3系のインストールについて
以下のページにあるようにPHPのバージョン違いのphp-xmlをインストールしている可能性はありませんか?
http://ozzwar.hatenablog.com/entry/2017/04/10/000226


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

tetsurou
投稿日時: 2019/1/16 9:38
対応状況: −−−
新米
登録日: 2019/1/15
居住地:
投稿: 9
Re: ECCUBE3系のインストールについて
ご回答を頂きありがとうございます。
php -mで確認してみましたが、xml xmlreader xmlwriter全ては入っておりました。
468
投稿日時: 2019/1/16 10:02
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1685
Re: ECCUBE3系のインストールについて
libxmlも入っているという事ですよね?
phpinfo();を記述したphpファイルを用意して、
PHPの設定にlibxmlやxmlが表示される&有効になっているか確認されてみては如何でしょうか?


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

tetsurou
投稿日時: 2019/1/16 11:00
対応状況: −−−
新米
登録日: 2019/1/15
居住地:
投稿: 9
Re: ECCUBE3系のインストールについて
ご回答いただきありがとうございます。
頂いたアドバイスを元に、phpinfoでlibxmlも確認いたしましたが、入っているようでした。

phpのヴァージョンが新しすぎるのとかが問題になっている事も可能性としては考えられるものでしょうか?
468
投稿日時: 2019/1/16 11:39
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1685
Re: ECCUBE3系のインストールについて
ECCUBE4がPHP7.3では動作しない(外部ライブラリに問題有り)というのは先日確認しましたが、
私のほうでは、ECCUBE3とPHP7.2ではどうなのかは確認できておりません。

弊社でAWSにPHP7.1の環境構築してECCUBE3を運用しているサイトはありますので、
PHP7.1では問題無く、動作するものと思います。


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

tetsurou
投稿日時: 2019/1/16 16:52
対応状況: −−−
新米
登録日: 2019/1/15
居住地:
投稿: 9
Re: ECCUBE3系のインストールについて
ご回答頂きありがとうございます。

結局、PHPをアンインストールし、再度入れなおす事でエラーを解決する事が出来ました。
ご教授頂きありがとうございました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


ec-cube.co

統計情報

総メンバー数は42,285名です
総投稿数は90,791件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1882
4
468
1685
5
yuh
1571
6
red
1245
7
umebius
1200
8
fukap
907
9
tsuji
837
10
shutta
827
11 ramrun 789
12
tao_s
699
13
h_tanaka
693
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© LOCKON CO.,LTD. All Rights Reserved.