バージョン選択

フォーラム

メニュー

オンライン状況

34 人のユーザが現在オンラインです。 (22 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 33
hotmas1te もっと...

サイト内検索

プラグイン > その他 > AmazonPay プラグインインストールで500エラーが出ます

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
masa_ext
投稿日時: 2019/2/6 21:58
対応状況: −−−
新米
登録日: 2019/2/6
居住地:
投稿: 6
AmazonPay プラグインインストールで500エラーが出ます
▼テンプレート
[EC-CUBE]4.0.1、新規インストール
[レンタルサーバ] さくらクラウド
[OS] CentOS7
[PHP] 7.1.26
[データベース] MySQL 5.7.25
[WEBサーバ] Apache/2.4.6
[ブラウザ] Google Chrome
[導入プラグインの有無] ApazonPay
[現象] AmazonPayを有効かを行うと500エラーになります。
admin-logは下記の通りです。一部サイト名など伏字(xxxx)にさせていただきました。

admin.ERROR [aj00dpeek8kmceriaeb1l6seuk] [289ee57] [1] [Eccube\Log\Logger:log:64] - システムエラーが発生しました。 ["Expected response code 220 but got code \"\", with message \"\"","/var/www/html/xxxx/src/Eccube/Service/PluginService.php",271,"#0 /var/www/html/xxxx/src/Eccube/Service/PluginService.php(226): Eccube\\Service\\PluginService->postInstall(Array, 1770)\n#1 /var/www/html/xxxxx/src/Eccube/Controller/Admin/Store/PluginController.php(330): Eccube\\Service\\PluginService->installWithCode('AmazonPay')\n#2 /var/www/html/xxxxx/vendor/symfony/http-kernel/HttpKernel.php(151): Eccube\\Controller\\Admin\\Store\\PluginController->enable(Object(Eccube\\Entity\\Plugin), Object(Eccube\\Util\\CacheUtil), Object(Symfony\\Component\\HttpFoundation\\Request))\n#3 /var/www/html/xxxx/vendor/symfony/http-kernel/HttpKernel.php(68): Symfony\\Component\\HttpKernel\\HttpKernel->handleRaw(Object(Symfony\\Component\\HttpFoundation\\Request), 1)\n#4 /var/www/html/xxxxx/vendor/symfony/http-kernel/Kernel.php(200): Symfony\\Component\\HttpKernel\\HttpKernel->handle(Object(Symfony\\Component\\HttpFoundation\\Request), 1, true)\n#5 /var/www/html/xxxxx/index.php(74): Symfony\\Component\\HttpKernel\\Kernel->handle(Object(Symfony\\Component\\HttpFoundation\\Request))\n#6 {main}"] [POST, /xxxx/store/plugin/3/enable, 218.217.218.220, https://xxxx.com/xxxx/store/plugin, Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36]

ログを確認しましたが理解不足もあり原因がわかりません。
説明が至らないところもあるかと思いますがご返信いただければ幸いです。
よろしくお願いいたします
468
投稿日時: 2019/2/7 9:59
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1685
Re: AmazonPay プラグインインストールで500エラーが出ます
ご提示いただいたエラーメッセージ「Expected response code 220 but got code ""」だけ見ると、
smtp関連のエラーのように見受けられるのですが、
.envファイルのMAILER_URLの記述を誤っている可能性はありませんか?
プラグイン有効化の際にキャッシュがクリアされ、
.envファイルが再読込されるのではないかと思いますが、
その際、.envファイルのMAILER_URLの記述に問題があってエラーが出ているのかもしれません。
その辺りを確認してもエラーが発生するようであれば、
プラグイン配布元のアイピーロジック様にお問い合わせされたほうが良いかと思います。


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

nanasess
投稿日時: 2019/2/7 14:45
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1882
Re: AmazonPay プラグインインストールで500エラーが出ます
Amazon Pay プラグインは、127.0.0.1 の SMTP を利用する前提となっていたと記憶しています。
開発元の IPLogic 様にお問い合わせいただくと良いと思います


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
有限会社 Loop AZ

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

masa_ext
投稿日時: 2019/2/7 15:49
対応状況: −−−
新米
登録日: 2019/2/6
居住地:
投稿: 6
Re: AmazonPay プラグインインストールで500エラーが出ます
返信ありがとうございます。

開発環境に変更し再度確かめたところ確かにメールのところでエラーになっていました。

.envファイルのMAILER_URLをgmailに書き換えております。
現在そこも問題があり別スレッドで相談をしております。

まずは、MAILER_URLについて問題を解決したいと思います。

ご教授ありがとうございました。
masa_ext
投稿日時: 2019/2/7 15:52
対応状況: −−−
新米
登録日: 2019/2/6
居住地:
投稿: 6
Re: AmazonPay プラグインインストールで500エラーが出ます
ご返信ありがとうございます。

SMTPの設定をgmailにしております。現在この設定も少々問題が発生しており別スレッドで相談中です。

まずは127.0.0.1(localhost)で再度確認をしてみます。

ご教授ありがとうございました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


ec-cube.co

統計情報

総メンバー数は42,285名です
総投稿数は90,790件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1882
4
468
1685
5
yuh
1571
6
red
1245
7
umebius
1200
8
fukap
907
9
tsuji
837
10
shutta
827
11 ramrun 789
12
tao_s
699
13
h_tanaka
692
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© LOCKON CO.,LTD. All Rights Reserved.