バージョン選択

フォーラム

メニュー

オンライン状況

80 人のユーザが現在オンラインです。 (60 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 80
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > EC-CUBE4 プラグインの有効化・インストールができません。

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
minny
投稿日時: 2019/3/13 16:54
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 41
EC-CUBE4 プラグインの有効化・インストールができません。
[EC-CUBE] EC-CUBE 4.0.2
[レンタルサーバ] heteml
[PHP] 7.1.14
[データベース] 使用しているDB名、バージョン
[WEBサーバ] 使用しているWEBサーバ名、バージョン
[ブラウザ] 使用しているブラウザ名、バージョン
[導入プラグインの有無] おすすめ商品管理プラグイン・メーカー管理プラグイン
[カスタマイズの有無] なし

[現象] EC-CUBE 4.0.2をインストール後、テンプレートはデフォルトのまま、プラグインをオーナーズストアから購入しました。
その後、管理画面を開くとプラグイン一覧に表示されているのですが、有効化とアップデートボタンがありません。
試しに管理画面から『オーナーズストアから新規追加』ボタンを押すと500エラーとなります。
各パーミッションは以下のページ通りに変更しております。


http://doc4.ec-cube.net/quickstart_install


原因おわかりになりますでしょうか。

468
投稿日時: 2019/3/13 17:52
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1873
Re: EC-CUBE4 プラグインの有効化・インストールができません。
この状態でデータベースのdtb_pluginテーブルの内容は確認できますか?


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

minny
投稿日時: 2019/3/13 17:55
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 41
Re: EC-CUBE4 プラグインの有効化・インストールができません。
コメントありがとうございます。

--

返り値が空でした (行数 0)。 (クエリの実行時間 0.0017 秒)
SELECT * FROM `dtb_plugin`

--

となっています。
468
投稿日時: 2019/3/13 18:10
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1873
Re: EC-CUBE4 プラグインの有効化・インストールができません。
>その後、管理画面を開くとプラグイン一覧に表示されているのですが、有効化とアップデートボタンがありません。
上記のプラグイン一覧とは、管理画面>オーナーズストア>プラグイン>プラグイン一覧の画面という事でよろしいですか?
オーナーズストアのプラグインのエリアに、購入したプラグインが表示されているという事でよろしいでしょうか?

あと、一度、コンテンツ管理>キャッシュ管理からキャッシュのクリアを実行されてみては如何でしょうか?


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

minny
投稿日時: 2019/3/13 18:19
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 41
Re: EC-CUBE4 プラグインの有効化・インストールができません。
>管理画面>オーナーズストア>プラグイン>プラグイン一覧の画面
はいそうです。

一覧にインストールしたプラグインが2つ表示されているのですが、『ステータス』と『アップデート』の欄か空の状態です。

キャッシュのクリアも何度か試してみましたがダメでした・・。

その他にも、商品登録はできるのに削除ができませんでした。
削除ボタンを押すと、ポップアップで『削除しました』と出るのですが、その下にシステムエラーですとなり削除されません。

その後、再インストールをしてみたのですが全く同じ状態になりました。
Ringo
投稿日時: 2019/3/14 8:33
対応状況: −−−
常連
登録日: 2018/8/10
居住地:
投稿: 70
Re: EC-CUBE4 プラグインの有効化・インストールができません。

[現象] EC-CUBE 4.0.2をインストール後、テンプレートはデフォルトのまま、プラグインをオーナーズストアから購入しました。
その後、管理画面を開くとプラグイン一覧に表示されているのですが、有効化とアップデートボタンがありません。
試しに管理画面から『オーナーズストアから新規追加』ボタンを押すと500エラーとなります。
各パーミッションは以下のページ通りに変更しております。

『オーナーズストアから新規追加』

store/plugin/api/search
になります。
ここでの「500エラー」をなんとか修正しないと「プラグインを探す」が開かない。
→「インストール」ボタンが押せない。

4からは『プラグインのインストール手順』が以下の様に変更になった様です。
1.「管理画面」の「プラグイン」の「プラグインを探す」または『オーナーズストアから新規追加』にて「プラグイン」を探す。
2.「購入」または「入手する」にて、ドメインを選択して「購入」する。
3.「インストール」ボタンになるので「インストール」する。
4.「...数分お待ちください...」の表示後「完了」ボタン画面が表示される。
5.「完了」を押すと「プラグイン一覧」に「画面遷移」し「『ステータス』と『アップデート』と「削除」「有効化・無効化」ボタンが表示される。

これを、従来通りの、先にプラグインをオーナーズストアから購入してから
「プラグイン一覧」すると、「紐付け」は完了しているが「未インストール」なので、『ステータス』と『アップデート』の欄か空の状態、「削除」「有効化・無効化」ボタン無し
となります。

先にプラグインをオーナーズストアから購入した場合は、
「プラグインを探す」または『オーナーズストアから新規追加』で「プラグイン」を表示させると
上記の「3.」の段階になる。

故、『オーナーズストアから新規追加』の「500エラー」を何とか修正しないと、上記の「3.」の段階になれない。

という状況ではないかと思います。

「500エラー」については、
eccube-4.0.2/src/Eccube/Controller/Admin/Store/OwnerStoreController.php

    public function search(Request $request, $page_no = null, Paginator $paginator)
    {
    ...

のfunction名「serch」を変更して「プラグインを探す」または『オーナーズストアから新規追加』すると「システムエラー」になるので、
「serch」の(前)後で、発生していると想定されます。

logに何らかのエラーが出力されていれば手掛かりになるのですが。


その他にも、商品登録はできるのに削除ができませんでした。
削除ボタンを押すと、ポップアップで『削除しました』と出るのですが、その下にシステムエラーですとなり削除されません。

その後、再インストールをしてみたのですが全く同じ状態になりました。

パーミッションの設定に異常が有る様に感じます。
hetemlはssh、unzipは無いのでしょうか?
あれば、eccube-4.0.2.zipをアップロードしてunzipするだけで済むはずなのですが。

追伸:
ssh,unzip出来そうです。
https://heteml.jp/support/manual/sshsetting/
minny
投稿日時: 2019/3/14 8:51
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 41
Re: EC-CUBE4 プラグインの有効化・インストールができません。
コメントありがとうございます。

失礼いたしました。
”オーナーズストアプラグインから探す”のページまでは行けるのですが、入手するを押すと500エラーとなります。

例)
store/plugin/api/install/1758/confirm

/app/Plugin/の中には、.composerというディレクトリができています。

エラーログは沢山でているのですが、抜粋するとこんなのが出ていました。

[2019-03-14 08:47:46] php.INFO [321puc7jvmbg0kfa8t4n3ofvcf] [3edd248] [1] [Symfony\Component\Debug\ErrorHandler:handleError:523] - User Deprecated: The "Eccube\Service\Composer\ComposerApiService" service is private, getting it from the container is deprecated since Symfony 3.2 and will fail in 4.0. You should either make the service public, or stop using the container directly and use dependency injection instead. {"exception":"[object] (ErrorException(code: 0): User Deprecated: The \"Eccube\\Service\\Composer\\ComposerApiService\" service is private, getting it from the container is deprecated since Symfony 3.2 and will fail in 4.0. You should either make the service public, or stop using the container directly and use dependency injection instead. at /home/users/2/ia-inc/web/epros.jp/online/vendor/symfony/dependency-injection/Container.php:282)"} [GET, /online/melissa/store/plugin/authentication_setting,

別件ですが商品の削除もできません。
会員登録→削除はできました。
テンプレートの追加もできました。

商品を削除したときのエラーログは以下でした。
(URLは途中”~”としています)

-

[2019-03-14 09:48:56] admin.INFO [321puc7jvmbg0kfa8t4n3ofvcf] [7d5d3cd] [1] [Eccube\Log\Logger:log:64] - LOGIC START ["admin_product"] [GET, /online/melissa/product, 126.243.68.194, http://~/product, Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36]
[2019-03-14 09:48:56] admin.INFO [321puc7jvmbg0kfa8t4n3ofvcf] [7d5d3cd] [1] [Eccube\Log\Logger:log:64] - LOGIC END ["admin_product"] [GET, /online/melissa/product, 126.243.68.194, http://~/product, Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36]
[2019-03-14 09:48:56] app.INFO [N/A] [7d5d3cd] [1] [Eccube\Log\Logger:log:68] - PROCESS END ["admin_product"] [GET, /online/melissa/product, 126.243.68.194, http://~//product, Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36]
468
投稿日時: 2019/3/14 9:57
対応状況: −−−
登録日: 2008/10/26
居住地:
投稿: 1873
Re: EC-CUBE4 プラグインの有効化・インストールができません。
直接関係があるか分かりませんが、
以前、サーバ側の設定でPUT/DELETEの通信が許可されておらず、
管理画面の操作が正常に完了しないという現象がありました。
https://xoops.ec-cube.net/modules/newbb/viewtopic.php?viewmode=thread&topic_id=21367&forum=11&post_id=89835#forumpost89835

ECCUBE4は、所々、GET/POST以外にPUT/DELETEでのhttp通信も行っているようです。
(商品の削除はDELETEで通信されています)


----------------
株式会社シロハチ
■ECCUBE2系、3系構築カスタマイズご相談ください。
EC-CUBE3マニュアル
blog

minny
投稿日時: 2019/3/14 10:30
対応状況: −−−
常連
登録日: 2014/6/20
居住地:
投稿: 41
Re: EC-CUBE4 プラグインの有効化・インストールができません。
Ringo様

ありがとうございます。
unzip、WINSCPで試してみましたができませんでした。
phpファイルをアップする方法と、カスタムコマンドで試してみましたがエラーとなり、方法がわかりませんでした。


468様

ありがとうございます。
EC-CUBEの.htaccessに以下追加して、キャッシュをクリアにして試してみましたがダメでした。

<Limit PUT DELETE>
Order deny,allow
Allow from all
</Limit>
nanasess
投稿日時: 2019/3/14 11:36
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 2008
Re: EC-CUBE4 プラグインの有効化・インストールができません。
有効化やインストールの PHP プロセスが高負荷だと判断され、強制終了してしまう場合があります。(OOM KIller など)
このため、ヘテムルでのインストールは難しいかもしれません。

さくらのレンタルサーバー(スタンダード)でしたら、インストール・有効化がうまくいった実績あります。


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
スキルニル株式会社

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

(1) 2 3 4 »
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

ec-cube.co

統計情報

総メンバー数は52,427名です
総投稿数は93,796件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
2008
4
468
1873
5
yuh
1610
6
red
1359
7
umebius
1343
8
h_tanaka
930
9
fukap
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
780
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.