バージョン選択

フォーラム

メニュー

オンライン状況

121 人のユーザが現在オンラインです。 (91 人のユーザが フォーラム を参照しています。)
登録ユーザ: 2
ゲスト: 119
gambmaniac kurabiz もっと...

サイト内検索

質問 > 管理機能 > プラグインがアップデートできない

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
h_tanaka
投稿日時: 2019/9/9 10:13
対応状況: −−−
仙人
登録日: 2016/7/22
居住地: 愛媛県
投稿: 907
プラグインがアップデートできない
EC-CUBE 4.0.2
クーポンプラグイン 4.0.4 → 4.0.5

プラグインをアップデートしようとしたのですが、システムエラーが発生しました。
エラーログには次のようなエラーが出ていました。
<warning>Deprecation warning: require.ec-cube/Coupon4 is invalid, it should not contain uppercase characters. Please use ec-cube/coupon4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
Failed to initialize global composer: Composer could not find the config file: /Applications/MAMP/htdocs/test/app/Plugin/.composer/composer.json

こちらの記事を試してみたのですが、次のコマンドでうまくいきませんでした。
https://qiita.com/nanasess/items/583683eb94947aebea44

$ php composer.phar dumpautoload
Could not open input file: composer.phar

その後、ソースを更新すればいけるのではないかと思い、GitHubからダウンロードしたクーポンプラグインのソースをマージしました。
https://github.com/EC-CUBE/coupon-plugin

app/Plugin/Coupon4/composer.json
で定義されているバージョンは 4.0.5 になっているのですが、プラグイン一覧ではまだ 4.0.4 のままになっています。
プラグイン一覧でプラグインのアップデートを認識させるにはどうすればよいでしょうか?
nanasess
投稿日時: 2019/9/11 9:26
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1967
Re: プラグインがアップデートできない
共有サーバーでしょうか?
サーバーによっては,古い PHP プロセスが残ったままになってしまい、更新されない場合があります。
一旦 APP_ENV=dev にしてみるとか、可能であればサーバーを再起動してみると解消されることがあります


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
スキルニル株式会社

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

h_tanaka
投稿日時: 2019/9/11 9:34
対応状況: −−−
仙人
登録日: 2016/7/22
居住地: 愛媛県
投稿: 907
Re: プラグインがアップデートできない
nanasess さん

ローカルmacOSのMAMPで実行しています。
APP_ENV=dev で実行しています。

macOS Mojave 10.14.6
MAMP Version 5.2
PHP 7.1.22


----------------
EC-CUBE 《プラチナ》ランクパートナー
トエビス株式会社 田中 宏典
EC-CUBEの機能やデザインのカスタマイズ承ります。

red
投稿日時: 2019/9/11 10:19
対応状況: −−−
登録日: 2010/2/15
居住地: 東京都
投稿: 1343
Re: プラグインがアップデートできない
こういう話じゃないですか?
https://nob-log.info/2019/08/27/mamp-pro-%e3%81%aecgi%e3%83%a2%e3%83%bc%e3%83%89%e3%81%8cidle-timeout-30-sec%e3%81%ab%e3%81%aa%e3%82%8b/


----------------
EC-CUBEのカスタマイズ、トラブル解決承ります
お気軽にお問い合わせ下さい
https://www.ec-cube.net/integrate/partner/partner.php?partner_id=690

EC-CUBE4のプラグイントラブル、調査します

nanasess
投稿日時: 2019/9/11 10:39
対応状況: −−−
登録日: 2006/9/9
居住地: 宝塚
投稿: 1967
Re: プラグインがアップデートできない
なるほど、デフォルトで30秒って短いですね。。。


----------------
大河内健太郎(Kentaro Ohkouchi)
EC-CUBE公式エバンジェリスト
スキルニル株式会社

EC-CUBE1系2系長期サポートホスティングサービス CUBE Lab
https://cubelab.info/

h_tanaka
投稿日時: 2019/9/11 11:05
対応状況: −−−
仙人
登録日: 2016/7/22
居住地: 愛媛県
投稿: 907
Re: プラグインがアップデートできない
うーん。。
プラグインのソースコードがあればバージョンアップできるかな、とも思ったのですが、うまくいかないですね。
https://github.com/EC-CUBE/ec-cube/issues/3951


----------------
EC-CUBE 《プラチナ》ランクパートナー
トエビス株式会社 田中 宏典
EC-CUBEの機能やデザインのカスタマイズ承ります。

スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

ec-cube.co

統計情報

総メンバー数は49,518名です
総投稿数は93,188件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
1967
4
468
1818
5
yuh
1602
6
red
1343
7
umebius
1296
8
fukap
907
9
h_tanaka
907
10
tsuji
856
11
shutta
835
12 ramrun 789
13
tao_s
774
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
483
20 tonton 436


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.